Subject: [Danish] DANISH BOF introductory email

From: Michael Richardson <[email-masked]>
Date: Thu, 11 Feb 2021 19:51:45 -0500

Hi, there are some 30+ people subscribed to the DANISH list now from a wide
variety of organizations.  We should start!

The BOF has been approved (the only one, I think, for IETF110), and is
scheduled for the Friday Session I (at 12:00 UTC).

The BOF chairs are Wes Hardaker and Michael Richardson.
This non-WG forming BOF was created after the secdispatch discussion at IETF109.
Some organizational meetings with the ADs and proponents will occur next
week, and I expect that this will result in a draft agenda being posted.

We have added:
 1.draft-huque-dane-client-cert-05
   TLS Client Authentication via DANE TLSA records
 2.draft-huque-tls-dane-clientid-04
   TLS Extension for DANE Client Identity
to the list of documents at https://datatracker.ietf.org/wg/danish/documents/

It is possible that there are other documents on the Datatracker which are relevant!
Please point the list to them.

There are perhaps other documents which are yet-to-be-submitted which should
also be considered.  If you are working on something but you aren't quite
ready to submit it, then please let the BOF chairs know that something is
coming.

The secdispatch meetecho record which led to this BOF can be reviewed at:
    https://youtu.be/vA2P4EkNCIQ?t=3863

A key goal of the upcoming BOF is to establish a clear problem statement.

Two areas of problem statement were mentioned in the secdispatch and
in draft-huque-dane-client-cert, namely:
  a) IoT device authentication.
  b) SMTP client authentication.

The work is also presently very TLS specific.
This is either a feature (well focused work), or a problem (desire to use it
for object security).  Your comments and thoughts welcome.

BOF-co-chairs.
Wes + Michael

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Olle E. Johansson" <[email-masked]>
Date: Fri, 12 Feb 2021 10:41:19 +0100

> On 12 Feb 2021, at 01:51, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
> 
Great!

>  b) SMTP client authentication.

I have some ideas for realtime communication - SIP and possibly some
WebRTC implementations as well. Just loose ideas, based on my earlier
draft on SIP and DANE. Would be great if a vendor of SIP devices hooked on :-)

Also work with IoT device auth, so it’s my main interest here.

Thank you for your work in bringing it to BOF!

/O

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 12 Feb 2021 13:28:16 -0500

> scheduled for the Friday Session I (at 12:00 UTC).

The agenda page shows a different time (Thursday 16:00 UTC):

    https://sandbox.ietf.org/meeting/110/agenda-utc
    https://sandbox.ietf.org/meeting/110/session/28735.ics

which is right?

-- 
    Viktor.

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 12 Feb 2021 10:44:06 -0800

> The agenda page shows a different time (Thursday 16:00 UTC):

The agenda is always right.  Until it changes, then it's right again.
-- 
Wes Hardaker
USC/ISI

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Feb 2021 21:01:16 -0500

> which is right?

So,
a) "sandbox.ietf.org" is *not* in any way authoritative :-)
   It gets an irregular (sometimes daily) copy of the production DT, with
   some changes.

b) On Friday, the agenda was formally finalized, so maybe it changed, but:

   https://datatracker.ietf.org/meeting/110/agenda.html?show=danish
and:
   https://datatracker.ietf.org/wg/danish/meetings/

concurs... so please don't use "sandbox" as a reference :-)

---

From: Michael Richardson <[email-masked]>
Date: Mon, 15 Feb 2021 11:06:14 -0500

> draft on SIP and DANE. Would be great if a vendor of SIP devices hooked on :-)

Perhaps you want to explain more, either in the form of an 
Internet-Draft, slides, or emails?

> Also work with IoT device auth, so it’s my main interest here.

Please tell us more.
m2m?
device to cloud?
within an ecosystem/vertical?
cross-vertical?
Home? Industrial? Automotive? Building?

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 16 Feb 2021 07:44:23 +0100

> On 15 Feb 2021, at 17:06, Michael Richardson <[email-masked]> wrote:
> 
> Perhaps you want to explain more, either in the form of an Internet-Draft, slides, or emails?
I just need to collect my thoughts on this, but I will certainly come up with slides
if that’s needed.
> Home? Industrial? Automotive? Building?

It’s a project with device2gateway and gateway@cloud involved. Not for homes.

We have the usual issues - establishing trust in multiple CAs, rollover of everything
from device keys to CAs. I’m a contractor and came in late, so a lot of decisions
was made early and a lot of decisions was not made in time, so it’s a bit of a 
clean up mission :-)

/O