Subject: [Detnet] Data Plane IP, OAM section

From: Balázs Varga A <[email-masked]>
Date: Mon, 20 May 2019 15:20:19 +0000

Hi,

Data plane documents are under review to prepare them for the workgroup last call.
OAM section is intended to be removed from the "DetNet Data Plane: IP" document.
https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/

Any objections?

Cheers
Bala'zs

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 20 May 2019 12:54:45 -0400

Balázs,

Sounds good, it's just a placeholder right now.

Cheers,
Andy

On Mon, May 20, 2019 at 11:20 AM Balázs Varga A <[email-masked]>
wrote:

> OAM section is intended to be removed from the “DetNet Data Plane: IP”
> document.
>
> Bala’zs
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: Loa Andersson <[email-masked]>
Date: Tue, 21 May 2019 14:53:57 +0800

Bala’zs and Andy,

I have no problem removing the OAM section from the data plane
documents.

The question I have is what do we do about the OAM for the specific
data planes, do we paln separate documents??

/Loa

On 2019-05-21 00:54, Andrew G. Malis wrote:
> On Mon, May 20, 2019 at 11:20 AM Balázs Varga A 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi,____
> 
>     __ __
> 
>     Data plane documents are under review to prepare them for the
>     workgroup last call.____
> 
>     OAM section is intended to be removed from the “DetNet Data Plane:
>     IP” document.____
> 
>     https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/____
> 
>     __ __
> 
>     Any objections?____
> 
>     __ __
> 
>     Cheers____
> 
>     Bala’zs____
> 
>     __ __
> 
>     [email-masked] <mailto:[email-masked]>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 21 May 2019 08:43:28 +0000

Hi Loa,

We have a dedicated OAM document:
https://tools.ietf.org/html/draft-mirsky-detnet-oam-02

Unfortunately not showed among the DetNet documents :--(((
https://datatracker.ietf.org/group/detnet/documents/

Cheers
Bala'zs

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Loa Andersson
Sent: Tuesday, May 21, 2019 8:54 AM
To: Andrew G. Malis <[email-masked]>; Balázs Varga A <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet] Data Plane IP, OAM section

Bala’zs and Andy,

I have no problem removing the OAM section from the data plane documents.

The question I have is what do we do about the OAM for the specific data planes, do we paln separate documents??

/Loa

--

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 21 May 2019 09:22:41 -0400

Loa,

Also note that we were only discussion one particular data plane document
(IP), not all of them. For example, there's quite a bit of discussion about
OAM in the MPLS data plane draft.

Cheers,
Andy

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 21 May 2019 10:39:09 -0700

Hi Balazs,
thank you for pointing to the OAM for DetNet draft. It lapsed and that may
be why is not showing up among other DetNet documents. Mach and I will work
on adding OAM for DetNet over IP data plane. I think it would be good to
use this document for discussion, the definition of OAM for DetNet over all
possible data plane variants. We welcome cooperation and co-authors.

Regards,
Greg

---

From: Loa Andersson <[email-masked]>
Date: Wed, 22 May 2019 14:10:47 +0800

Bala'zs,

The draft is expired, that is why it is not shown on the detnet page.
Normally  that is a sign that the interest is not that high.

Andy,

Yes - you are right, but the difference between what we are doing for
the MPLS data plane and for the IP data plane was one reason that I
asked. Also when checking the draft-mirsky it has a strong MPLS leaning.
What was removed from the data plane draft was (the little we have) on
IP OAM. draft-mirsky does not add much compared to that.

Greg,

Please revive the draft, even if you do no other changes, we need it
active. That said I'm not sure that we want ONE draft covering both
MPLS and IP OAM, it is normally a recipe for delay.

All,

Once the draft-mirsky is active again, let us decide what we want to do.
I see two alternatives

First, build on draft-mirsky and create one draft for everything.

Second, break the IP OAM out of draft-mirsky and start a new draft for
DetNet IP OAM and base the DetNet MPLS OAM in draft-mirsky.

I have a slight preference for the second alternative.

But make it a wg decision.

/Loa

On 2019-05-22 01:39, Greg Mirsky wrote:
> Hi Balazs,
> thank you for pointing to the OAM for DetNet draft. It lapsed and that 
> may be why is not showing up among other DetNet documents. Mach and I 
> will work on adding OAM for DetNet over IP data plane. I think it would 
> be good to use this document for discussion, the definition of OAM for 
> DetNet over all possible data plane variants. We welcome cooperation and 
> co-authors.
> 
> Regards,
> Greg
> 
> On Tue, May 21, 2019 at 1:43 AM Balázs Varga A 
>     From: detnet <[email-masked]
>     <mailto:[email-masked]>> On Behalf Of Loa Andersson
>     To: Andrew G. Malis <[email-masked] <mailto:[email-masked]>>;
>     Balázs Varga A <[email-masked]
>     <mailto:[email-masked]>>
>     Cc: [email-masked] <mailto:[email-masked]>
>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >     Hi,____
>      >
>      >     __ __
>      >
>      > [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     Loa Andersson                        email: [email-masked] <mailto:[email-masked]>
>     Senior MPLS Expert

--

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 22 May 2019 07:23:11 -0700

Hi Loa,
thank you for your suggestion. Will revive the draft today.
And I agree with your suggestion to discuss whether we want to have one
draft for DetNet OAM over all possible variants of the data plane.

Best regards,
Greg

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 22 May 2019 11:20:06 -0400

Greg,

As the data plane drafts have been separated to focus on each of the
individual data planes, that may be the best course of action for the OAM
drafts as well. If it turns out that there's a reasonable amount of
material that's common between the two, then there can also be a third OAM
Framework draft with the common material, again mirroring the data plane
drafts. Just a thought.

Cheers,
Andy

On Wed, May 22, 2019 at 10:23 AM Greg Mirsky <[email-masked]> wrote:

>> >      > <[email-masked] <mailto:[email-masked]
>> >

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 22 May 2019 08:35:01 -0700

Hi Andy,
thank you for sharing your opinion. I agree, having several documents that
address encapsulation of DetNei OAM in the particular data plane (MPLS,
IPv4, and IPv6 may be the reasonable number for OAM) makes a lot of sense
to me too. As Loa have pointed, the existing DetNet OAM draft is fairly
strong for MPLS data plane. If the WG and the WG Chairs agree to have
DetNet OAM encapsulation defined in several documents, we can update the
scope of draft-mirsky-detnet-oam aiming it at MPLS data plane. OAM
protocols specific to DetNet, e.g. exercising PREF, to be defined in the
separate document(s) as these should be common for all DetNet data plane
and OAM encapsulation in DetNet.

Regards,
Greg

On Wed, May 22, 2019 at 8:20 AM Andrew G. Malis <[email-masked]> wrote:

>>> >     To: Andrew G. Malis <[email-masked] <mailto:[email-masked]
>>> >>;