Subject: [Dhcpv6bis] terminology summary

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Apr 2014 20:58:48 -0400

I will post this email to the main list, according to ticket: #49.

Here is a list of terminology present in 3315:
4.1.  IPv6 Terminology
   address                   
   host                      
   IP                        
   interface                 
   link                      
   link-layer identifier     
   link-local address        
   multicast address         
   neighbor                  
   node                      
   packet
   prefix                    
   prefix length             
   router                    
   unicast address           

== (I don't think we should any change of these)

4.2.  DHCP Terminology
   appropriate to the link   
   binding                   
   configuration parameter   
   DHCP                      
   DHCP client (or client)   
   DHCP domain               
   DHCP realm                
   DHCP relay agent (or relay agent)  
   DHCP server (or server)   
   DUID                      
   Identity association (IA) 
   Identity association identifier (IAID)  
   Identity association for non-temporary addresses (IA_NA)  
   Identity association for temporary addresses (IA_TA) 
   message                   
   Reconfigure key           
   relaying                  
   transaction ID           

Here is a list of terminology present in 3633:

3.  Terminology
   requesting router
   delegating router
   Identity Association for Prefix Delegation (IA_PD)

These are in conflict:
      - there are none in conflict.

These ones might be changed:

1) I suggest that IA* be changed:

from:
   Identity association (IA) 
   Identity association identifier (IAID)  
   Identity association for non-temporary addresses (IA_NA)  
   Identity association for temporary addresses (IA_TA) 
   Identity Association for Prefix Delegation (IA_PD)

to:
   IA                   - Identity association ...
   IAID                 - Identity association identifier ...
   IA_NA                - Identity association for non-temporary addresses
   IA_TA                - Identity association for temporary addresses...
   IA_PD                - Identity Association for Prefix Delegation (IA_PD)

why? in my experience the full written out version is essentially never used,
and the acronyms have risen to the point of being full nouns on their own,
so the point where they are even spoken aloud at times like "eya-tah" (IA_TA).

2) we may want to define some additional roles, particularly for the
   PD cases where we have a DHCP server that can act as a DHCP client
   when it is a PD requesting router, and that we can have chains of them.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Leaf Yeh" <[email-masked]>
Date: Thu, 3 Apr 2014 22:24:56 +0800

1.  For the list of 4.1, most of them sounds not IPv6 terms except '
link-local address', but in fact for IP terms, how about to change to title
to be 'IP Terminology' :-).

 And even in the IP Terminology, I prefer not keep the following 3 term:
 
 address :   The definition sounds not accurate, because we have MAC (or
link-layer) address in this draft.
 ip :
 packet : 

 If we delete the whole list of IP terms, supposed the draft could still
work without doubt. 
 
 Anyway, I'd personally like to keep 'link-local IPv6 address', which sounds
important for DHCPv6.

2.  I'd like section 4.2 could be 'DHCPv6 Terminology', 

or just let those terms stay in 'Terminology' (section 4) if don't keep
'IPv6 Terminology'.

Then some terms in the list of 4.2 could be:

DHCPv6 client
DHCPv6 domain
DHCPv6 realm
DHCPv6 relay agent  
DHCPv6 server  

I personally prefer a small list of the necessary term.

For the list of 4.2, we might not need:

appropriate to the link - something in Binding for clients
configuration parameter - something in Binding for clients
DHCP - we only have DHCPv6 in this draft
IAID - Combine with IA
IA_NA - example in IA
IA_TA - example in IA
Message - no need special words on it
Relaying - combine with DHCPv6 Relay Agent

Does the above sounds a kind of picky comment?

Best Regards,
Leaf

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Michael
Richardson
Sent: Wednesday, April 02, 2014 8:59 AM
To: dhcpv6bis
Subject: [Dhcpv6bis] terminology summary

4.2.  DHCP Terminology
   appropriate to the link   
   binding                   
   configuration parameter   
   DHCP                      
   DHCP client (or client)   
   DHCP domain               
   DHCP realm                

3.  Terminology
   requesting router
   delegating router

These are in conflict:

from:

to:

why? in my experience the full written out version is essentially never
used, and the acronyms have risen to the point of being full nouns on their
own, so the point where they are even spoken aloud at times like "eya-tah"
(IA_TA).

-- 
]               Never tell me the odds!                 | ipv6 mesh networks
[ 
]   Michael Richardson, Sandelman Software Works        | network architect
[ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails
[ 

_______________________________________________
Dhcpv6bis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "Leaf Yeh" <[email-masked]>
Date: Sat, 5 Apr 2014 10:52:08 +0800

3. Per the discussion on the ML of DHC @ IETF89
(http://www.ietf.org/mail-archive/web/dhcwg/current/msg15356.html ),

I guess we don't need 

   requesting router
   delegating router

any more.

Best Regards,
Leaf

-----Original Message-----
From: Leaf Yeh [mailto:[email-masked]] 
Sent: Thursday, April 03, 2014 10:25 PM
To: 'Michael Richardson'
Cc: 'dhcpv6bis'
Subject: RE: [Dhcpv6bis] terminology summary

 

DHCPv6 client
DHCPv6 domain
DHCPv6 realm
DHCPv6 relay agent
DHCPv6 server  

appropriate to the link - something in Binding for clients configuration
parameter - something in Binding for clients DHCP - we only have DHCPv6 in
this draft IAID - Combine with IA IA_NA - example in IA IA_TA - example in
IA Message - no need special words on it Relaying - combine with DHCPv6
Relay Agent

Best Regards,
Leaf

-----Original Message-----

4.2.  DHCP Terminology
   appropriate to the link   
   binding                   
   configuration parameter   
   DHCP                      
   DHCP client (or client)   
   DHCP domain               
   DHCP realm                

3.  Terminology
   requesting router
   delegating router

These are in conflict:

from:

to:

---

From: Michael Richardson <[email-masked]>
Date: Sat, 12 Apr 2014 16:32:05 -0400

Leaf Yeh <[email-masked]> wrote:
    > link-local address', but in fact for IP terms, how about to change to
    > title to be 'IP Terminology' :-).

okay.

    > If we delete the whole list of IP terms, supposed the draft could still

I'm not sure that I agree with deleting all the terms.

    > 2.  I'd like section 4.2 could be 'DHCPv6 Terminology',

okay.

    > DHCPv6 server

So, you want to s/DHCP/DHCPv6/g

    > DHCP - we only have DHCPv6 in this draft

I found that I need those terms.

    > Does the above sounds a kind of picky comment?

please consider the person reasoning this document for the first time.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 13 Apr 2014 20:59:06 +0000

I think Michael's first pass was on target.

I don't think we should change DHCP to DHCPv6 throughout (there are currently 32 uses of "DHCPv6" and 257 of "DHCP" (which includes those 32).

I think we may need to through and clean this up as many of those "DHCPv6" references were added with the SOL_MAX/INF_MAX text inclusion.

I think sticking to DHCP is fine as the context in this DHCPv6 document is clear.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Saturday, April 12, 2014 4:32 PM
To: Leaf Yeh
Cc: 'dhcpv6bis'
Subject: Re: [Dhcpv6bis] terminology summary

okay.

okay.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: "Leaf Yeh" <[email-masked]>
Date: Mon, 14 Apr 2014 10:21:34 +0800

Bernie - I think Michael's first pass was on target... sticking to DHCP is
fine as the context in this DHCPv6 document is clear.

That sounds you want changes in BIS as minimal as possible. :-)

Best Regards,
Leaf

-----Original Message-----
From: Bernie Volz (volz) [mailto:[email-masked]] 
Sent: Monday, April 14, 2014 4:59 AM
To: Michael Richardson; Leaf Yeh
Cc: 'dhcpv6bis'
Subject: RE: [Dhcpv6bis] terminology summary

I don't think we should change DHCP to DHCPv6 throughout (there are
currently 32 uses of "DHCPv6" and 257 of "DHCP" (which includes those 32).

I think we may need to through and clean this up as many of those "DHCPv6"
references were added with the SOL_MAX/INF_MAX text inclusion.

I think sticking to DHCP is fine as the context in this DHCPv6 document is
clear.

- Bernie

-----Original Message-----

okay.

okay.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -=
IPv6 IoT consulting =-

---

From: "Leaf Yeh" <[email-masked]>
Date: Mon, 14 Apr 2014 10:28:58 +0800

Leaf -     

    > Relaying - combine with DHCPv6 Relay Agent

Michael - I'm not sure that I agree with deleting all the terms... please
consider the person reasoning this document for the first time.

I guess the only reason here might be for how easy to read the document.

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
Richardson
Sent: Sunday, April 13, 2014 4:32 AM
To: Leaf Yeh
Cc: 'dhcpv6bis'
Subject: Re: [Dhcpv6bis] terminology summary

okay.

okay.

---

From: Marcin Siodelski <[email-masked]>
Date: Mon, 14 Apr 2014 10:30:14 +0200

Yes. I will go over the text and modify as suggested.

Thanks for catching it.

Marcin

---

From: Marcin Siodelski <[email-masked]>
Date: Mon, 14 Apr 2014 14:19:01 +0200

In the rfc3315bis.xml, I replaced 'DHCPv6' with 'DHCP' in the text that
has been added with the merge of SOL_MAX_RT and INF_MAX_RT

Marcin