Subject: [Dhcpv6bis] dashes in symbolic names

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Aug 2014 09:10:48 -0400

I'm putting DHCPv6 option and message type names into a new implementation.
Except for:

      INFORMATION-REQUEST   11
      RELAY-FORW            12
      RELAY-REPL            13

      DUID-LLT              1
      DUID-EN               2
      DUID-LL               3

all the rest of the symbolic constants are free of "-", and are valid
    C,C++,C#,SmallTalk,Ruby,Pythhon,Java,Javascript constants.

I realize that IANA already has the values with the - in them, but given that
we are not consistent in use of - vs _ in the symbols, would there be
objection to asking IANA to normalize them to _?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ralph Droms <[email-masked]>
Date: Tue, 19 Aug 2014 10:41:08 -0400

> objection to asking IANA to normalize them to _?

Seems like a reasonable request to me.

- Ralph

> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 19 Aug 2014 15:35:26 +0000

In our code, we just replace - with _.

These definitions are for human readable text so I'm not sure it is a big deal to use - instead of _.

But open a ticket and we can discuss and then perhaps contact IANA.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Tuesday, August 19, 2014 9:11 AM
To: dhcpv6bis
Subject: [Dhcpv6bis] dashes in symbolic names

      INFORMATION-REQUEST   11
      RELAY-FORW            12
      RELAY-REPL            13

      DUID-LLT              1
      DUID-EN               2
      DUID-LL               3

I realize that IANA already has the values with the - in them, but given that we are not consistent in use of - vs _ in the symbols, would there be objection to asking IANA to normalize them to _?

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-