Subject: [Dhcpv6bis] My notes from 4/22 meeting

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 22 Apr 2015 13:48:24 +0000

The agenda is:

- Review currently assigned tickets (why not done & is reassignment  needed). See http://trac.tools.ietf.org/group/dhcpv6bis/report/4.

Ticket 86 & 91 – Changed to remove Delayed Auth Protocol. Need to follow up with Michael on whether he will do this or if we need to assign. Marcin closed #91 (there is a belief that there is no issue with this text even if it stayed).
Ticket 127 - Ted to check with Tim Winters whether Tim will do this or whether Ted will take on ticket.
Ticket 102 - Ongoing issue to finish adding Prefix Delegation text and balance it with Address Assignment. Leave assigned to Bernie.
Ticket 114 - Bernie needs to follow up with WG on the issues.
Ticket 132 – Issue to deal with near end when we finalize terminology. Leave assigned to Bernie.

- Update tickets based on IETF-92 Dallas discussion (see http://www.ietf.org/mail-archive/web/dhcwg/current/msg16480.html) and assign tickets as needed.  Tickets 142, 144, 81, 17, 58, 82, 114, 70, 86 were included in this discussion.

Ticket 142 – Leave unassigned for now. Likely to be assigned to Tomek/Marcin at a later time (once stateful issues merged)
Ticket 144 – Assigned to Sheng. (Ignoring unknown options should apply to Server, Relay Agent, Clients!! Not just servers.)
Ticket 81 – Assign to Ted. Ted to develop IANA instructions for adding column to option table about “required in ORO”. Discussed that we should require clients to include all options it wants but servers don’t need to remove options. Discussion was pending at time I had to depart. NOTE: We need to take to the ML before we finalize on this issue (whichever way it goes).

** My notes stopped here.

- Assign stateful issues tickets (59, 60, 61, 62, 63, 64, 64, 66).
- Review other unassigned tickets and assign if ready, or initiate discussion on DHC WG mailing list to finalize consensus if needed.
- Any other business?

---

From: Tomek Mrugalski <[email-masked]>
Date: Wed, 22 Apr 2015 18:22:24 +0200

On 22.04.2015 15:48, Bernie Volz (volz) wrote:
> The agenda is: 
> 
> - Review currently assigned tickets (why not done & is reassignment 
> needed). See _http://trac.tools.ietf.org/group/dhcpv6bis/report/4_.
> 
> Ticket 86 & 91 – Changed to remove Delayed Auth Protocol. Need to follow
> up with Michael on whether he will do this or if we need to assign.
> Marcin closed #91 (there is a belief that there is no issue with this
> text even if it stayed).
> Ticket 102 - Ongoing issue to finish adding Prefix Delegation text and
> balance it with Address Assignment. Leave assigned to Bernie.
> - Update tickets based on IETF-92 Dallas discussion
> (see _http://www.ietf.org/mail-archive/web/dhcwg/current/msg16480.html_)
> and assign tickets as needed.  Tickets 142, 144, 81, 17, 58, 82, 114,
> 70, 86 were included in this discussion.
> 
> Ticket 142 – Leave unassigned for now. Likely to be assigned to
> Tomek/Marcin at a later time (once stateful issues merged)
> Ticket 144 – Assigned to Sheng. (Ignoring unknown options should apply
> to Server, Relay Agent, Clients!! Not just servers.)
> Ticket 81 – Assign to Ted. Ted to develop IANA instructions for adding
> column to option table about “required in ORO”. Discussed that we should
> require clients to include all options it wants but servers don’t need
> to remove options. Discussion was pending at time I had to depart. NOTE:
> We need to take to the ML before we finalize on this issue (whichever
> way it goes).
> 

We had a related discussion on how to request options. Ted brought up
the map-dhcp draft (softwires work), currently is in RFC Ed queue. Ted
will send msg regarding map-dhcp to the responsible AD (Terry/Brian)
about necessary changes. That is unfortunate, as the change may possible
require consensus in both DHC *and* Softwires.

Marcin will take #18.

There was a very long discussion about addresses and prefix length on
DHC list recently. The consesus remains unchanged, though. Addresses and
prefix lengths are distinct concepts, but most APIs require specifying a
prefix length when adding an address. The best would be to configure
just an address, but if the OS API requires a prefix length, an address
should be added with /128 length in that case. Ted will propose
appropriate text in #68.

Andrew will take #82.

#114 is still assigned to Bernie. Bernie is expected to continue working
on it.

There's nothing to do wrt to #70. Tomek will close the ticket.

Marcin will ask Michael about #86, if busy, will take over. The ticket
became rather easy to deal with - the solution is to deprecate delayed
auth by removing the whole text related to it.

3. Assign stateful issues tickets (59, 60, 61, 62, 63, 64, 64, 66).
Marcin will take a lead on this and will reassign some tickets to Tomek.
Others are more than welcome to pick unassigned tickets if they have
more time to dedicate.

4. Review other unassigned tickets and assign if ready, or initiate
discussion on DHC WG mailing list to finalize consensus if needed.
We skipped reviewing other tickets, as everyone seems to have enough
work to do.

5. Any other business?
We had a brief discussion that it doesn't make sense to meet in 2 week.
The May meeting is thus cancelled.

We reiterated the desire to use jitsi, if possible. Will do it the next
time. Marcin mentioned that the third alternative is to use ISC phone
bridge, which has US number. Tomek and Marcin will check whether it's
possible to connect using voip/sip.

Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 22 Apr 2015 20:26:17 +0000

> The May meeting is thus cancelled.

I sent cancellation. So the next meeting is the first Wed in June.

>We reiterated the desire to use jitsi, if possible. Will do it the next time.
>Marcin mentioned that the third alternative is to use ISC phone bridge,
>which has US number. Tomek and Marcin will check whether it's

I can also set up WebEx. WebEx does have global dial-in numbers - not sure if that is better than just a US number (see
http://cisco.com/en/US/about/doing_business/conferencing/index.html for list). But, hopefully we can get Jitsi to work. Next time, it is just me that has issues, I can always disconnect from VPN as I usually do this call from home (today I had to do it from the office since I had to be in office for 9 AM meeting).

I guess I wasn't assigned any other tickets? Maricn - let me know if you want me to do some of the Stateful issues ones.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Wednesday, April 22, 2015 12:22 PM
To: [email-masked]
Subject: Re: [Dhcpv6bis] My notes from 4/22 meeting

On 22.04.2015 15:48, Bernie Volz (volz) wrote:
> Ticket 86 & 91 - Changed to remove Delayed Auth Protocol. Need to 
> follow up with Michael on whether he will do this or if we need to assign.
> Ticket 132 - Issue to deal with near end when we finalize terminology.
> Leave assigned to Bernie.
> 
> 
> - Update tickets based on IETF-92 Dallas discussion (see 
> _http://www.ietf.org/mail-archive/web/dhcwg/current/msg16480.html_)
> Ticket 142 - Leave unassigned for now. Likely to be assigned to 
> Tomek/Marcin at a later time (once stateful issues merged) Ticket 144 
> - Assigned to Sheng. (Ignoring unknown options should apply to Server, 
> Relay Agent, Clients!! Not just servers.) Ticket 81 - Assign to Ted. 
> Ted to develop IANA instructions for adding column to option table 
> about "required in ORO". Discussed that we should require clients to 
> include all options it wants but servers don't need to remove options. 
> Discussion was pending at time I had to depart. NOTE:

We had a related discussion on how to request options. Ted brought up the map-dhcp draft (softwires work), currently is in RFC Ed queue. Ted will send msg regarding map-dhcp to the responsible AD (Terry/Brian) about necessary changes. That is unfortunate, as the change may possible require consensus in both DHC *and* Softwires.

Marcin will take #18.

There was a very long discussion about addresses and prefix length on DHC list recently. The consesus remains unchanged, though. Addresses and prefix lengths are distinct concepts, but most APIs require specifying a prefix length when adding an address. The best would be to configure just an address, but if the OS API requires a prefix length, an address should be added with /128 length in that case. Ted will propose appropriate text in #68.

Andrew will take #82.

#114 is still assigned to Bernie. Bernie is expected to continue working on it.

Marcin will ask Michael about #86, if busy, will take over. The ticket became rather easy to deal with - the solution is to deprecate delayed auth by removing the whole text related to it.

3. Assign stateful issues tickets (59, 60, 61, 62, 63, 64, 64, 66).
Marcin will take a lead on this and will reassign some tickets to Tomek.
Others are more than welcome to pick unassigned tickets if they have more time to dedicate.

4. Review other unassigned tickets and assign if ready, or initiate discussion on DHC WG mailing list to finalize consensus if needed.
We skipped reviewing other tickets, as everyone seems to have enough work to do.

5. Any other business?

We reiterated the desire to use jitsi, if possible. Will do it the next time. Marcin mentioned that the third alternative is to use ISC phone bridge, which has US number. Tomek and Marcin will check whether it's possible to connect using voip/sip.

Tomek

_______________________________________________
Dhcpv6bis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcpv6bis