Subject: [Dhcpv6bis] pushed my branch

From: Michael Richardson <[email-masked]>
Date: Wed, 01 Mar 2017 09:31:19 -0500

<#part sign=pgpmime>

I rebased my branch upon master, and pushed the result.
I hope I haven't mangled any text.  At lease xml2rfc is happy.

I think that I managed to remove duplicates, etc.  I haven't dealt with the
things in my email that I didn't know how to edit about.

I shall review/reply to my email and look back at the text again.
There were some substantial questions in my email.
(I shall be spending the day trying to get to zero inbox)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 1 Mar 2017 15:00:48 +0000

Michael:

At least in one case, these changes added back “IPv6” before address. In general, we took steps to REMOVE IPv6 as it should be obvious and redundant. We also tended to use DHCP instead of DHCPv6. And, made sure to use “leases” instead of just “addresses” in a lot of text that came from 3315 (in some cases we say addresses and delegated prefixes). You might want to check those usages and clean them up.

This is always the difficult part of doing “bulk” cleanups of these kinds of issues while the document is still in flux and having a team of “writers” – they have to be redone periodically as the “old” usage patterns creep back in (or we properly fail to communicate them to the team).

It also seems you decided to add DUID-UUID where we had decided to reference that RFC instead.

- Bernie

On 3/1/17, 9:31 AM, "Dhcpv6bis on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

    <#part sign=pgpmime>

    

    
    _______________________________________________
    Dhcpv6bis mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 1 Mar 2017 15:07:06 +0000

Here’s another odd one:

      <t>DHCP servers SHOULD examine the TTL as part of determining if the
      client sending the message is on-link.  See <!-- xref target="TTL" /-->.</t>

This will leave “See.” In the document?

What is this about TTL???? (Time to live?) This was added in Section 14. I don’t under what TTL is and why a server would ever care to check whatever this is?

- Bernie

    <#part sign=pgpmime>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 01 Mar 2017 20:14:24 -0500

> What is this about TTL???? (Time to live?) This was added in Section
    > 14. I don’t under what TTL is and why a server would ever care to check
    > whatever this is?

Yeah. I think that I commented out the xref because it didn't point anywhere!
As far as I can see, it was there before.  Maybe I'm mistaken.
Maybe I intended that we have some discussion about what the TTL is supposed
to be?

At least we have nice commits that can easily be revert :-)

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 2 Mar 2017 03:49:00 +0000

Perhaps you meant "hop limit"? The IPv6 header field is that name, replaces IPv4 TTL.

I disagree with this as servers do not have access to the original IPv6 header (perhaps the advanced socket API provides a mechanism to obtain this), but I see no value in this.

Let's remove this text.

- Bernie (from iPad)

> On Mar 1, 2017, at 8:14 PM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 6 Mar 2017 19:13:48 +0000

Hi:

I made some cleaned ups to the text pushed (so I think what is there now is great). Also did a few other items (assigned to me) and a few cleanups.

I still have a few TODO items left on the big sheet to do ... hopefully will continue to work away at them to complete mine by end of this week.

Reminder that we plan to published the 07 by the IETF-98 deadline (3/13).

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Wednesday, March 01, 2017 10:49 PM
To: Michael Richardson <[email-masked]>
Cc: dhcpv6bis <[email-masked]>
Subject: Re: [Dhcpv6bis] pushed my branch

Let's remove this text.

- Bernie (from iPad)

>> Here's another odd one:
>> This will leave "See." In the document?
> 
>> 14. I don't under what TTL is and why a server would ever care to check
>> whatever this is?
>