Subject: [Dhcpv6bis] Fwd: [v6ops] New Version Notification for draft-hilliard-v6ops-host-addr-update-00.txt

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 20 Jul 2017 12:35:35 +0000

Hi:

For -10, should we consider making this (see below) a SHOULD:

3315bis-09 does not recommend this, it says the client MAY do it and MUST rate-limit it (with an example rate-limit of one every 30 seconds).

In any case, the server still needs to keep track

Also, while this is true, do we think that is a serious issue? How frequently are network prefixes changed? With v6 they are probably more stable than they have been for v4. So likely a false argument.

- Bernie (from iPhone)

Begin forwarded message:

From: Lorenzo Colitti <[email-masked]<mailto:[email-masked]>>
Date: July 20, 2017 at 11:42:56 AM GMT+2
To: "Bernie Volz (volz)" <[email-masked]<mailto:[email-masked]>>
Cc: Tore Anderson <[email-masked]<mailto:[email-masked]>>, james woodyatt <[email-masked]<mailto:[email-masked]>>, IPv6 Operations <[email-masked]<mailto:[email-masked]>>
Subject: Re: [v6ops] New Version Notification for draft-hilliard-v6ops-host-addr-update-00.txt

On Thu, Jul 20, 2017 at 11:23 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
>> What if the topology change was such that the global address of the DHCPv6 server is no longer valid due to renumbering?

Address of DHCPv6 server does not matter - it can change. Clients generally never directly address packets to its address. They multicast to fe02::1:2.

Surely the RECONFIGURE is not multicast, but unicast from server to client?

Also, 3315bis recommends that clients refresh information via dhcp when a network change occurs (such as new prefixes in an RA appear).

3315bis-09 does not recommend this, it says the client MAY do it and MUST rate-limit it (with an example rate-limit of one every 30 seconds).

In any case, the server still needs to keep track of all topology changes in order to give a correct answer.

---

From: Timothy Winters <[email-masked]>
Date: Thu, 20 Jul 2017 08:40:13 -0400

Hi Bernie,

Yes I was thinking the same thing, probably a SHOULD.

The story that I hear about this roaming on wireless-type network.

~Tim

On Thu, Jul 20, 2017 at 8:35 AM, Bernie Volz (volz) <[email-masked]> wrote:

> 3315bis-09 does not recommend this, it says the client MAY do it and MUST
> rate-limit it (with an example rate-limit of one every 30 seconds).
>
>
> Also, while this is true, do we think that is a serious issue? How
> frequently are network prefixes changed? With v6 they are probably more
> stable than they have been for v4. So likely a false argument.
>
> - Bernie (from iPhone)
>
> Begin forwarded message:
>
> *From:* Lorenzo Colitti <[email-masked]>
> *Date:* July 20, 2017 at 11:42:56 AM GMT+2
> *To:* "Bernie Volz (volz)" <[email-masked]>
> *Cc:* Tore Anderson <[email-masked]>, james woodyatt <[email-masked]>, IPv6
> Operations <[email-masked]>
> *Subject:* *Re: [v6ops] New Version Notification for
> draft-hilliard-v6ops-host-addr-update-00.txt*
>
> On Thu, Jul 20, 2017 at 11:23 AM, Bernie Volz (volz) <[email-masked]>
> wrote:
>
>> >> What if the topology change was such that the global address of the
>> DHCPv6 server is no longer valid due to renumbering?
>>
>> Address of DHCPv6 server does not matter - it can change. Clients
>> generally never directly address packets to its address. They multicast to
>> fe02::1:2.
>>
>
>> Also, 3315bis recommends that clients refresh information via dhcp when a
>> network change occurs (such as new prefixes in an RA appear).
>>
>
> 3315bis-09 does not recommend this, it says the client MAY do it and MUST
> rate-limit it (with an example rate-limit of one every 30 seconds).
>
> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcpv6bis
>
>

-- 

Now offering testing for SDN applications and controllers in our SDN switch
test bed. Learn more today http://bit.ly/SDN_IOLPR

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 20 Jul 2017 13:03:23 +0000

Ok. Will plan to update draft to change.

Also, not sure if the rate limit example of once every 30 seconds should be tweaked?

- Bernie (from iPhone)

On Jul 20, 2017, at 2:40 PM, Timothy Winters <[email-masked]<mailto:[email-masked]>> wrote:

Hi Bernie,

~Tim

On Thu, Jul 20, 2017 at 8:35 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
Hi:

- Bernie (from iPhone)

Begin forwarded message:

_______________________________________________
Dhcpv6bis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcpv6bis

--

Now offering testing for SDN applications and controllers in our SDN switch test bed. Learn more today http://bit.ly/SDN_IOLPR

---

From: Timothy Winters <[email-masked]>
Date: Thu, 20 Jul 2017 09:08:53 -0400

I think that's the text from the rate limiting in other Sections?   I'm
also fine going silent on the time and just say rate-limiting.

~Tim

On Thu, Jul 20, 2017 at 9:03 AM, Bernie Volz (volz) <[email-masked]> wrote:

> On Jul 20, 2017, at 2:40 PM, Timothy Winters <[email-masked]> wrote:
>
> Hi Bernie,
>
>>> Also, 3315bis recommends that clients refresh information via dhcp when
>>> a network change occurs (such as new prefixes in an RA appear).
>>>
>>
> Now offering testing for SDN applications and controllers in our SDN
> switch test bed. Learn more today http://bit.ly/SDN_IOLPR
>
>

--