Subject: [dns-privacy] I-D Action: draft-ietf-dprive-dnsoquic-09.txt

From: [email-masked]
Date: Tue, 08 Feb 2022 10:38:29 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS PRIVate Exchange WG of the IETF.

        Title           : DNS over Dedicated QUIC Connections
        Authors         : Christian Huitema
                          Sara Dickinson
                          Allison Mankin
	Filename        : draft-ietf-dprive-dnsoquic-09.txt
	Pages           : 33
	Date            : 2022-02-08

Abstract:
   This document describes the use of QUIC to provide transport privacy
   for DNS.  The encryption provided by QUIC has similar properties to
   that provided by TLS, while QUIC transport eliminates the head-of-
   line blocking issues inherent with TCP and provides more efficient
   packet loss recovery than UDP.  DNS over QUIC (DoQ) has privacy
   properties similar to DNS over TLS (DoT) specified in RFC7858, and
   latency characteristics similar to classic DNS over UDP.  This
   specification describes the use of DNS over QUIC as a general-purpose
   transport for DNS and includes the use of DNS over QUIC for stub to
   recursive, recursive to authoritative, and zone transfer scenarios.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsoquic/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-dprive-dnsoquic-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dprive-dnsoquic-09

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 9 Feb 2022 10:09:17 +0000

Hi All, 

This update attempts to address the comments we received in IETF Last Call (thanks to all that provided comments):

* Return RFC 8467 to a normative reference after more discussion on padding policies
* Update details of text on port allocation of 853 after discussion with IANA
* Update to security considerations with additional references and text on recursive to auth, zone transfer and general DNS/QUIC security.
* Clarify text on stream usage
* Various typos fixed

Note that we tried to address the Secdir review via this PR which contains some discussion of the points raised: https://github.com/huitema/dnsoquic/pull/145. If there are additional changes needed for this review please let us know by providing text (a PR or new issue in the same repo is welcome). 

Best regards

Sara. 

> On 8 Feb 2022, at 18:38, [email-masked] wrote:
> 
> 
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy