Subject: [Doh] DOH in Node.js + interop help wanted

From: Sebastiaan Deckers <[email-masked]>
Date: Thu, 27 Sep 2018 18:51:12 +0800

Hi DOH list,

Thanks for the feedback last week (Re: POST and GET).

My friend and I implemented a DOH middleware for Node.js.

https://github.com/qoelet/playdoh

Feel free to use https://commons.host as an endpoint. It's a public
uncensored anonymous DOH-only resolver running our implementation on ~20
PoPs worldwide. YMMV.

Notes:
- Draft-14
- Pathname/domain are ignored
- Accept: application/dns-message
- HTTP/2 only (Is this a spec violation?)

It seems to work okay with Firefox (Nightly/64). Is there a list of DOH
clients or test suites for interop?

Feedback appreciated.

Regards,
Sebastiaan

---

From: Daniel Stenberg <[email-masked]>
Date: Thu, 27 Sep 2018 13:05:40 +0200 (CEST)

> clients or test suites for interop?

There's a small attempt to maintain an inoffcial list here:

https://github.com/curl/curl/wiki/DNS-over-HTTPS#supported-in-browsers-and-clients

-- 

  / daniel.haxx.se

---

From: manu tman <[email-masked]>
Date: Thu, 27 Sep 2018 08:34:50 -0700

> https://github.com/curl/curl/wiki/DNS-over-HTTPS#supported-in-browsers-and-clients

Frank Denis also maintain a list of (not DoH only) implementations
https://dnscrypt.info/implementations

As much as test suite, I had played with such idea during IETF 101 and
should have a branch locally, it was against version 04 of the draft. I
will try to find it back and push it to github so you can start playing
with it.

>
> <https://github.com/curl/curl/wiki/DNS-over-HTTPS#supported-in-browsers-and-clients>
>
> --
>
>   / daniel.haxx.se
>
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>