Subject: Re: [Doh] [Ext] [Technical Errata Reported] RFC8484 (5603)

From: Paul Hoffman <[email-masked]>
Date: Tue, 15 Jan 2019 22:10:50 +0000

I agree with this erratum.

--Paul Hoffman

> On Jan 15, 2019, at 2:09 PM, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC8484,
> "DNS Queries over HTTPS (DoH)".
> 
> --------------------------------------
> You may review the report below and at:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__www.rfc-2Deditor.org_errata_eid5603&d=DwIBaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=yvHk3BrvY-tKWGRmaFbQS1aHXNfQjC40fPfI5u1VsFs&m=VzLcVlbkdAIA49v98uw454RaR0ztfEM47wd9oJ041fA&s=_dbZ0_XVEL_UmId-dnaukR70mWZx3XP4MKQ2blvNYf4&e=
> 
> --------------------------------------
> Type: Technical
> Reported by: Carsten Bormann <[email-masked]>
> 
> Section: 4.1
> 
> Original Text
> -------------
>   The URI Template defined in this document is processed without any
>   variables when the HTTP method is POST.  When the HTTP method is GET,
>   the single variable "dns" is defined as the content of the DNS
>   request (as described in Section 6), encoded with base64url
>   [RFC4648].
> 
> 
> Corrected Text
> --------------
>   The URI Template defined in this document is processed without any
>   variables when the HTTP method is POST.  When the HTTP method is GET,
>   the single variable "dns" is defined as the content of the DNS
>   request (as described in Section 6), encoded with base64url
>   [RFC4648]. Padding characters for base64url MUST NOT be included.
> 
> 
> Notes
> -----
> Note that Section 6 does say the same thing for a different usage of base64url, and note that the examples in 4.1.1 even explicitly state this, but the text that states the usual deviation from the default of RFC 4648 should be in the defining part as well.  (This is almost, but not quite, an editorial erratum.)
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC8484 (draft-ietf-doh-dns-over-https-14)
> --------------------------------------
> Title               : DNS Queries over HTTPS (DoH)
> Publication Date    : October 2018
> Author(s)           : P. Hoffman, P. McManus
> Category            : PROPOSED STANDARD
> Source              : DNS Over HTTPS
> Area                : Applications and Real-Time
> Stream              : IETF
> Verifying Party     : IESG

---

From: RFC Errata System <[email-masked]>
Date: Tue, 15 Jan 2019 14:09:19 -0800 (PST)

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5603

Section: 4.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------