Subject: [Doh] gethostbyname?

From: Fred Baker <[email-masked]>
Date: Tue, 26 Mar 2019 10:35:19 +0100

I have a silly question. In section 4, the draft goes to the API level to specify how to resolve a domain name. gethostbyname was deprecated in favor of getaddrinfo (and therefore IPv6 capability) in 1999 (RFC 2553), and is now found in all common OS's including Linux, FreeBSD, Windows, MacOSX, and so on. A reference to gethostbyname in this draft comes across as ignorant at best, perhaps deliberately so.

What do we need to do to drag the authors into the current century?

---

From: Ben Schwartz <[email-masked]>
Date: Tue, 26 Mar 2019 07:26:49 -0400

Please avoid casting aspersions on other working group participants, even
in jest, as it might be misconstrued and cause offense.

On Tue, Mar 26, 2019 at 5:35 AM Fred Baker <[email-masked]> wrote:

> I have a silly question. In section 4, the draft goes to the API level to
> specify how to resolve a domain name. gethostbyname was deprecated in favor
> of getaddrinfo (and therefore IPv6 capability) in 1999 (RFC 2553), and is
> now found in all common OS's including Linux, FreeBSD, Windows, MacOSX, and
> so on. A reference to gethostbyname in this draft comes across as ignorant
> at best, perhaps deliberately so.
>
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>