Subject: [Doh] Working Group Session Agenda @ Prague

From: Dave Lawrence <[email-masked]>
Date: Wed, 13 Mar 2019 11:17:08 -0400

* Note Well
  https://www.ietf.org/about/note-well/

* draft-ietf-doh-resolver-associated-doh, Paul Hoffman, 30 minutes
  https://datatracker.ietf.org/doc/draft-ietf-doh-resolver-associated-doh/

* draft-livingood-doh-implementation-risks-issues, Jason Livingood, 10
  minutes
    https://datatracker.ietf.org/doc/draft-livingood-doh-implementation-risks-issues

* draft-reid-doh-operator, Jim Reid, 10 minutes
  https://datatracker.ietf.org/doc/draft-reid-doh-operator/

* Open discussion

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 13 Mar 2019 18:02:10 -0400

Given the volume of discussion on-list about the latter two talks, and the absence of any significant time for open discussion, what do you expect us to gain from this session?  I fully support spending the bulk of the time here on resolver-associated, but I'm concerned that having the same presentation given twice in the balance of time.  It could be three if you wanted to use the last 10 minutes on draft-bertola-bcp-doh-clients. 

Having a clear goal in mind might help this be a productive use of time; and - if I might suggest - a shorter period of presentation (maybe Jim can negotiate with his co-author) followed by a very narrowly scoped discussion would be useful.  There are lots of different concerns in these drafts, but maybe we can find one key point to concentrate on.  I don't see us being able to settle one, let alone two, but we might get further into a single topic. 

If I were to offer a suggestion for that topic, I'd want to talk a little about the indistinguishability characteristics of DoH as distinct from DoT.  And the operational consequences of the same.  That seems well within the remit of this group.

On Thu, Mar 14, 2019, at 02:17, Dave Lawrence wrote:
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>

---

From: Jim Reid <[email-masked]>
Date: Thu, 14 Mar 2019 14:23:16 +0000

> On 13 Mar 2019, at 22:02, Martin Thomson <[email-masked]> wrote:
> 

Martin, I’ll be happy to work with Jason and the WG co-chairs so we all make the most productive use of the WG time in Prague.

However it seems unlikely there would be "the same presentation given twice” even if that discussion didn’t take place. The two drafts are very different, albeit with some overlap. And maybe that overlapping material (bypass concerns mostly?) should get moved into yet another draft which might well end up being for another WG.

draft-livingood-doh-implementation-risks-issues and draft-reid-doh-operator discuss quite distinct aspects of the impact of DoH deployment/uptake. IMO both should be considered separately by the WG. It would be a pity if they were somehow smashed together into a single discussion topic for Prague. If that did happen, I fear the discussion would lack focus and probably be inconclusive.

I think the questions to resolve at the WG are:

1) Are the issues identified in draft-livingood-doh-implementation-risks-issues valid/reasonable and does the WG want to work on them?
2) Are the issues identified in draft-reid-doh-operator valid/reasonable and does the WG want to work on them?

And if the answers to q1 or q2 are no, the followup question would be:
	what, if anything, needs to be done to the draft(s) to make them WG compatible?

It would be good if further discussion on the list focused on these 2 or 3 questions.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 14 Mar 2019 08:36:48 -0700

On Thu, Mar 14, 2019 at 7:23 AM Jim Reid <[email-masked]> wrote:

> > Given the volume of discussion on-list about the latter two talks, and
> the absence of any significant time for open discussion, what do you expect
> us to gain from this session?  I fully support spending the bulk of the
> time here on resolver-associated, but I'm concerned that having the same
> presentation given twice in the balance of time.  It could be three if you
> wanted to use the last 10 minutes on draft-bertola-bcp-doh-clients.
> >
> > Having a clear goal in mind might help this be a productive use of time;
> and - if I might suggest - a shorter period of presentation (maybe Jim can
> negotiate with his co-author) followed by a very narrowly scoped discussion
> would be useful. There are lots of different concerns in these drafts, but
> maybe we can find one key point to concentrate on.  I don't see us being
> able to settle one, let alone two, but we might get further into a single
> topic.
>
> Martin, I’ll be happy to work with Jason and the WG co-chairs so we all
> make the most productive use of the WG time in Prague.
>
> However it seems unlikely there would be "the same presentation given
> twice” even if that discussion didn’t take place. The two drafts are very
> different, albeit with some overlap. And maybe that overlapping material
> (bypass concerns mostly?) should get moved into yet another draft which
> might well end up being for another WG.
>
> draft-livingood-doh-implementation-risks-issues and
> draft-reid-doh-operator discuss quite distinct aspects of the impact of DoH
> deployment/uptake. IMO both should be considered separately by the WG. It
> would be a pity if they were somehow smashed together into a single
> discussion topic for Prague. If that did happen, I fear the discussion
> would lack focus and probably be inconclusive.
>
> 1) Are the issues identified in
> draft-livingood-doh-implementation-risks-issues valid/reasonable and does
> the WG want to work on them?

>         what, if anything, needs to be done to the draft(s) to make them

Given the extraordinary amount of discussion there has already been
on-list, it's hard to imagine how we could possibly resolve these in 10
minutes each.

-Ekr

---

From: Jim Reid <[email-masked]>
Date: Thu, 14 Mar 2019 15:46:39 +0000

> On 14 Mar 2019, at 15:36, Eric Rescorla <[email-masked]> wrote:
> 
> Given the extraordinary amount of discussion there has already been on-list, it's hard to imagine how we could possibly resolve these in 10 minutes each.

True. That’s why I suggested having focused discussions about them on the list. The discussions to date have gone off at a tangent (or two).

Here’s what I suggested earlier today:

I hope the WG can concentrate on these questions in the run-up to Prague.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 14 Mar 2019 09:47:24 -0700

On Thu, Mar 14, 2019 at 8:46 AM Jim Reid <[email-masked]> wrote:

> True. That’s why I suggested having focused discussions about them on the
> list. The discussions to date have gone off at a tangent (or two).
>

That seems.... optimistic... but in any case, that still calls into
question why we need 20 min of presentation time followed by effectively no
time for discussion.

-Ekr

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 14 Mar 2019 18:07:18 +0000

Yeah, it’s a tight timeline for sure. I know for my slides (I just did a 1st draft) I’d talk for 2 – 3 mins and the rest can be Q&A. I could envision a scenario where Jim and I do our slides back-to-back, allowing for 10-15 mins of discussion on the two.

From: Doh <[email-masked]> on behalf of Eric Rescorla <[email-masked]>
Date: Thursday, March 14, 2019 at 12:48 PM
To: Jim Reid <[email-masked]>
Cc: DoH WG <[email-masked]>
Subject: Re: [Doh] Working Group Session Agenda @ Prague

On Thu, Mar 14, 2019 at 8:46 AM Jim Reid <[email-masked]<mailto:[email-masked]>> wrote:

> On 14 Mar 2019, at 15:36, Eric Rescorla <[email-masked]<mailto:ekr@rtfm..com>> wrote:
>

That seems.... optimistic... but in any case, that still calls into question why we need 20 min of presentation time followed by effectively no time for discussion.

-Ekr

---

From: Dave Lawrence <[email-masked]>
Date: Fri, 15 Mar 2019 13:50:21 -0400

We are evaluating the concerns raised about time and the draft agenda
and expect to have an update on Monday.