Subject: [Doh] Changes in draft-ietf-doh-resolver-associated-doh-01

From: Paul Hoffman <[email-masked]>
Date: Thu, 7 Mar 2019 00:18:56 +0000

If you looked at the diff, you'll know: it's pretty much a complete reorganization based on comments that I got that the order and style of the three protocols defined in the document made it hard to determine which protocol did what. The discussion about web applications was reduced to a minimum. Also, the details for "DoH Servers from HTTPS" were filled in; it is now definitely JSON returned.

Feel free to comment. There is still more to do here.

--Paul Hoffman

---

From: "Hewitt, Rory" <[email-masked]>
Date: Thu, 7 Mar 2019 00:36:34 +0000

Paul,

In Sec 2.1, could we see an example TXT record?

If multiple TXT records are returned, in addition to the URI template itself, can each contain some indication of priority (similar to MX records) and/or re-resolving strategies (round-robin, etc.) to apply across the set of TXT records?

In Sec  2.2, for [[ Need to talk about what a response with an empty list means ]], it would be simplest to return a 501 Not Implemented, no?

Rory

-----Original Message-----
From: Paul Hoffman <[email-masked]> 
Sent: Wednesday, March 6, 2019 4:19 PM
To: DoH WG <[email-masked]>
Subject: [Doh] Changes in draft-ietf-doh-resolver-associated-doh-01

--Paul Hoffman

_______________________________________________
Doh mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/doh