Subject: [Doh] handling HTTP re-directs in DoH

From: Stephen Farrell <[email-masked]>
Date: Fri, 12 Apr 2019 12:39:53 +0100

Hiya,

Discussion on another list prompted me to re-read 8484 to
see if I can understand what's supposed to happen if a DoH
server returns a 3xx. I didn't find an explicit answer in
the RFC, so am wondering what implementers do in that case?

Thanks,
S.

---

From: Daniel Stenberg <[email-masked]>
Date: Fri, 12 Apr 2019 14:44:24 +0200 (CEST)

On Fri, 12 Apr 2019, Stephen Farrell wrote:

> Discussion on another list prompted me to re-read 8484 to see if I can 
> understand what's supposed to happen if a DoH server returns a 3xx. I didn't 
> find an explicit answer in the RFC, so am wondering what implementers do in 
> that case?

I *think* the Firefox implementation will follow them if received. The curl 
implementation does not (mostly because of doing as little as possible until 
proven necessary). I've not seen any DoH server implementation actually send 
any redirects (but I also haven't looked very hard).

3xx responses are part of HTTP so why shouldn't they be acknowledged? I'd say 
that also goes for 1xx responses, 401 responses and more.

-- 

  / daniel.haxx.se

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 12 Apr 2019 07:54:32 -0700

> the RFC, so am wondering what implementers do in that case?

DoH is HTTPS. A DoH client is an HTTPS client. Redirects, caching, 
everything is plain HTTP and TLS.

--Paul Hoffman

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 12 Apr 2019 16:25:08 +0100

Hiya,

On 12/04/2019 13:44, Daniel Stenberg wrote:
> I *think* the Firefox implementation will follow them if received. The
> curl implementation does not (mostly because of doing as little as
> possible until proven necessary).

Thanks.

> everything is plain HTTP and TLS.

Well, a) see above, and b) I asked about what implementers are doing
not what they ought be doing:-)

Cheers,
S.