Subject: [Doh] On shutting down work on draft-ietf-doh-resolver-associated-doh

From: Paul Hoffman <[email-masked]>
Date: Mon, 19 Aug 2019 20:03:13 +0000

Greetings again. The DNSOP WG has adopted draft-ietf-dnsop-resolver-information as a WG document. That draft covers the transport of information that was previously in draft-ietf-doh-resolver-associated-doh. The data content from draft-ietf-doh-resolver-associated-doh is tentatively in draft-sah-resinfo-doh, which may come to this WG or to DNSOP, depending on how the WG chairs feel.

Given that, I'd like the WG to drop consideration of draft-ietf-doh-resolver-associated-doh. I could do a final draft of draft-ietf-doh-resolver-associated-doh that is a tombstone so that people in the future know that we consciously killed it.

Thoughts?

--Paul Hoffman

---

From: Dave Lawrence <[email-masked]>
Date: Sat, 31 Aug 2019 16:33:45 -0400

Paul Hoffman writes:
> Given that, I'd like the WG to drop consideration of
> draft-ietf-doh-resolver-associated-doh. I could do a final draft of
> draft-ietf-doh-resolver-associated-doh that is a tombstone so that
> people in the future know that we consciously killed it. 
> 
> Thoughts?

It looks like this never got a response.  Personally (no hats) I'd
like that proposed final documenting of consciously dropping it.

---

From: Warren Kumari <[email-masked]>
Date: Sat, 31 Aug 2019 17:38:13 -0400

> like that proposed final documenting of consciously dropping it.

+1 (and sorry for not responding earlier).

It seems much better to document that this was intentional and not that e.g
people just got sidetracked, etc.

W

>
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 31 Aug 2019 17:45:13 -0400

The chairs can either mark the old draft "Parked" Or "Dead" in the data
tracked and add a comment with a link to the current draft.

I actually did the Datatracker stuff to mark draft-sah-resolver-information
as
"Replaces".  draft-ietf-doh-resolver-associated-doh

hope that doesn't upset the authors.

Tim

On Sat, Aug 31, 2019 at 5:38 PM Warren Kumari <[email-masked]> wrote:

> It seems much better to document that this was intentional and not that
> e.g people just got sidetracked, etc.
>
> W
>
>
>>
> I don't think the execution is relevant when it was obviously a bad idea
> in the first place.

---

From: Warren Kumari <[email-masked]>
Date: Sat, 31 Aug 2019 17:47:40 -0400

IMO, that’s good, but it’s only clear to people who view this through the
datatracker - I still think it would be good to also put in. A (short)
tombstone saying what happened, and why.

W

On Sat, Aug 31, 2019 at 5:45 PM Tim Wicinski <[email-masked]> wrote:

> I actually did the Datatracker stuff to mark
> draft-sah-resolver-information as

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 31 Aug 2019 17:55:39 -0400

I totally agree Warren.   As a working group chair, I have been conditioned
to see the world through the data tracker (not saying it's a good thing).