Subject: [Dots] Martin Duke's No Objection on draft-ietf-dots-signal-call-home-14: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Wed, 11 Aug 2021 14:57:59 -0700

Martin Duke has entered the following ballot position for
draft-ietf-dots-signal-call-home-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-call-home/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

(5.3.1) Please clarify if the entire source-prefix needs to fall within the
responsibility of the DOTS server.

e.g. If the client needs all of 1.2.3.0/24 to be squelched, and this prefix is
split between two domains, can the client send the same request to both
servers, or can it simply replicate the same message to both and expect them to
administer the relevant portions?

---

From: <[email-masked]>
Date: Thu, 12 Aug 2021 10:08:00 +0100

Hi Martin,

Please see inline.

Regards

Jon

> -----Original Message-----
> From: Martin Duke via Datatracker [mailto: [email-masked]]
> Sent: 11 August 2021 22:58
> To: The IESG
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: [Dots] Martin Duke's No Objection on 
> draft-ietf-dots-signal-call-
> home-14: (with COMMENT)
> 

Jon> Thanks.

> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
> 
> 
> Please refer to 
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> (5.3.1) Please clarify if the entire source-prefix needs to fall 
> within the responsibility of the DOTS server.
> 
> e.g. If the client needs all of 1.2.3.0/24 to be squelched, and this 
> prefix is split between two domains, can the client send the same 
> request to both servers, or can it simply replicate the same message 
> to both and expect them to administer the relevant portions?
> 

Jon> Yes, the entire source prefix needs to fall within the 
Jon> responsibility of the DOTS server.  Further into 5.3.1, there is:-

" The Call Home DOTS server MUST check that the 'source-prefix' is
   within the scope of the Call Home DOTS server domain.  
  ....
   Invalid mitigation
   requests are handled as per Section 4.4.1 of
   [I-D.ietf-dots-rfc8782-bis]."

> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots