Subject: [Dtls-iot] Does DTLS support SNI

From: rohit verma <[email-masked]>
Date: Fri, 3 Apr 2015 08:50:05 -0400

Does DTLS support SNI? The DTLS RFC is silent on this  DTLS RFC https://tools.ietf.org/html/rfc4347 is silent on the usage of TLS extensions.We may need DTLS for example, in a scenario for virtual hosting for iOT applications

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 03 Apr 2015 17:58:40 +0200

Hi Rohit,

yes, you can use SNI with DTLS.

In https://tools.ietf.org/html/draft-ietf-dice-profile-10 we recommend
the use of SNI when the server is part of a hosting environment.

Ciao
Hannes

On 04/03/2015 02:50 PM, rohit verma wrote:
> 
> Does DTLS support SNI? The DTLS RFC is silent on this  DTLS RFC
> https://tools.ietf.org/html/rfc4347 is silent on the usage of TLS
> extensions.
> We may need DTLS for example, in a scenario for virtual hosting for iOT
> applications
> 
> 
> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot
>