Subject: Re: [dtn-interest] N4C trial data

From: <[email-masked]>
Date: Sat, 14 May 2011 10:24:15 +0100

Stephen posted to and I replied to the old list address.
Forwarding to the new one and fixing cc... mails should be to
[email-masked]

On 14 May 2011, at 08:09, Wood L Dr (Electronic Eng) wrote:

> http://dx.doi.org/10.1109/MIC.2011.67
> Stephen Farrell, Security in the Wild, IEEE Internet Computing,
> vol. 15 issue 3, pp. 86-91, May-June 2011.
> is probably worth mentioning as well, as that summarises the
> Padjelanta scenario.
> 
> That says (p. 90);
> "Because we used BP to handle all traffic in the DTN, we would
> have benefited here from using its cryptographic security
> mechanisms (BSP).4 However, our BP implementation doesn’t yet
> fully support security, so we didn’t have this option at the
> time."
> 
> Without bundle security or any form of end-to-end reliability
> for bundles, how did you determine that bundles arrived without
> error and were fragmented and reassembled correctly, and
> that application data was delivered across the
> bundle subnet without error?
> 
> thanks,
> 
> Lloyd Wood
> http://sat-net.com/L.Wood/dtn
> 
> On 13 May 2011, at 18:59, Stephen Farrell wrote:
> 
>> 
>> Hi all,
>> 
>> We've just put up [1] a first cut of our data from the DTN
>> trial we did in the arctic last year. There's a draft tech
>> report and 6 gigs of logs, scripts etc. (Beware: The tarball
>> is 451MB.)
>> 
>> This'll change a bit as we finish off the tech report and
>> fix any missing bits and pieces from the dataset but in the
>> meantime we'd love it if people wanted to make use of this.
>> 
>> As a teaser, there were 9500 contacts over a 6 week period
>> so if you're developing any DTN routing stuff, then this
>> should be a good way to see how your ideas would have
>> worked. The tarball has the full dtnd logs and scripts to
>> generate a bunch of CSV files and other gnuplot goodies.
>> 
>> Feel free to ping me if you've any questions or use the
>> address in the README for support-type questions.
>> 
>> Enjoy,
>> Stephen.
>> 
>> PS: In case someone's interested, the smaller report and
>> data from 2009 are also up there, [2] but are probably
>> less generally useful.
>> 
>> [1] http://dtn.dsg.cs.tcd.ie/n4c-summer10/
>> [2] http://dtn.dsg.cs.tcd.ie/n4c-summer09/
> 
> 
> 

Lloyd Wood
[email-masked]
http://sat-net.com/L.Wood

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 14 May 2011 13:30:31 +0100

Hi Lloyd,

> Forwarding to the new one and fixing cc... mails should be to

Yeah, I keep doing that. We'll check it out. Not sure we
can arrange to forward but should at least bounce with a
message or something.

>> is probably worth mentioning as well, as that summarises the

Must add that stuff to the tech report as well;-)

>> bundle subnet without error?

We didn't. But it more-or-less worked. I think there was however
some fragmentation seen but we've yet to bottom out on that.

If you want, all the information is in the published logs so
you could go after that yourself. That's on our list of things
to do, but since we weren't progressing that we've just put
the data out so other, quicker, people might be able to help
find out answers like that;-) (I think the fragmentation
was of pushed web content bundles mostly over the Dublin to
Ritsem/Sjofjallet links that ran over a VPN over GSM. If you
do go looking you'll be helping us debug scripts etc which'd
be great for us...so we'll help as we can.)

Cheers,
S.

PS: Just updated the tech report in case someone has
downloaded but yet to read it. That'll happen a few more
times in the next week or so.

---

From: <[email-masked]>
Date: Sat, 14 May 2011 13:35:35 +0100

> can arrange to forward but should at least bounce with a

I got a message bounce - below. Not sure if messages to the old list are forwarded - looking at:
http://maillists.intel-research.net/pipermail/dtn-interest/2011-May/thread.html
your message was forwarded, and that's my first copy to the old list address?
If my second copy also turns up there, all is good.

From: 	[email-masked]
	Subject: 	Auto-response for your message to the "dtn-interest" mailing list
	Date: 	14 May 2011 08:09:59 GMT+01:00
	To: 	Wood L Dr (Electronic Eng) <[email-masked]>

IMPORTANT: DO NOT POST TO THIS LIST

The dtn-interest list has moved...

Please go to:

http://www.irtf.org/mailman/listinfo/dtn-interest

Lloyd Wood
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 14 May 2011 13:47:36 +0100

On 14/05/11 13:35, [email-masked] wrote:
> I got a message bounce - below. 

I think you just get one of those (maybe per month or something),
not enough for me to do the right thing in any case;-)

We'll check it out next week. (Ping me if we forget to do that.)
S.

> Not sure if messages to the old list are forwarded - looking at:

---

From: Lyndon Nerenberg <[email-masked]>
Date: Sat, 14 May 2011 09:41:05 -0700 (PDT)

> 	Subject: 	Auto-response for your message to the "dtn-interest" mailing list

At the very least they should change the Subject header to something that 
people's brains haven't been trained to ignore. Perhaps

   Subject: Your DTN-INTEREST mail was rejected; the mailing list has moved

would better catch people's attention.