Subject: [dtn-interest] costs for a DTN system

From: Jeremiah Scholl <[email-masked]>
Date: Wed, 9 Nov 2011 16:49:01 +0000

Hello.  I know some doctors that work on a medical mission in Swaziland that are interested in investigating using DTN for reporting of lab results from central labs to health clinics there. Currently these results are sent via paper with motorbike transport. The idea is to make the motorbikes, lab and clinics DTN enabled, and use digital records in order to improve the workflow a bit.

They asked me about the (hardware) costs of implementing a DTN system and I am not knowledgeable enough to answer their questions.  But, am I correct that they would need.

a)       WiFi or Bluetooth set ups on the bikes and at the clinics.
b)       Some sort of small portable computer on the bikes that is DTN enabled.  I have no idea of the best hardware, so I am wondering if anyone can give me a clue as to the cheapest way to do this.
c)       Computers at the clinics and lab (this they already can get).
a.       Note that electricity at the lab and clinics is reliable so really the mobile nodes should be the only "unusual" aspect of the system.

Thus, I suppose I am really asking...
1)       Can someone provide me with an estimate of the "per bike" costs for the DTN system (not including the bike)?
2)       Is there any "plug and play" system that already is available for this that would not require any additional software development?  For example DTN boxes that support basic file transfer with security etc.  If so, what is the cost for that system?

Thanks,

Jeremiah Scholl

----------------------------------------------
Jeremiah Scholl, Ph.D.
Senior Researcher
Health Informatics Centre
Karolinska Institutet
+46852483926

---

From: Teemu <[email-masked]>
Date: Thu, 10 Nov 2011 10:28:05 +0200

Hi,

We have developed a DTN system that's used in a mine[1] where we use
ALIX.3D boards[2] with two WiFi interfaces, flash memory and running a
standard Linux distro. These are installed in pickup trucks and powered
from the car battery. They have proven to be pretty robust (we use an
outdoor enclosure) - I think we got close to a year of use before one had
to be manually rebooted (they do reboot regularly due to the battery
getting cut off though). I think the total component cost for one of these
is around 200-250€ depending on the exact configuration.

Cheers,
-Teemu

[1] 
http://www.cl.cam.ac.uk/~fb375/extremecom/2010/GinzboorgExtremeCom10.pdf
[2] 
http://shop.varia-store.com/product_info.php?info=p477_ALIX-3D3-Mainboard--
500MHz--256MB--1xLAN--2xMini-PCI-USB-VGA.html

On 9.11.2011 18.49, "Jeremiah Scholl" <[email-masked]> wrote:

>Hello.  I know some doctors that work on a medical mission in Swaziland
>that are interested in investigating using DTN for reporting of lab
>results from central
> labs to health clinics there. Currently these results are sent via paper
>with motorbike transport. The idea is to make the motorbikes, lab and
>clinics DTN enabled, and use digital records in order to improve the
>workflow a bit.
> 
>They asked me about the (hardware) costs of implementing a DTN system and
>I am not knowledgeable enough to answer their questions.  But, am I
>correct that they
> would need.
> 
>a)      
>WiFi or Bluetooth set ups on the bikes and at the clinics.
>b)      
>Some sort of small portable computer on the bikes that is DTN enabled.  I
>have no idea of the best hardware, so I am wondering if anyone
> can give me a clue as to the cheapest way to do this.
>c)      
>Computers at the clinics and lab (this they already can get).
>a.      
>Note that electricity at the lab and clinics is reliable so really the
>mobile nodes should be the only “unusual” aspect of the system.
> 
>Thus, I suppose I am really asking…
>1)      
>Can someone provide me with an estimate of the “per bike” costs for the
>DTN system (not including the bike)?
>2)      
>Is there any “plug and play” system that already is available for this
>that would not require any additional software development?  For
> example DTN boxes that support basic file transfer with security etc.
>If so, what is the cost for that system?
> 
>Thanks,
> 
>Jeremiah Scholl
> 
>_______________________________________________
>dtn-interest mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 11 Nov 2011 08:47:57 +0000

Hi Jeremiah,

> 1)       Can someone provide me with an estimate of the "per bike" costs for the DTN system (not including the bike)?

We've used two kinds of "data mule" one was a PC-engines board that's
now end-of-life (can't recall costs) so more recently we've used
Asus EEE pcs which you can pick up 2nd hand mostly these days.

> 2)       Is there any "plug and play" system that already is available for this that would not require any additional software development?  For example DTN boxes that support basic file transfer w…

We have a build process for both of the above that starts with
setting up the OS (ubuntu in the case of the EEE pcs) and goes
all the way to a working DTN node. You'd need to mess with the
scripts probably but contact us if you're interested.

If you reckon a netbook can be safely handled, both physically
and in terms of possible theft, I'd say going for that would
be your best bet.

Note however, that we've not done anything that'd get you
real confidentiality for any of our data-mule setups. We do
run backhaul connections via a VPN and that could be done
with a mule, but there'd be a bit of work required to merge
the scripts we use for the backhaul and mule setups.

Cheers,
S.

---

From: Jeremiah Scholl <[email-masked]>
Date: Fri, 11 Nov 2011 09:40:10 +0000

Hi Stephen.  Someone else (from KTH here in Stockholm) contacted me about using android phones and for the moment that seems like our best option.

Personally I think neither phones or laptops will work out well over the medium term due to theft. But the guys in Swaziland are ok with trying phones for a pilot, since they already are sending some lab reports via SMS to android phones at these clinics. Those reports however are very limited and the idea was to use DTN to improve them. 

Really, I would like it if someone could work out a cheap open source hardware implementation of a DTN node with WiFI connectivity that is suitable to put on a motorbike for extended periods of time. 

I wonder if this would be publishable in DTN community or if it's just too practical and not theoretical enough. If so, maybe someone could get a masters student to try working on this problem for their thesis.

Jeremiah

-----Original Message-----
From: Stephen Farrell [mailto:[email-masked]] 
Sent: den 11 november 2011 09:48
To: Jeremiah Scholl
Cc: [email-masked]
Subject: Re: [dtn-interest] costs for a DTN system

Hi Jeremiah,

Cheers,
S.

---

From: Sebastian Schildt <[email-masked]>
Date: Fri, 11 Nov 2011 10:56:40 +0100

Hi Jeremiah,

> 1)       Can someone provide me with an estimate of the “per bike” costs for the DTN system (not including the bike)?
Since IBR-DTN (http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/getstarted.html) runs on OpenWRT (Embedded Linux plattform), it would enable you to choose from a wide range of cheap systems. Easiest would be the Ubiquity RouterStationPro (http://ubnt.com/rspro), as this is one of our reference plattforms and there are binary builds available for it.  An RSpro+WiFI Card+SDCard should be available for less than 100$. Regarding hardware specifications even much less powerful equipment is sufficient. This http://journal.ub.tu-berlin.de/eceasst/article/view/512/544 includes a list of hardware that ran IBR-DTN successfully 

> 2)       Is there any “plug and play” system that already is available for this that would not require any additional software development?  For example DTN boxes that support basic file transfer with security etc.  If so, what is the cost for that system?
I do not know about any "production-ready" system that works out of the box, as most implementations, including IBR-DTN, are research software.We do however try to be as user-friendly as possible, i.e. for simple applications there is a set of command line tools, which can be used to quickly put together an application using some scripting without any need to got deeper into the implementation or some obscure API.

Regarding costs there might be another solution: We are currently working on bringing IBR-DTN to Android phones. We currently have some alpha versions running on even very cheap phones like the Huawei Joy. No rooting required. This  is however work in progress, and as of yet  there is no fixed date on when we will release this officially. However, if you are interested to test feel this free to contact us.

<End-Of-Advertisement>

Sebastian

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 11 Nov 2011 12:34:24 +0000

Hiya,

> Personally I think neither phones or laptops will work out well over the medium term due to theft. But the guys in Swaziland are ok with trying phones for a pilot, since they already are sending so…

I think someone has done an android thing that we tested,
can't recall who. (Maybe bytewalla's? - Alex knows.)

I agree that theft is a gotcha.

> Really, I would like it if someone could work out a cheap open source hardware implementation of a DTN node with WiFI connectivity that is suitable to put on a motorbike for extended periods of tim…

Agree, however, its hard to compete with the cost of a 2nd hand
laptop or phone really.

You could think about making it less attractive, e.g. take off
the screen/keyboard, or just wrap a phone in loads of ganky
tape so it looks like a horrible ball of crap:-)

We also played with the FIT-PC2 a while ago. Nice little box
but the version we got didn't support booting on poweron, though
I think they have a newer one that does.

If you do go with something on OpenWRT then either IBR-DTN or DTN2
could do the job - the PC-engines mule we used was OpenWRT so we
also have a build for that.

I guess the ideal bike mule from a h/w perspective would be
something like a gumstick built into the frame of the bike
and powered from a dynamo. Should be a fine masters project,
but it'll still be easier to hand someone a phone or netbook
when you come to deploying it I'd bet.

> I wonder if this would be publishable in DTN community or if it's just too practical and not theoretical enough. If so, maybe someone could get a masters student to try working on this problem for…

Well you could certainly get it into extremecom (Dec 23 due date
is maybe too soon), or a CHANTS demo.

Personally, I think papers about really doing things should get
more acceptance - we're all too fond of papers that claim to have
invented the perfect routing scheme and are then forgotten;-)

If you do manage to get something deployed I'd be interested in
traces/logs as well - so do try to make sure whatever you pick
logs everything you can think of.

And if we can be of help, feel free to ask - the answer might
be "sorry" but that doesn't cost anything,

Cheers,
S.