Subject: [dtn-interest] Nasa mars exploration programm and DTN

From: "Marc Manthey (macbroadcast )" <[email-masked]>
Date: Tue, 13 Dec 2011 03:28:24 +0100

hello list,

most of you might  heard about the  nasa mars exploration programm http://mars.jpl.nasa.gov/

I read that DTN was origninally made for a inter planetary internet http://www.dtnrg.org

- NASA Tests First Deep Space Internet (DTN)  http://www.youtube.com/watch?v=wYySDpaMuwY

You think they test this on the "mars exploration programm" or are  
there some infos about it ?

thanks a lot

Marc

--  Les enfants teribbles - research / deployment
Marc Manthey- Vogelsangerstrasse 97
50823 Köln - Germany
Tel.:0049-221-29891489
Mobil:0049-1577-3329231
web: http://let.de
project : http://stattfernsehen.com
twitter: http://twitter.com/macbroadcast/
facebook: http://www.facebook.com/opencu

Please think about your responsibility towards our environment: Each  
printed e-mail causes about 0.3 grams of CO2 per page.

Opinions expressed may not even be mine by the time you read them, and  
certainly don't reflect those of any other entity (legal or otherwise).

---

From: Tina TSOU <[email-masked]>
Date: Tue, 13 Dec 2011 02:35:02 +0000

Marc,
That sounds exciting.
Which case are we going to address from the following?
1. The delay is big, we are going to build a system to bear it?
or
2. The delay is big, we try to build a system to shorten the delay.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

From: [email-masked] [mailto:[email-masked]] On Behalf Of "Marc Manthey (macbroadcast ?)"
Sent: Monday, December 12, 2011 6:28 PM
To: [email-masked]
Subject: [dtn-interest] Nasa mars exploration programm and DTN

hello list,

I read that DTN was origninally made for a inter planetary internet http://www.dtnrg.org<http://www.dtnrg.org/>

You think they test this on the "mars exploration programm" or are there some infos about it ?

thanks a lot

Marc

web: http://let.de<http://let.de/>

Please think about your responsibility towards our environment: Each printed e-mail causes about 0.3 grams of CO2 per page.

Opinions expressed may not even be mine by the time you read them, and certainly don't reflect those of any other entity (legal or otherwise).

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 12 Dec 2011 22:16:15 -0500

On Mon, Dec 12, 2011 at 9:28 PM, "Marc Manthey (macbroadcast )"
<[email-masked]> wrote:
> - NASA Tests First Deep Space Internet (DTN)
>  http://www.youtube.com/watch?v=wYySDpaMuwY
>

This was discussed last year :

http://www.ietf.org/mail-archive/web/dtn-interest/current/msg00240.html

Apparently MSL won't be running DTN, at least during the prime
mission. This doesn't surprise me; spacecraft ops
tends to be very conservative about adopting new technology.

Regards
Marshall

> Please think about your responsibility towards our
> environment: Each printed e-mail causes about 0.3 grams of CO2 per page.
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: Vint Cerf <[email-masked]>
Date: Tue, 13 Dec 2011 01:26:12 -0500

it will be running the predecessor to the DTN's Bundle Protocol, CFDP,
if I remember correctly.

vint

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Tue, 13 Dec 2011 08:05:59 -0600

The following is all public knowledge.

The Mars Science Laboratory (MSL) launched Nov 26, 2011.
http://www.youtube.com/watch?v=1QCNsKricls

MSL, like every NASA large project, had substantial cost overruns.  Any new technology is not likely to be included   until the primary mission completes.

I believe Vint is correct that CFDP is being used.  Most likely CFDP mode 2 (reliable transport).  I do not believe CFDP mode 3 or 4 is being used.  Others may know.  CFDP mode 4 is reliable multi hop file transfer with weigh points.  So it is analogous to DTN with only one route option (sting of pearls network).   CFDP mode 2 is reliable file transfer, but single hop.  So you sort of have to manually create a multi-hop store and forward environment.  Others at JPL would know better.  The current NASA future architecture documents support CFDP mode 2, but not mode 3 or 4.  DTN is preferred over CFDP mode 3 and 4 due to the flexibility (multi-path, multi-hop).

I'm not sure of the funding situation, but I think the next major Mars flight may be " ExoMars Trace Gas Orbiter (TGO), sometimes referred to as Trace Gas Mission (TGM) by NASA<http://en.wikipedia.org/wiki/NASA>, is a flexible collaborative proposal within NASA and the European Space Agency<http://en.wikipedia.org/wiki/European_Space_Agency> (ESA) to send a new orbiter<http://en.wikipedia.org/wiki/Orbiter>-carrier to Mars<http://en.wikipedia.org/wiki/Mars> in 2016 as part of the European-led ExoMars<http://en.wikipedia.org/wiki/ExoMars> mission."

TGO may be the next Mars Relay.  Whether or not DTN would be onboard is TBD.  There may be nothing to relay.  Also, ESA is the prime on this mission.  The Space Science Decadal Surveys have basically indicated that any new Mars landing should include sample return or not be done.   In addition, there is a price limit that has been place on such a mission that basically makes it impossible to do within budget.  So, it is currently a NO GO  in the current funding environment.

Space = Politics.

Politics = Uncertainty

IMHO, the most likely early deployment of DTN is near-earth Low Earth Orbiting systems.  But you need to be able to handle multi-gigabyte files.

- Will

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Tue, 13 Dec 2011 07:58:47 -0800

Actually I believe a variant of "class-1" (unacknowledged, i.e., without retransmission) CFDP is flying on MSL.  Will is correct: Mars missions are very expensive and are inherently very risky, so new technology like DTN is unlikely to be included until after the completion of the primary mission.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ivancic, William D. (GRC-RHN0)
Sent: Tuesday, December 13, 2011 6:06 AM
To: [email-masked]
Subject: Re: [dtn-interest] Nasa mars exploration programm and DTN

Space = Politics.

Politics = Uncertainty

- Will

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 13 Dec 2011 11:26:08 -0500

On Tue, Dec 13, 2011 at 9:05 AM, Ivancic, William D. (GRC-RHN0)
<[email-masked]> wrote:
> MSL, like every NASA large project, had substantial cost overruns.  Any new
> technology is not likely to be included   until the primary mission
> completes.
>
> I believe Vint is correct that CFDP is being used.  Most likely CFDP mode 2
> (reliable transport).  I do not believe CFDP mode 3 or 4 is being used.
>  Others may know.  CFDP mode 4 is reliable multi hop file transfer with
> weigh points.  So it is analogous to DTN with only one route option (sting
> of pearls network).   CFDP mode 2 is reliable file transfer, but single hop.
>  So you sort of have to manually create a multi-hop store and forward
> environment.  Others at JPL would know better.  The current NASA future
> architecture documents support CFDP mode 2, but not mode 3 or 4.  DTN is
> preferred over CFDP mode 3 and 4 due to the flexibility (multi-path,
> multi-hop).
>
> I'm not sure of the funding situation, but I think the next major Mars

I would say that the funding situation is unknowable until we know whether or
not the "SkyCrane" is going to work, A lot is riding on MSL, and more
than just a rover
is going  to be suspended on those 3 bridles.

Regards
Marshall

> flight may be " ExoMars Trace Gas Orbiter (TGO), sometimes referred to as
> Trace Gas Mission (TGM) by NASA, is a flexible collaborative proposal within
> NASA and the European Space Agency (ESA) to send a new orbiter-carrier to
> Mars in 2016 as part of the European-led ExoMars mission."
>
> TGO may be the next Mars Relay.  Whether or not DTN would be onboard is TBD.
>  There may be nothing to relay.  Also, ESA is the prime on this mission.
>  The Space Science Decadal Surveys have basically indicated that any new
> Mars landing should include sample return or not be done.   In addition,
> there is a price limit that has been place on such a mission that basically
> makes it impossible to do within budget.  So, it is currently a NO GO  in
> the current funding environment.
>
> Space = Politics.
>
> Politics = Uncertainty
>
> IMHO, the most likely early deployment of DTN is near-earth Low Earth
> Orbiting systems.  But you need to be able to handle multi-gigabyte files.
>
>
> - Will
>
>
>
>