Subject: [dtn-interest] DTN enabled printer or fax machine?

From: Jeremiah Scholl <[email-masked]>
Date: Thu, 10 May 2012 09:01:59 +0000

Hello DTN people.  Just now I was looking the presentation slides at the link below, specifically slide 10.  It shows an "sms printer" that is used for printing out results from laboratory tests so they can be returned to a clinic via SMS, instead of requiring the physical transport of paper records.

http://www.teampata.org/downloads/presentations/2011/2%20Shaffiq%20Essajee%20Fast%20tracking%20infants.pdf

The idea is being applied to reduce the time from when tests are taken of infants that might have HIV, to when they can put them on Anti Retroviral Treatment.

It made me wonder if anyone has implemented a "dtn printer" or "dtn fax machine". It could be used as a substitute for paper mail, where SMS is not the best alternative. It could provide several advantages.

For example, some studies that transmit health information to mobile phones run into problems because the phones get stolen.  The printer hardware would not be so useful for general purposes however, like a mobile phone is, so the incentive to steal one would not be as great. Also in situations where you want a paper copy of the information that a DTN network is transmitting, then the usability would be much better than having a general computer-printer combo. This is usually the case in  a healthcare setting since the remote clinics that would use a system like this use paper records and it is quite difficult to get them to change over to completely use electronic records.

Also potentially you could transmit much nicer documents than the SMS version.

So I have two questions....

a)      Has anyone ever implemented a DTN-enabled fax machine or printer?

b)      If not would anyone be interested in creating an open source hardware/software implementation of one? I think that it could be useful in the healthcare domain.

Jeremiah

----------------------------------------------
Jeremiah Scholl, Ph.D.
Senior Researcher
Health Informatics Centre
Karolinska Institutet
+46852483926

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Thu, 10 May 2012 23:42:37 +0000

This sounds like a great idea to me; I don't know of anybody who's working on anything similar, and it does sound like something that could be very useful.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jeremiah Scholl
Sent: Thursday, May 10, 2012 2:02 AM
To: [email-masked]
Cc: Shabbir
Subject: [dtn-interest] DTN enabled printer or fax machine?

Jeremiah

---

From: "Scott, Keith L." <[email-masked]>
Date: Fri, 11 May 2012 11:32:32 +0000

This has got to be doable.  A coupling between BP for OpenWRT and either tunneling or proxying the Windows shared printer service or CUPS...

You might want duplicate suppression at the printer a la the Disruption Tolerant Payload Conditioning work that SPICE/NASA have been working on.

                                --keith

From: [email-masked] [mailto:[email-masked]] On Behalf Of Burleigh, Scott C (313B)
Sent: Thursday, May 10, 2012 7:43 PM
To: [email-masked]
Subject: Re: [dtn-interest] DTN enabled printer or fax machine?

Scott

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Jeremiah Scholl
Sent: Thursday, May 10, 2012 2:02 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Shabbir
Subject: [dtn-interest] DTN enabled printer or fax machine?

Jeremiah

---

From: Eric Travis <[email-masked]>
Date: Fri, 11 May 2012 14:50:11 -0400

> b)      If not would anyone be interested in creating an open source
> hardware/software implementation of one? I think that it could be useful in
> the healthcare domain.

While not a "bundling" flavored DTN approach, we built and deployed a
DTN-enabled logger for remotely deployed middle boxes a while back
using XMPP (RFC 6121,6122 originall known as Jabber) as the persistent
messaging infrastructure.

We chose to embedded xmpp servers with the clients to make the
disconnects transparent to the reporting processes and used a
previously deployed xmpp server local to the log repository.

It was simple to implement most of it using mature open source code.
There are little bits of glue that are implementation dependent
(client and server interfaces) but those are low impact.

If you haven't already considered a similar approach, it might be able
to provide just what you need.

Eric