Subject: [dtn-interest] SUNSET (open source framework for underwater sensor networks)

From: Chiara Petrioli <[email-masked]>
Date: Mon, 14 May 2012 13:28:58 +0200

Dear colleagues,

We are releasing SUNSET  (La Sapienza University Networking framework
for underwater Simulation Emulation and real-life Testing). SUNSET is
a new open source solution, developed by the UWSN SENSES Lab Group, to
seamlessly simulate (using ns2), emulate and test  at sea novel
communication protocols for underwater communications.

We have extensively used it for in field tests for two years, and we
are now releasing it to the research community believing it can speed
up significantly  research in the field of underwater sensor networks.
  It allows to seamlessy use the same code for simulating, emulating
and experimenting at sea solutions for UWSNs. You can find information
on SUNSET and on our activities here

Underwater wireless sensor network group:
http://reti.dsi.uniroma1.it/UWSN_Group/

SENSES laboratory:
http://reti.dsi.uniroma1.it/SENSES_lab/

Best Regards
Prof. Chiara Petrioli
Director, SENSES lab
Computer Science Department
University of Rome La Sapienza
E-mail: [email-masked]

---

From: "Scott, Keith L." <[email-masked]>
Date: Tue, 15 May 2012 14:53:55 +0000

There was a paper recently out of Brazil about using DTN to do deepwater monitoring (http://www.gta.ufrj.br/ftp/gta/TechReports/RPC11.pdf).

Would there be interest in integrating a DTN implementation with the ns-2 simulator and emulation framework/testbed?  DTN (specifically the DTN2 implementation of the Bundle Protocol) has been ported to Gumstix, and I assume that the Interplanetary Overlay Network (ION) implementation could be as well.

		--keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chiara Petrioli
Sent: Monday, May 14, 2012 7:29 AM
To: [email-masked]
Subject: [dtn-interest] SUNSET (open source framework for underwater sensor networks)

Dear colleagues,

SENSES laboratory:

Best Regards
Prof. Chiara Petrioli
Director, SENSES lab
Computer Science Department
University of Rome La Sapienza
E-mail: [email-masked]
_______________________________________________
dtn-interest mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Anders Lindgren <[email-masked]>
Date: Tue, 15 May 2012 17:00:45 +0200

This (integrating DTN2 with ns simulation/emulation) has already been
done, but with ns-3 instead of ns-2 as the underlying simulator. It
was done within the N4C project.

Paper:
http://www.springerlink.com/content/2677573v6u3l8151/?MUD=MP

Youtube video explaining the system:
http://www.youtube.com/watch?v=bqq1jNVgRgc

/A

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 15 May 2012 11:22:31 -0700

> From: [email-masked] [mailto:dtn-interest-
> [email-masked]] On Behalf Of Scott, Keith L.
> Sent: Tuesday, May 15, 2012 7:54 AM
> To: Chiara Petrioli; [email-masked]
> Subject: Re: [dtn-interest] SUNSET (open source framework for
> underwater sensor networks)
> 
> There was a paper recently out of Brazil about using DTN to do
> deepwater monitoring
> (http://www.gta.ufrj.br/ftp/gta/TechReports/RPC11.pdf).
> 
> Would there be interest in integrating a DTN implementation with the
> ns-2 simulator and emulation framework/testbed?  DTN (specifically the
> DTN2 implementation of the Bundle Protocol) has been ported to Gumstix,
> and I assume that the Interplanetary Overlay Network (ION)
> implementation could be as well.
> 
> 		--keith

Keith, if the goal is to integrate implementation code, I'd recommend to use ns-3 rather than ns-2 for new simulation efforts, due to its improved capabilities in that regard.  In another message in this thread, Anders Lindgren pointed to one example of how ns-3 can be integrated with LXC containers.  ns-3 is also being integrated with the CORE network emulator.  There are some other efforts in development (INRIA's direct code execution environment, allowing implementation code to execute in a simulation context) that may apply as well.

With respect to underwater networking in particular, there have been a few previous contributions to ns-3 of underwater acoustic network models and underwater mobility models, and I'm aware of at least one other project getting started in this area.  Although I haven't had a chance to look at SUNSET, I'd be curious to see whether those models could be made available in ns-3 as well.

- Tom