Subject: [dtn-interest] PRoPHET Protocol on NS2

From: Phearin SOK <[email-masked]>
Date: Thu, 25 Oct 2012 15:25:23 +0900

Hi,

I'm currently doing research on PRoPHET protocol. And, I want to 
communicate between the PRoPHET protocol and lower layers of the network 
to retrieve some information from the lower layers.
Could anyone tell me whether we can simulate the PRoPHET protocol in 
DTN2 with NS-2? And if possible, what are the classes or relevant 
elements of the PRoPHET protocol for simulating in NS-2?

Thanks,

Phearin

---

From: Phearin SOK <[email-masked]>
Date: Thu, 25 Oct 2012 15:29:24 +0900

Hi,

Thanks,

Phearin

---

From: Emmanuel Lochin <[email-masked]>
Date: Thu, 25 Oct 2012 08:32:11 +0200

Hi,

ns-2 is definitely not the best simulator for DTN.
You should consider The One for any kind of DTN evaluation  :
http://www.netlab.tkk.fi/tutkimus/dtn/theone/

EL

On 25 October 2012 08:29, Phearin SOK <[email-masked]> wrote:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: SOK Phearin <[email-masked]>
Date: Thu, 25 Oct 2012 00:52:27 -0700 (PDT)

Hello Jani, 

It would be a big help from you. Could you please send me the files and documents that you mentioned? So that i could do the implementation and simulation.

Thank you in advance.

Regards,

SOK, Phearin

Graduate Student of Computer, Information, and Communication Engineering
MBC Laboratory, New Millennium Building, Konkuk University, Seoul, Republic of Korea

>________________________________
> From: Jani Lakkakorpi <[email-masked]>
>To: [email-masked] 
>Cc: Joerg Ott <[email-masked]> 
>Sent: Thursday, October 25, 2012 4:39 PM
>Subject: Re: [dtn-interest] PRoPHET Protocol on NS2
> 
>Hi Phearin,
>
>I have written DTN code for ns-2. The code supports mobile nodes and
>different DTN routing protocols (epidemic, spray and wait, PRoPHET).
>The PRoPHET code is not written according to the latest draft. If you
>are interested, I can send you the files and some documentation.
>
>BR,
>Jani
>
>-----
>Jani Lakkakorpi
>Research Scientist
>Aalto University
>Department of Communications and Networking
>
>2012/10/25 Joerg Ott <[email-masked]>:
>> Hi Jani,
>>
>> if you want somebody to implement Prophet code for your
>> DTN framework in ns-2 or ns-3, maybe talk to this guy.
>>
>> Jörg
>>
>>
>> -------- Original Message --------
>> Subject: [dtn-interest] PRoPHET Protocol on NS2
>> Date: Thu, 25 Oct 2012 15:25:23 +0900
>> From: Phearin SOK <[email-masked]>
>> To: [email-masked]
>>
>> Hi,
>>

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 25 Oct 2012 10:01:34 -0700

Hello Phearin,

The ns-3 tool may be a better fit because it can be used to
run real code. Also, the DTN2 code can run natively in the
Common Open Research Emulator (CORE) which has been mentioned
on the list before:

http://www.ietf.org/mail-archive/web/dtn-interest/current/msg04272.html

Fred
[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Phearin SOK
> Sent: Wednesday, October 24, 2012 11:25 PM

---

From: Joerg Ott <[email-masked]>
Date: Thu, 25 Oct 2012 22:07:34 +0300

Hi Fred,

yes, this is indeed nice, but it seriously limits the number of
nodes you can run on a given machine.  (We also have a native
DTN ns-3 implementation if this helps.)

Jörg

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 25 Oct 2012 12:12:37 -0700

Hi Joerg,

> From: Joerg Ott [mailto:[email-masked]]
> Sent: Thursday, October 25, 2012 12:08 PM
> To: Templin, Fred L
> Cc: Phearin SOK; [email-masked]
> nodes you can run on a given machine.

Are you meaning to say that CORE limits the number of nodes,
or ns-3?

> (We also have a native DTN ns-3 implementation if this helps.)

That is interesting - could you send a pointer to the code?

Thanks - Fred

---

From: Anders Lindgren <[email-masked]>
Date: Thu, 25 Oct 2012 22:40:25 +0200

Also, more important in this case (as they want to simulate PRoPHET), Is that there is no properly functioning implementation of PRoPHET in DTN2, so this approach would not be very suitable here. I would recommend using the ONE. 

/A

Sent from my iPhone

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 25 Oct 2012 14:36:02 -0700

Let me clarify something that may not have come across the right
way when I first said it. I meant that ns-3 might be a better
fit than *ns-2* - I was not meaning to make any statements
about the One which I don't know anything about.

That said, any real code (not just DTN2) can run in ns-3, so
I don't anticipate a problem running PRoPHET there.

Thanks - Fred

> From: Anders Lindgren [mailto:[email-masked]]
> Sent: Thursday, October 25, 2012 1:40 PM
> To: Joerg Ott
> Cc: Templin, Fred L; Phearin SOK; [email-masked]
> Also, more important in this case (as they want to simulate PRoPHET), Is
> that there is no properly functioning implementation of PRoPHET in DTN2,
> so this approach would not be very suitable here. I would recommend using
> the ONE.
> 
> /A
> 
> Sent from my iPhone
>

---

From: Joerg Ott <[email-masked]>
Date: Fri, 26 Oct 2012 09:16:16 +0300

Hi Fred,

> Are you meaning to say that CORE limits the number of nodes,

DTN2 is a pretty voluminous beast and running, say, 100+ instances
on a single machine might not be the fastest thing to do.

> That is interesting - could you send a pointer to the code?

I am not sure if this is published on the web (had been doing
some polishing lately).

Jörg

---

From: Joerg Ott <[email-masked]>
Date: Fri, 26 Oct 2012 09:19:10 +0300

I guess what Anders say is: you need DTN2 or something similar
as a basis before you can implement Prophet to begin with.

Jörg

---

From: Phearin SOK <[email-masked]>
Date: Fri, 26 Oct 2012 15:37:30 +0900

Hi all,

I have tried and also asked Shigs about the ONE. And, he said the ONE 
didn't do any low level simulation. Thus, my point is to obtain some 
information from lower layer (Physical Layer) and use in PRoPHET 
protocol. you may check the answer in the following link:
http://www.shigs.co.uk/the-one-simulator/

What i can see from the DTN2 is that PRoPHET is implemented based on the 
internet draft. I guess I may use this PRoPHET implementation (and other 
related elements in DTN2) to simulate on NS2 since NS2 provides us to 
communicate between lower and higher layers. is it possible to do so? or 
should you have any other simulators providing such mechanism?

Thanks
Phearin

---

From: Phearin SOK <[email-masked]>
Date: Fri, 26 Oct 2012 15:45:18 +0900

Hi Jörg,

> on a single machine might not be the fastest thing to do.

Did you mean that we could run DTN2 as a simulator? then, i could use 
DTN2 for simulating and communicating with the lower layers, right?

Sorry if there is any inconvenience regarding the question, since it is 
quite a new topic research to me.

Thanks
Phearin

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 26 Oct 2012 11:10:50 -0700

Hi Jorg,

> Sent: Thursday, October 25, 2012 11:16 PM
> To: Templin, Fred L
> Cc: Phearin SOK; [email-masked]; Jani Lakkakorpi

I believe you are referring here to CORE, which would indeed
run N different instances of DTN2. I do not believe the same
is true of ns-3.

A "hybrid" simulation/emulation environment is also possible
in which a small to medium number of "high-fidelity" virtual
nodes can be built up in CORE and larger numbers of simulated
nodes can be instantiated in ns-3. Emulations running in CORE
and simulations running in ns-3 can then be internetworked
using as many or as few actual physical machines as desired.

Thanks - Fred