Subject: Re: [dtn-interest] Fwd: Re: IETF Challenges - DTN and the Internet of Stuff

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Mon, 13 May 2013 15:00:01 +0000

Will there be a DTNRG meeting at IETF 87 in July, to discuss this topic and a couple of others?  Sorry, I know this may seem premature, but Federal budget sequestration in the U.S. is making it important to do travel planning early.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Sunday, March 03, 2013 5:23 AM
To: DTN interest
Subject: [dtn-interest] Fwd: Re: IETF Challenges - DTN and the Internet of Stuff

FYI for those not on the main ietf discussion list.
Full thread involves other stuff but starts at [1].

I think it'd be timely for us to start discussion about that 5050bis topic in the next few weeks, probably after next week's Orlando IETF meeting is done.

So if people with ideas could sharpen those over the next two weeks ready to start the discussion, that'd be great.

S.

[1] http://www.ietf.org/mail-archive/web/ietf/current/msg77405.html

-------- Original Message --------
Subject: Re: IETF Challenges - DTN and the Internet of Stuff
Date: Sat, 02 Mar 2013 11:42:37 +0000
From: Stephen Farrell <[email-masked]>
To: Fred Baker (fred) <[email-masked]>
CC: [email-masked] <[email-masked]>

On 03/02/2013 10:54 AM, Fred Baker (fred) wrote:
> From my perspective, an important technical challenge in coming years might be a variation on delay-tolerant networking. We have done a fair bit of work in this area, for some definition of "we" - SOAP, Saratoga, and the NASA/JPL DTNrg work. As Dave Crocker likes to point out, we actually have a canonical DTN application and specification we all use - SMTP.
> 
> In your blog, you mentioned emergency communications. Emergency communications are all about ensuring the ability to deliver a message end to end at a time when the intervening network is strenuously overloaded, chaotic, or randomly connected. The canonical examples include events like the fall of the twin towers, where half of the US undersea cable connectivity to Europe was cut by a falling building, hurricanes like Katrina or Sandy, or massive cyber-attacks; more run-of-the-mill models might come in the Smart Objects domain of telemetry.

<dtnrg-co-chair-hat>

Cool. As it happens, DTNRG folks agreed last summer to start work on a bis version of the bundle protocol (RFC5050), and now that we've gotten a few other things out of the way, we should be starting in on that real soon now. So if that does happen, then I'd say now's a great time to get involved in DTN stuff.

Discussion will be on [email-masked] and the RG may well meet at the July IETF to talk in detail about that. If anyone's interested in having a chat in Orlando, just ping me and if there's enough of us, I'll see if we can find a spot/slot to chat.

DTN details can be found at [1].

</dtnrg-co-chair-hat>

Cheers,
S.

[1] http://www.dtnrg.org/wiki

> One example of a delay-tolerant network was Tsinghua's experiment in measuring Beijing pollution. They put sensors and GPS units on taxis; every time a taxi stopped, it asked its GPS where it was and what time it was, asked its sensors for their data, and packaged the lot together into a reading. I think they also asked for time in queue - when did the taxi stop, and when did it subsequently change its position significantly. Every time the taxi passed a bus, it synchronized with a wifi SSID on the bus, and uploaded all of its data from the past hour or two. Every time the bus went through a central station, it synchronized with a central reader and uploaded its cached readings to Tsinghua. Net result - Tsinghua got a whole lot of data on taxi routes, congested intersections, and pollution data. Individual readings were delivered tens to hundreds of times and sorted out by the analytic process. They developed what they described to us as a fairly sophisticated model.
> 
> I'm obviously not thinking, in this, about VoIP or Video/IP, although I could imagine the Internet of Stuff implementing those in some way such as carrying attachments (think HeyTell). I'm thinking more in the direction of IM or email. The key thing is a service for containerized freight, if you will. I can think of military applications, and a variety of telemetry applications in the Internet of Stuff, which could include anything from meter reading to variations on middleware-controlled communications.

> 
> In any event, I could imagine future requirements that could build on such a model, perhaps built in JSON or XML.
> 

_______________________________________________
dtn-interest mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 13 May 2013 16:04:01 +0100

If we can get enough folks to have a useful discussion of a 5050bis
and other topics, that'd defo justify a session. I'm hearing that
you think that'd be good. Others? (off-list is fine if you prefer
and just a "+1, I'd be there" is enough for now)

S.

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 13 May 2013 17:27:59 +0100

I am definitely planning to be in Berlin for IETF 87.

/Elwyn

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 16 May 2013 09:46:05 +0100

Hi all,

I got what I think are enough "I'll be there" messages so
I've requested a 2.5 hour session in Berlin for the DTNRG.
As usual, we'll only know the day of the meeting a few
weeks ahead of time so if you can please plan to be at the
entire IETF meeting.

One topic for I hope a substantial bit of agenda time is:
what about a 5050bis? Contributions to the list on that
in the meantime are most welcome. (Start new threads please.)

Please start other sending agenda requests to the chairs.

Thanks,
Stephen.

---

From: Anders Lindgren <[email-masked]>
Date: Fri, 17 May 2013 17:15:58 +0200

Hi,

I'd like a slot in the agenda to present the -00 version of the routing
framework draft that I promised we would write at the Google meeting last
year. It should be appearing in an ID repository close to you real soon now.

/Anders

On Thu, May 16, 2013 at 10:46 AM, Stephen Farrell <[email-masked]
> wrote:

> > Will there be a DTNRG meeting at IETF 87 in July, to discuss this topic
> and a couple of others?  Sorry, I know this may seem premature, but Federal
> budget sequestration in the U.S. is making it important to do travel
> planning early.
> >
> > Scott
> >
> > From: [email-masked] [mailto:
> [email-masked]] On Behalf Of Stephen Farrell
> > I think it'd be timely for us to start discussion about that 5050bis
> topic in the next few weeks, probably after next week's Orlando IETF
> meeting is done.
> >
> > So if people with ideas could sharpen those over the next two weeks
> ready to start the discussion, that'd be great.
> >
> > S.
> >
> >> From my perspective, an important technical challenge in coming years
> might be a variation on delay-tolerant networking. We have done a fair bit
> of work in this area, for some definition of "we" - SOAP, Saratoga, and the
> NASA/JPL DTNrg work. As Dave Crocker likes to point out, we actually have a
> canonical DTN application and specification we all use - SMTP.
> >>
> >> In your blog, you mentioned emergency communications. Emergency
> communications are all about ensuring the ability to deliver a message end
> to end at a time when the intervening network is strenuously overloaded,
> chaotic, or randomly connected. The canonical examples include events like
> the fall of the twin towers, where half of the US undersea cable
> connectivity to Europe was cut by a falling building, hurricanes like
> Katrina or Sandy, or massive cyber-attacks; more run-of-the-mill models
> might come in the Smart Objects domain of telemetry.
> >
> > <dtnrg-co-chair-hat>
> >
> > Cool. As it happens, DTNRG folks agreed last summer to start work on a
> bis version of the bundle protocol (RFC5050), and now that we've gotten a
> few other things out of the way, we should be starting in on that real soon
> now. So if that does happen, then I'd say now's a great time to get
> involved in DTN stuff.
> >
> > Discussion will be on [email-masked] and the RG may well meet at
> the July IETF to talk in detail about that. If anyone's interested in
> having a chat in Orlando, just ping me and if there's enough of us, I'll
> see if we can find a spot/slot to chat.
> >
> >> One example of a delay-tolerant network was Tsinghua's experiment in
> measuring Beijing pollution. They put sensors and GPS units on taxis; every
> time a taxi stopped, it asked its GPS where it was and what time it was,
> asked its sensors for their data, and packaged the lot together into a
> reading. I think they also asked for time in queue - when did the taxi
> stop, and when did it subsequently change its position significantly. Every
> time the taxi passed a bus, it synchronized with a wifi SSID on the bus,
> and uploaded all of its data from the past hour or two. Every time the bus
> went through a central station, it synchronized with a central reader and
> uploaded its cached readings to Tsinghua. Net result - Tsinghua got a whole
> lot of data on taxi routes, congested intersections, and pollution data.
> Individual readings were delivered tens to hundreds of times and sorted out
> by the analytic process. They developed what they described to us as a
> fairly sophisticated model.
> >>
> >> I'm obviously not thinking, in this, about VoIP or Video/IP, although I
> could imagine the Internet of Stuff implementing those in some way such as
> carrying attachments (think HeyTell). I'm thinking more in the direction of
> IM or email. The key thing is a service for containerized freight, if you
> will. I can think of military applications, and a variety of telemetry
> applications in the Internet of Stuff, which could include anything from
> meter reading to variations on middleware-controlled communications.
> >
> >>
> >> In any event, I could imagine future requirements that could build on
> such a model, perhaps built in JSON or XML.
> >>
> >
> >
> >
> >