Subject: Re: [dtn-interest] dtnrg.org website is down...

From: Stephen Farrell <[email-masked]>
Date: Mon, 21 Oct 2013 14:56:47 +0100

Hi Lloyd, All,

On 10/11/2013 01:56 PM, [email-masked] wrote:
> okay, mail handling's still down (so forgot password fails), creating a new user throws an unhandled exception.
> 
> So, no operational changes since August.
> 
> any news on fixes?

Yeah, that's a straight fail on our part. We had hoped to
have enough cycles to manage this properly but haven't.
(Partly due to the good news that Alex got his PhD thesis
submitted and is now enjoring the world of work;-)

Anyway, I think the best thing now would be for someone
else to take over hosting the wiki if someone is interested
and able.

For that, you'd need to be able to setup a virtual host
with reasonable connectivity and probably be able to put
in a bit of effort on migrating the wiki content to
some other wiki tool (unless you like and are happy to
manage moinmoin). Once up and running, there's not too
much effort involved. If someone is up for that please
get in touch with Elwyn and I.

Apologies again,
S.

> 
> thanks
> 
> Lloyd Wood
> http://sat-net.com/L.Wood/
> 
> 
> ________________________________________
> From: Elwyn Davies [[email-masked]]
> Sent: 24 August 2013 08:55
> To: Wood L  Dr (Electronic Eng)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [dtn-interest] dtnrg.org website is down...
> 
> Yup.  Logins are turned off at present because of the problems we had -
> we have had to clear out all registered users and start over.
> 
> Unfortunately both Stephen and I are away at Extremecom this week so
> please bear with us and we will get things working properly when we
> return.  In the meantime please keep the problem reports coming in so we
> can handle them on our return (and allow logins to known people).
> 
> Regards,
> Elwyn (in Reykjavik)
> 
> 
> On 24/08/13 07:11, [email-masked] wrote:
>> Yup, logins down, can't get password reminders:
>>
>> This wiki is not enabled for mail processing. Contact the owner of the wiki, who can enable email.
>>
>> attempting to create new accounts generates
>> Unhandled Exception
>>
>> An unhandled exception was thrown by the application.
>>
>> rather than just nothing.
>>
>>
>> Looks like a bit of docs got broken:
>>
>> http://www.dtnrg.org/wiki/Docs
>>
>> Other Related Materials
>>
>>      Lloyd Wood's pages
>>
>> The pages link is broken, output after wikihtmling should be something like
>> Lloyd Wood's <a class="http" href="http://www.ee.surrey.ac.uk/Personal/L.Wood/dtn/">Bundle Protocol/Interplanetary Internet/Saratoga/HTTP-DTN pages</a> <span class="anchor" id="line-349"></span></p>
>>
>> Page history appears to be history, so can't see when this edit was done.
>>
>> hmmm
>> http://www.dtnrg.org/wiki/LloydWood
>>
>> Looks like you've changed wiki software type, and this page is one of a number that wasn't converted.
>>
>> cheers
>>
>> Lloyd Wood
>> http://sat-net.com/L.Wood/
>>
>>
>> ________________________________________
>> From: [email-masked] [[email-masked]] On Behalf Of Stephen Farrell [[email-masked]]
>> Sent: 22 August 2013 17:58
>> To: Michael Snell
>> Cc: [email-masked]
>> Subject: Re: [dtn-interest] dtnrg.org website is down...
>>
>> Hi all,
>>
>> I've put the wiki back up read-only for the moment.
>>
>> I had to clean out a bunch of wiki-spam that seems to
>> have been created over the last few months following a
>> mis-config on our part that allowed a bug to be exploited.
>>
>> That involved deleting the spam so I may have deleted
>> (the visible version of) some real content. Please check
>> and let me know if that's the case and I'll put it back.
>> (Its a bit hard since the spam files end up with names
>> that overlap with the real files.)
>>
>> I'll be offline from tomorrow for a week or so (at
>> Extremecom) so just send me mail with fixes and I'll
>> do 'em when I'm back.
>>
>> I'll also put back the accounts etc. then, and a
>> better way to handle new users.
>>
>> Thanks and sorry for the outage,
>> Cheers,
>> S.
>>
>>
>> On 08/22/2013 07:55 AM, Michael Snell wrote:
>>> I read the announcement from Stephen, but did not conclude from it that the
>>> entire website would be down. Probably a lack of mental acuity on my
>>> part... at any rate-- thanks so much for the update!
>>>
>>> Mike
>>> On Aug 21, 2013 11:43 PM, "Elwyn Davies" <[email-masked]> wrote:
>>>
>>>> There was an announcement on Tuesday...
>>>> The wiki software is being upgraded and some problems fixed.
>>>> Hopefully we will be back online shortly.
>>>>
>>>> Sorry for any inconvenience.
>>>>
>>>> Elwyn
>>>>
>>>> On Wed, 2013-08-21 at 21:01 -0700, Michael Snell wrote:
>>>>> Just thought you'd like to know.
>>>>>
>>>>>
>>>>> Mike Snell
>>>>> _______________________________________________
>>>>> dtn-interest mailing list
>>>>> [email-masked]
>>>>> https://www.irtf.org/mailman/listinfo/dtn-interest
>>>>
>>>
>>>
>>> _______________________________________________
>>> dtn-interest mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/dtn-interest
>>>
>> _______________________________________________
>> dtn-interest mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/dtn-interest
> 
> 
>

---

From: <[email-masked]>
Date: Mon, 21 Oct 2013 15:23:44 +0100

Ah, well.

Perhaps it's appropriate that a protocol with a broken design, that we couldn't get fixed, is commemorated by a broken wiki, that we couldn't get fixed.

Lloyd Wood
http://sat-net.com/L.Wood/den

________________________________________
From: Stephen Farrell [[email-masked]]
Sent: 21 October 2013 14:56
To: Wood L  Dr (Electronic Eng); [email-masked]
Cc: [email-masked]; DTN interest
Subject: Re: [dtn-interest] dtnrg.org website is down...

Hi Lloyd, All,

Apologies again,
S.

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 22 Oct 2013 01:43:54 +0000

Hi,

On Oct 21, 2013, at 21:56, Stephen Farrell <[email-masked]> wrote:
> I think the best thing now would be for someone

like all RGs (and WGs), you can simply make a bunch of wiki pages underneath http://trac.tools.ietf.org/group/irtf/trac/wiki

Lars