Subject: [dtn-interest] DTN Simulator

From: MEZGHANI Farouk <[email-masked]>
Date: Fri, 18 Oct 2013 18:17:31 +0200

Hi all,

Am working on Content Dissemination in DTN.
Any idea about Open source simulator knowing that i am working on 
network layer.

Thanks a lot for any help with this.

Best Regards,
Farouk MEZGHANI

---

--------------------------------------------------------
PhD student. Farouk MEZGHANI
Laboratoire IRIT/ENSEEIHT équipe IRT
--------------------------------------------------------
Tél. +33 (0)5 34 32 22 16

email: [email-masked]
WWW: http://mezghani.perso.enseeiht.fr
--------------------------------------------------------

---

From: Joerg Ott <[email-masked]>
Date: Fri, 18 Oct 2013 19:26:20 +0300

We have stuff for ns-2 and ns-3 if you are really into packets:

https://wiki.aalto.fi/display/[email-masked]/DTN+Code+for+ns-2+and+ns-3

Jörg

On 18.10.2013 19:17, MEZGHANI Farouk wrote:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: MEZGHANI Farouk <[email-masked]>
Date: Fri, 18 Oct 2013 18:52:30 +0200

Thank you Jörg for the link, i will take a look.

another question : Do you have an idea about the ONE simulator.
I saw that there are already some DTN modules implemented in this 
simulator, and is faster than ns2 & 3.

I am just trying to find the most suitable simulator for my work.

Best Regards,
Farouk

---

From: MEZGHANI Farouk <[email-masked]>
Date: Mon, 21 Oct 2013 19:00:10 +0200

Dear all,

I want to implement my own protocol in DTN network simulator based on 
message Broadcasting.
I realised that The ONE simulator dosen't contain the broadcasting 
module. (only unicast)
I don't care about the lower layer stuff, so i don't want to use the 
ns2/3 (especially simulation takes a lot of time)

Any proposition for DTN simulator knowing that i want to evaluate the 
content dissemination in VANETs. As results, i want to show the delivery 
delay, delivery ratio ...

Thank you for any help.

Best Regards,
Farouk

On Sat, 19 Oct 2013 10:52:19 +0300, Joerg Ott wrote:
> Hi Farouk,
> kinda, since we built it :-)
>
> If you are interested in wireless interference and in including
> MAC and transport layer behavior, ns2/3 is the choice.  If you
> don't care about this lower layer stuff or can reasonably abstract
> from it, go for the ONE.
>
> Cheers,
> Jörg
>