Subject: [dtn-interest] FW: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

From: <[email-masked]>
Date: Tue, 25 Feb 2014 08:23:04 +0000

Congratulations to  DTNRG on reaching the below milestone in getting
this draft well on the way to being published.

It's been a long delay since draft-demmer-dtnrg-tcp-clayer-00.txt in October
2006, but defining how the bundle protocol is carried over TCP will go a long
way to improving support for networked communications under the very
difficult disrupted and delay-tolerant network conditions when TCP break...
um. Ah.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: IETF-Announce [[email-masked]] On Behalf Of The IESG [[email-masked]]
Sent: 24 February 2014 17:40
To: Lars Eggert; [email-masked]; [email-masked]
Cc: [email-masked]; The IESG; [email-masked]
Subject: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

The IESG has completed a review of draft-irtf-dtnrg-tcp-clayer-08
consistent with RFC5742.

The IESG has no problem with the publication of 'Delay Tolerant
Networking TCP Convergence Layer Protocol'
<draft-irtf-dtnrg-tcp-clayer-08.txt> as an Experimental RFC.

The IESG has concluded that there is no conflict between this document
and IETF work.

The IESG would also like the IRTF to review the comments in the
datatracker related to this document and determine whether or not they
merit incorporation into the document. Comments may exist in both the
ballot and the history log.

The IESG review is documented at:
http://datatracker.ietf.org/doc/conflict-review-irtf-dtnrg-tcp-clayer/

A URL of the reviewed Internet Draft is:
http://datatracker.ietf.org/doc/draft-irtf-dtnrg-tcp-clayer/

The process for such documents is described in RFC 5743

Thank you,

The IESG Secretary

---

From: Vint Cerf <[email-masked]>
Date: Tue, 25 Feb 2014 03:51:41 -0500

Lloyd,
This makes it possible to support applications end to end over DTN
including the Internet.
It is a compatibility mechanism.

vint

On Tue, Feb 25, 2014 at 3:23 AM, <[email-masked]> wrote:

> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: <[email-masked]>
Date: Tue, 25 Feb 2014 09:27:00 +0000

Vint,

the impression I've gained is that most bundle protocol use is over TCP - that is,
rather than being a compatibility mechanism, TCP is the dominant transport for the
bundle protocol.

Are there any statistics or metrics of use that can shed light here?

thanks

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Vint Cerf [[email-masked]]
Sent: 25 February 2014 08:51
To: Wood L  Dr (Electronic Eng)
Cc: dtn-interest
Subject: Re: [dtn-interest] FW: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

Lloyd,
This makes it possible to support applications end to end over DTN including the Internet.
It is a compatibility mechanism.

vint

On Tue, Feb 25, 2014 at 3:23 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Congratulations to  DTNRG on reaching the below milestone in getting
this draft well on the way to being published.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: IETF-Announce [[email-masked]<mailto:[email-masked]>] On Behalf Of The IESG [[email-masked]<mailto:[email-masked]>]
Sent: 24 February 2014 17:40
To: Lars Eggert; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; The IESG; [email-masked]<mailto:[email-masked]>
Subject: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

Thank you,

The IESG Secretary

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Vint Cerf <[email-masked]>
Date: Tue, 25 Feb 2014 04:43:02 -0500

there is a lot more TCP and IP network readily available than others so,
statistically, this is not a surprise. I anticipate that LTE may prove
another supporting environment. Of course, there continues to be work in
deep space such as the latest laser comm tests to/from the moon at 600 Mb/s.

vint

On Tue, Feb 25, 2014 at 4:27 AM, <[email-masked]> wrote:

> From: IETF-Announce [[email-masked]<mailto:
> [email-masked]>] On Behalf Of The IESG [
> [email-masked]<mailto:[email-masked]>]
> To: Lars Eggert; [email-masked]<mailto:
> [email-masked]>; [email-masked]<mailto:
> [email-masked]>

---

From: Caini Carlo <[email-masked]>
Date: Tue, 25 Feb 2014 11:30:06 +0100

Dear Vint and Lloyd,
     In my opinion, the possibility of using TCP 
as convergence layer in a Bundle Protocol DTN 
architecture has many advantages that go beyond 
the mere compatibility with Internet and that can 
be achieved (in some selected but important 
cases) despite the challenges of the links.
To cite an example I have personally 
investigated, consider GEO satellite 
communications. In these the main challenge is 
the RTT of about 600 ms mainly due to the 
propagation time on the satellite link. With such 
a large RTT, TCP New Reno cannot provide 
satisfactory performance, especially in the 
presence of concurrent terrestrial TCP traffic 
(i.e. with short RTTs). The usual solutions are 
TCP splitting PEPs that divide the end-to-end 
paths into three legs: 1) from source to the 
first PEP, 2) between the two PEPs, 3) from PEP 
to destination. TCP splitting PEPs provide good 
performance but violate the end-to-end semantic 
of TCP and are ineffective with IPsec.
By contrast, the BP DTN architecture allows to 
"naturally" split the end-to-end connection into 
3 DTN hops (the same as before), which 
automatically solves the problem of RTT 
unfairness between satellite and terrestrial 
connection; you can use TCP and the first and the 
last, as they have no challenges at all; you can 
use whatever convergence layer you want in the 
intermediate connection (the satellite one), 
included TCP variants specialized for satellite. 
Note that on a link with less than 600ms and 
without (or with just minor disruption) these 
specialized variants of TCP work well (i.e. you 
do not need LTP). In short, in GEO communications 
you can have TCP, by choice, on all the DTN hops, 
with excellent performance. The price to pay with 
respect to PEPs is the lack of transparency, 
because you you need to install and use DTN on 
the end points. It may be worthwhile.

Yours,
    Carlo

At 10.43 25/02/2014, Vint Cerf wrote:
>there is a lot more TCP and IP network readily 
>available than others so, statistically, this is 
>not a surprise. I anticipate that LTE may prove 
>another supporting environment. Of course, there 
>continues to be work in deep space such as the 
>latest laser comm tests to/from the moon at 600 Mb/s.
>
>vint
>
>
>
>On Tue, Feb 25, 2014 at 4:27 AM, 
><<mailto:[email-masked]>[email-masked]> wrote:
>Vint,
>
><http://about.me/lloydwood>http://about.me/lloydwood
>From: Vint Cerf [<mailto:[email-masked]>[email-masked]]
>To: Wood L Â Dr (Electronic Eng)
>Cc: dtn-interest
>Subject: Re: [dtn-interest] FW: Results of 
>IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08
>
>Lloyd,
>This makes it possible to support applications 
>end to end over DTN including the Internet.
>On Tue, Feb 25, 2014 at 3:23 AM, 
><<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> 
>wrote:
>Congratulations to Â DTNRG on reaching the below milestone in getting
><http://about.me/lloydwood>http://about.me/lloydwood
>From: IETF-Announce 
>[<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>] 
>On Behalf Of The IESG 
>[<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>]
>To: Lars Eggert; 
><mailto:[email-masked]>[email-masked]<mailto:[email-masked]>; 
><mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
>Cc: 
><mailto:[email-masked]>[email-masked]<mailto:[email-masked]>; 
>The IESG; 
><mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
><http://datatracker.ietf.org/doc/conflict-review-irtf-dtnrg-tcp-clayer/>http://datatracker.ietf.org/doc/conflict-review-irtf-dtnrg-tcp-clayer/
>
><http://datatracker.ietf.org/doc/draft-irtf-dtnrg-tcp-clayer/>http://datatracker.ietf.org/doc/draft-irtf-dtnrg-tcp-clayer/
>
><mailto:[email-masked]>[email-masked]<mailto:[email-masked]>
><https://www.irtf.org/mailman/listinfo/dtn-interest>https://www.irtf.org/mailman/listinfo/dtn-interest
>
>

---

From: <[email-masked]>
Date: Tue, 25 Feb 2014 12:42:29 +0000

With newReno, only SACK matters now. (Though window scaling is still
a dark art, with little thanks to Windows XP.)

As it happens, I've spent the last couple of years dealing with PEP middlebox TCP
accelerators and caches for satellite links.

When supporting a number of ISPs backhauled via satellite links from the island
populations they themselves support, there are interesting scalability problems
with tracking the number of flows and resulting buffer state held over long
periods of time. It's interesting pushing the state of the art there.

The main difference between these 'transparent' proxies and a more explicit,
visible, hop-by-hop partitioning in the different domain conditions afforded by
bundling (or tuned visible http proxy caching) is that these get -used-.

Endpoints are dumb. Endpoints do dumb things. State at endpoints can't
be trusted. That TCP has congestion control and is trusted to control its
own state is increasingly an anomaly in a world where every link must have
protection against DoS attacks. TCP can't be trusted to do the right thing
through bottlenecks like satellite links.

While state in the network is undesirable, with PEPs, NAT and firewalls
(never mind QoS shaping or BGP) it's necessary - and it's state under the
explicit control of a (hopefully knowledgeable) network operator. The
'impedance mismatch' of capacity, speed and delay between the satellite
and terrestrial networks imposes QoS shaping, acceleration...it's not
something that can be resolved by itself.

In discussing whether the junction between the satellite and ground
network is a proxy, a bundling agent, or something else, we accept
that there must be some sort of stateful control there. We're
only debating what exact form that state takes.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Caini Carlo [[email-masked]]
Sent: 25 February 2014 10:30
To: Vint Cerf; Wood L  Dr (Electronic Eng)
Cc: dtn-interest
Subject: Re: [dtn-interest] FW: Results of IETF-conflict review for  draft-irtf-dtnrg-tcp-clayer-08

Dear Vint and Lloyd,

Yours,
    Carlo

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Tue, 25 Feb 2014 13:55:20 +0000

Are there any known "Operational" deployments of DTN?  I no NASA is investigating DTN, be we still do not have what I would call an Operational deployment.

Also, LTE is a connected network.  How would DTN help here?  Dropbox and email work pretty well in this situation as does text messaging and even voice conversations (with voice mail when disconnected).

Note, to the best of my knowledge, there was no high-rate DTN deployed on the Lunar Laser Communication Demonstration (LLCD).  Rather, DTN was sent over the link from one ground DTN agent to another.  I'm not sure at what rate.

http://www.nasa.gov/content/disruption-tolerant-networking-experiments-with-optical-communications/#.UwyepiQmXAY

Will
******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic

From: Vint Cerf <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 25, 2014 4:43 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: dtn-interest <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] FW: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

there is a lot more TCP and IP network readily available than others so, statistically, this is not a surprise. I anticipate that LTE may prove another supporting environment. Of course, there continues to be work in deep space such as the latest laser comm tests to/from the moon at 600 Mb/s.

vint

On Tue, Feb 25, 2014 at 4:27 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Vint,

thanks

Lloyd Wood
From: Vint Cerf [[email-masked]<mailto:[email-masked]>]

Lloyd,

vint

On Tue, Feb 25, 2014 at 3:23 AM, <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> wrote:
Congratulations to  DTNRG on reaching the below milestone in getting
this draft well on the way to being published.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: IETF-Announce [[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>] On Behalf Of The IESG [[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>]
Sent: 24 February 2014 17:40
To: Lars Eggert; [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>; The IESG; [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
Subject: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

Thank you,

The IESG Secretary

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 25 Feb 2014 13:58:50 +0000

Not sure whether this is operational - but some nice work by the folks
from Telefonica on time-shifting bulk transfers using DTN during
offpeak hours to transmit data at very minimal cost :

Delay Tolerant Bulk Data Transfers on the Internet
http://dl.acm.org/citation.cfm?doid=1555349.1555376

Arjuna

On 25 February 2014 13:55, Ivancic, William D. (GRC-RHN0)
<[email-masked]> wrote:
> Are there any known "Operational" deployments of DTN?  I no NASA is
> investigating DTN, be we still do not have what I would call an Operational
> deployment.
>
> Also, LTE is a connected network.  How would DTN help here?  Dropbox and
> email work pretty well in this situation as does text messaging and even
> voice conversations (with voice mail when disconnected).
>
> Note, to the best of my knowledge, there was no high-rate DTN deployed on
> the Lunar Laser Communication Demonstration (LLCD).  Rather, DTN was sent
> over the link from one ground DTN agent to another.  I'm not sure at what
> rate.
>
> From: Vint Cerf <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc: dtn-interest <[email-masked]>
>
>> <[email-masked]<mailto:[email-masked]>> wrote:
>> [[email-masked]<mailto:[email-masked]>] On
>> Behalf Of The IESG [[email-masked]<mailto:[email-masked]>]
>> [email-masked]<mailto:[email-masked]>;
>> [email-masked]<mailto:[email-masked]>
>> Cc: [email-masked]<mailto:[email-masked]>; The IESG;
>> [email-masked]<mailto:[email-masked]>

-- 
Arjuna Sathiaseelan | http://www.cl.cam.ac.uk/~as2330/

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 25 Feb 2014 14:03:09 +0000

One of the things we at Cambridge are working out with Joerg Ott and
others are to bring together IP, ICN and DTN together under a single
abstraction to support a diverse set of services..

link to our technical report is here if anyone is interested:
http://www.cl.cam.ac.uk/techreports/UCAM-CL-TR-841.pdf

Arjuna

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Tue, 25 Feb 2014 14:08:14 +0000

ARjuna,

This work was presented quite a while ago, I think at the DTNRG meeting in
2009 at Google in Mountain View.  I also do not know if it is or was
operational.  DTN at high rate has been a bit of a problem.  This is a
nice use of DTN as it is quite bounded and very simple network.

Will

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Tue, 25 Feb 2014 16:10:05 +0000

DTN has been in (limited) operational use on the International Space Station since 2009, conveying data from on-board biology experiments to a lab at the University of Colorado, Boulder.  DTN will become part of the operational infrastructure of ISS, available for use by all payload systems, sometime in 2015 when ISS change request 013799 is completed.

Will, you are correct that the tests of DTN over laser comm were among DTN nodes residing in machines on the ground: each bundle was sent from one bundle protocol agent via the laser link to the satellite and echoed (at link layer) back down to another BPA on Earth.  The bundles traversed cislunar distance, but there was no bundle protocol agent on the satellite.

Scott

From: dtn-interest [mailto:[email-masked]] On Behalf Of Ivancic, William D. (GRC-RHN0)
Sent: Tuesday, February 25, 2014 5:55 AM
To: Vint Cerf; [email-masked]
Cc: dtn-interest
Subject: Re: [dtn-interest] FW: Results of IETF-conflict review for draft-irtf-dtnrg-tcp-clayer-08

Will

vint

thanks

Lloyd Wood

Lloyd,

vint

Lloyd Wood

Thank you,

The IESG Secretary