Subject: [dtn-interest] Period of the discovery message

From: MEZGHANI Farouk <[email-masked]>
Date: Thu, 15 May 2014 14:59:59 +0200

Hi all,

I checked in IBR-DTN and I found that the discovery messages are 
exchanged periodically between neighbors each "1second".

Is it possible to exchange this period from "1second" to "4 second" ?
If yes, I appreciate if someone can tell me in what file I can find the 
parameter responsible for that.

Best regards,
Farouk

---

From: Sebastian Schildt <[email-masked]>
Date: Sun, 18 May 2014 21:04:29 +0200

Hello Farouk,

At the moment it is either on (1sek between announcements) or off for standard Linux/OS X and OpenWRT versions.  If you really need to change it start here

https://github.com/ibrdtn/ibrdtn/blob/master/ibrdtn/daemon/src/net/DiscoveryAgent.cpp

The Android version has some more tricks up its sleeves, only beaconing periodically when the WiFi state changed, as contunous announcements would drain the battery really fast.

For technical questions related to IBR-DTN usually the ibr-dtn mailing list is  a better place

https://mail.ibr.cs.tu-bs.de/listinfo/ibr-dtn

dtn-interest is rather about hmmm.. philosophies and attitudes regarding DTN (and Bundle Protocol) in general. So it is well worth following both lists :)

Sebastian

On 15 May 2014, at 14:59, MEZGHANI Farouk <[email-masked]> wrote:

> Hi all,
> 
> I checked in IBR-DTN and I found that the discovery messages are exchanged periodically between neighbors each "1second".
> 
> If yes, I appreciate if someone can tell me in what file I can find the parameter responsible for that.
> 
> Best regards,
> Farouk
> 
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest