Subject: [dtn-interest] FW: New Version Notification for draft-wood-dtnrg-http-dtn-delivery-08.txt

From: <[email-masked]>
Date: Tue, 6 May 2014 13:07:06 +0000

http://tools.ietf.org/html/draft-wood-dtnrg-http-dtn-delivery<http://tools.ietf.org/html/draft-wood-dtnrg-http-dtn-delivery-08>

Based on recent discussion, we have just updated our http-dtn draft.

http://sat-net.com/L.Wood/dtn/http-dtn

has related papers, and there's also some discussion of http-dtn in our

'Bundle of Problems' paper, which I may have mentioned previously.

>> In particular, the HTTP-DTN concept clearly merits serious
>> consideration as a way of addressing the well-known challenges of
>> delay-tolerant networking, but I don't think this BoF request
>> discussion is the right place to try to conduct that serious
>> consideration.
>
> I think Lloyd's http-dtn stuff is maybe one possible approach but the
> issue of whether or not an IETF WG prioritises ease of terrestrial
> deployment or prioritises minimal change to 5050 is basically
> independent of http-dtn. So we shouldn't get hung up on a false
> dichotomy there.
>
>> What I think would make more sense would be for a couple of
>> experimental HTTP-DTN implementations to be developed and exercised
>> in practical deployment scenarios, just as has been done with the
>> DTNRG's BP-based protocol suite over the past decade, so that we
>> can all get a better sense of the architecture's demonstrated
>> advantages and disadvantages.  The DTNRG seems to me to be the
>> right venue for that research.

Lloyd Wood
http://about.me/lloydwood

On Tuesday, 6 May 2014, 22:53, "[email-masked]" <[email-masked]> wrote:

A new version of I-D, draft-wood-dtnrg-http-dtn-delivery-08.txt
has been successfully submitted by Lloyd Wood and posted to the
IETF repository.

Name:        draft-wood-dtnrg-http-dtn-delivery
Revision:    08
Title:        Using HTTP for delivery in Delay/Disruption-Tolerant Networks
Document date:    2014-05-06
Group:        Individual Submission
Pages:        11
URL:            http://www.ietf.org/internet-drafts/draft-wood-dtnrg-http-dtn-delivery-08.txt
Status:        https://datatracker.ietf.org/doc/draft-wood-dtnrg-http-dtn-delivery/
Htmlized:      http://tools.ietf.org/html/draft-wood-dtnrg-http-dtn-delivery-08
Diff:          http://www.ietf.org/rfcdiff?url2=draft-wood-dtnrg-http-dtn-delivery-08

Abstract:
  This document describes how to use the Hypertext Transfer Protocol,
  HTTP, for communication across delay- and disruption-tolerant
  networks, by making every transit node in the network HTTP-capable,
  and doing peer HTTP transfers between nodes to move data hop-by-hop
  or subnet-by-subnet towards its final destination.  HTTP is well-
  known and straightforward to implement in these networks.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Kevin Fall <[email-masked]>
Date: Tue, 6 May 2014 13:05:22 -0400

I'd suggest that if you wish to reference material outside RFCs and
you wish to reference your problems paper, you also reference the
architectural retrospective paper and possibly Ion Stoica's "HTTP as
the narrow waist of the future internet" paper from HotNets-IX.  I'd
also suggest the (work in progress) from 2011 reference be fixed
somehow.

- Kevin

On Tue, May 6, 2014 at 9:07 AM,  <[email-masked]> wrote:
> http://tools.ietf.org/html/draft-wood-dtnrg-http-dtn-delivery
>
> URL:
> http://www.ietf.org/internet-drafts/draft-wood-dtnrg-http-dtn-delivery-08.txt
> Status:
> https://datatracker.ietf.org/doc/draft-wood-dtnrg-http-dtn-delivery/
> Htmlized:
> http://tools.ietf.org/html/draft-wood-dtnrg-http-dtn-delivery-08
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-wood-dtnrg-http-dtn-delivery-08
>
> Abstract:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: <[email-masked]>
Date: Tue, 6 May 2014 23:09:31 +0000

Thanks, Kevin.

Our Bundle of Problems paper cites your architectural paper.

On Stoica/Popa's work,
http://www.eecs.berkeley.edu/Pubs/TechRpts/2012/EECS-2012-5.pdf
HTTP: an evolvable narrow waist for the future internet, Popa, Wendell, Ghodsi and Stoica, Tech report UCB-EECS-2012-5, University of California at Berkeley, 4 Jan 2012
is even more interesting (and less constrained for space) than their earlier Hotnets 2010 paper that you mention. It shows use of explicit intermediaries in http deliveries, and that http use performed well with little overhead. That work seems to be heading in HTTP-DTN's direction.

Thanks for the pointer!

Lloyd Wood
http://sat-net.com/L.Wood/dtn/http-dtn
________________________________________
From: [email-masked] <[email-masked]> on behalf of Kevin Fall <[email-masked]>
Sent: Wednesday, 7 May 2014 3:05 AM
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]
Subject: Re: [dtn-interest] FW: New Version Notification for draft-wood-dtnrg-http-dtn-delivery-08.txt

- Kevin

---

From: <[email-masked]>
Date: Sat, 10 May 2014 11:28:11 +0000

Oh, there's a public HTTP-DTN implementation (with open MIT License) in ManP2P-NG.

https://github.com/ComputerNetworks-UFRGS/ManP2P-ng/

Papers describing this HTTP-DTN implementation include:

http://dx.doi.org/10.1109/ISCC.2013.6755026

Self-* properties and P2P technology on disruption-tolerant management,
J. Campos Nobre, P. Arthur Pinheiro Rosa Duarte, L. Zambenedetti
Granville and L. Margarida Rockenbach Tarouco, 2013 IEEE Symposium on
Computers and Communications (ISCC), pp. 676-681, 7-10 July 2013.

http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=6573064
Delay-Tolerant Management Using Self-* Properties and P2P Technology,
J. Campos Nobre, P. Arthur Pinheiro Rosa Duarte, L. Zambenedetti
Granville and L. Margarida Rockenbach Tarouco, IFIP/IEEE International
Symposium on Integrated Network Management (IM 2013), Ghent, pp.
728-731, 27-31 May 2013.

Lloyd Wood
http://sat-net.com/L.Wood/dtn/http-dtn.html
________________________________
From: Wood L Dr (Electronic Eng)
Sent: Tuesday, 6 May 2014 11:07 PM
To: [email-masked]
Subject: FW: New Version Notification for draft-wood-dtnrg-http-dtn-delivery-08.txt

Abstract:

The IETF Secretariat

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Sat, 10 May 2014 20:28:59 -0300

Hi there.
Just to add up some context on Lloyd's email.
The HTTP-DTN code mentioned is a component of a prototype P2P-based
network management framework called ManP2P-ng. My research group
developed this component in order to investigate DTN management
considering terrestrial environments.
The code is really experimental (pre-alpha) and it is based on
previous versions of the HTTP-DTN draft. Thus, I am not sure how it
compares to the last draft.
Cheers.

Jéferson Campos Nobre
PhD Student
Computer Networks Group -  Institute of Informatics
Federal University of Rio Grande do Sul
http://www.inf.ufrgs.br/~jcnobre

On Sat, May 10, 2014 at 8:28 AM,  <[email-masked]> wrote:
> Subject: FW: New Version Notification for
> draft-wood-dtnrg-http-dtn-delivery-08.txt
>
>

---

From: <[email-masked]>
Date: Sun, 11 May 2014 14:00:52 +0000

Thanks, Jéferson.

Changes from even -00 of the http-dtn draft aren't that major. Interesting how the IETF's legal boilerplate has changed over the years, though...

http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=draft-wood-dtnrg-http-dtn-delivery-00.txt&url2=draft-wood-dtnrg-http-dtn-delivery-08.txt

Lloyd Wood
http://sat-net.com/L.Wood/dtn/http-dtn.html
________________________________________
From: [email-masked] <[email-masked]> on behalf of Jéferson Campos Nobre <[email-masked]>
Sent: Sunday, 11 May 2014 9:28 AM
To: [email-masked]; Wood L  Dr (Electronic Eng)
Subject: Re: [dtn-interest] HTTP-DTN implementations was RE: New Version Notification for draft-wood-dtnrg-http-dtn-delivery-08.txt

Hi there.

Jéferson Campos Nobre
PhD Student