Subject: [dtn-interest] Discovery message

From: Ghada Jaber <[email-masked]>
Date: Wed, 14 May 2014 10:14:46 +0100 (BST)

Hi all,

I have checked the discovery message used between dtn users. This message include Data which contains (user 
name, IP address, port number). 

I want to add, in the discovery message, another information "seq" which contains integer values.

For instance seq=[2,5,0,6,8].

Thus, when receiving the discovery messages, i can see the sequences of my neighbors.

Where can i add this ? In which class or method ?

I am using an adhoc network connecting 3 machines.

Thanks for your help,

Best Regards,
Ghada

Ghada Jaber 
Etudiante en 5eme année Réseau informatique et Telecommunication a l'INSAT 
Stagiaire a l'IRIT/ENSEEIHT
Tel : 003385681703
email : [email-masked]
Skype : ghada.jaber90

---

From: Flavio Esposito <[email-masked]>
Date: Wed, 14 May 2014 07:35:15 -0500

Hi Ghada,
leveraging an earlier work of Jorg Ott on integrating DTN and MANET,
we have done something very similar to what you want to do some time ago.

We augmented the DTN discovery to enable MANET routing policy
programmability,  (before we knew about OpenFlow; we used in fact
iptables).
Here you can find some references : http://csr.bu.edu/preda/

- Flavio

Flavio Esposito
Ph.D. Computer Science Department,
Boston University,
Member of Advanced Technology Group,
Exegy Inc.
http://cs-people.bu.edu/flavio

2014-05-14 4:14 GMT-05:00 Ghada Jaber <[email-masked]>:

> Hi all,
>
> I have checked the discovery message used between dtn users. This message
> include Data which contains (user name, IP address, port number).
>
> Etudiante en 5eme année Réseau informatique et Telecommunication a l'*INSAT
> *
> Stagiaire a l'*IRIT*/*ENSEEIHT*
> Tel : 003385681703
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>
>

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Thu, 15 May 2014 13:25:34 +0000

NASA Glenn Research Center did some work on DTN discovery over IPv4 a number of years ago.  The code was tested and worked.

http://roland.grc.nasa.gov/~ivancic/DTN/Bundle%20Agent%20Discovery/neonet2007-wyllie.pdf

Work was done by  Jim Wyllie.
Here is a link to an expired draft.
https://tools.ietf.org/html/draft-wyllie-dtnrg-badisc-01

Will

From: Flavio Esposito <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 14, 2014 8:35 AM
To: Ghada Jaber <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] Discovery message

Hi Ghada,

We augmented the DTN discovery to enable MANET routing policy programmability,  (before we knew about OpenFlow; we used in fact iptables).
Here you can find some references : http://csr.bu.edu/preda/

- Flavio

Flavio Esposito

2014-05-14 4:14 GMT-05:00 Ghada Jaber <[email-masked]<mailto:[email-masked]>>:
Hi all,

I have checked the discovery message used between dtn users. This message include Data which contains (user name, IP address, port number).

Thanks for your help,

Best Regards,
Ghada

Ghada Jaber
Etudiante en 5eme année Réseau informatique et Telecommunication a l'INSAT
Stagiaire a l'IRIT/ENSEEIHT
Tel :003385681703
email : [email-masked]<mailto:[email-masked]>
Skype : ghada.jaber90

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Thu, 15 May 2014 14:49:14 +0000

Jim's code is on the DTNGR wiki

http://www.dtnrg.org/wiki/DraftAutodiscoveryCode

******************************
William D. Ivancic

From: <Ivancic>, William Ivancic <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 15, 2014 9:25 AM
To: Flavio Esposito <[email-masked]<mailto:[email-masked]>>, Ghada Jaber <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] Discovery message

Will

Hi Ghada,

- Flavio

Flavio Esposito

Thanks for your help,

Best Regards,
Ghada

Ghada Jaber

---

From: Flavio Esposito <[email-masked]>
Date: Thu, 15 May 2014 10:19:44 -0500

Our code is also available.
The version (including the testbed) demonstrated at Mobicom '08 is
here<http://csr.bu.edu/preda/PreDA_files/PreDA-code.zip>.

We also released a user manual on how to install and run the testbed on (a
VM running) Ubuntu.
http://csr.bu.edu/preda/PreDA_files/PreDA-UserManual.pdf

Flavio Esposito

2014-05-15 9:49 GMT-05:00 Ivancic, William D. (GRC-RHN0) <
[email-masked]>:

>   From: <Ivancic>, William Ivancic <[email-masked]>
> To: Flavio Esposito <[email-masked]>, Ghada Jaber <[email-masked]>
>
> Cc: "[email-masked]" <[email-masked]>
>   NASA Glenn Research Center did some work on DTN discovery over IPv4 a
> number of years ago.  The code was tested and worked.
>
>
> http://roland.grc.nasa.gov/~ivancic/DTN/Bundle%20Agent%20Discovery/neonet2007-wyllie.pdf<http://roland.grc.nasa.gov/%7Eivancic/DTN/Bundle%20Agent%20Discovery/neonet2007-wyllie.pdf>
>
>   From: Flavio Esposito <[email-masked]>
> To: Ghada Jaber <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
>>  I have checked the discovery message used between dtn users. This
>> message include Data which contains (user name, IP address, port number).
>>