Subject: [dtn-interest] (dtnping) WARNING : TCPConnection & WARNING BundleCore

From: MEZGHANI Farouk <[email-masked]>
Date: Thu, 16 Oct 2014 11:26:07 +0200

Hello,

I'm trying to do a "dtnping" between two dtn nodes (node1 and node2).
from node 2  :  dtnping dtn://node1/echo
I have noticed that they can see each other, however, when I try to 
make a ping from node
2 to node 1, I get this warning :

WARNING: bundle rejected: bundle has expired
([415720186.377] dtn://node2.dtn/zsKZSPktexxyNvJ -> 
dtn://node1.dtn/echo)
WARNING: bundle has been rejected: bundle is expired

I cannot understand the reason. Someone have an idea how may I resolve 
it?
Thanks!
Best Regards,
Farouk

---

--------------------------------------------------------
PhD student. Farouk MEZGHANI
Laboratoire IRIT/ENSEEIHT équipe IRT
--------------------------------------------------------
Tél. +33 (0)5 34 32 22 16

email: [email-masked]
WWW: http://mezghani.perso.enseeiht.fr
--------------------------------------------------------

---

From: Sebastian Schildt <[email-masked]>
Date: Thu, 16 Oct 2014 11:49:26 +0200

Hi,

make sure both nodes have the correct (or rather the same) time. If one for example one node has an RTC , but the other one doesn’t and think it is 1970, the former node will not accept bundles form the latter (unless you set bundle lifetime to 50 years…)

Sebastian

On 16 Oct 2014, at 11:26, MEZGHANI Farouk <[email-masked]> wrote:

> I have noticed that they can see each other, however, when I try to make a ping from node
> ([415720186.377] dtn://node2.dtn/zsKZSPktexxyNvJ -> dtn://node1.dtn/echo)
> I cannot understand the reason. Someone have an idea how may I resolve it?
> Thanks!
> Best Regards,
> Farouk
> 
> ---
> 
> 
> 
> 
> 
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Michele Rodolfi <[email-masked]>
Date: Thu, 16 Oct 2014 11:57:28 +0200

Hi Farouk
try to check if the clock of the two nodes are synchronized
you can use an ntp server to get clock synchronization

Michele