Subject: [dtn-interest] New routing solutions?

From: waldir moreira <[email-masked]>
Date: Wed, 12 Nov 2014 12:16:46 +0000

Dear colleagues,
Recently our draft on social-aware opportunistic routing has expired (http://www.ietf.org/archive/id/draft-moreira-dlife-04.txt). 
Despite of a first interest from the DTNRG by the time of its first appearance, our draft has not received any technical feedback as expected (it remained as individual submission and no stream defined).    
Thus, the intention of this email is to check with my colleagues whether there is any interest from the DTNRG (or its IETF WG counterpart) on new routing solutions. 
I recall that some emails were exchanged about a generic framework to allow better development of new solutions, but that didnt go far as well.
Be it for new routing approaches or for a generic routing framework, we would be more than happy to contribute if there is still any interest from this RG in such direction. 
Best regards,
Waldir Aranha Moreira Junior, Ph.D.
Researcher at the Association for Research and Development in Cognition and People Centric Computing - COPELABSInvited Professor at University Lusofona - ULHT/ULPExternal collaborator of the Research Group on Computer Networks and Multimedia Communications - GERCOM/UFPA
LinkedIn profile

---

From: Antonio Carlos de Oliveira Junior <[email-masked]>
Date: Wed, 12 Nov 2014 15:12:50 -0200

Dear Waldir Moreira,

Our group are working on such approaches using dLife protocol as
benchmark on ONE simulator. We believe that daily life routines can
improve the message dissemination.

All the best.
Antonio

On 12 November 2014 10:16, waldir moreira <[email-masked]> wrote:
> Dear colleagues,
>
> Recently our draft on social-aware opportunistic routing has expired
> (http://www.ietf.org/archive/id/draft-moreira-dlife-04.txt).
>
> Despite of a first interest from the DTNRG by the time of its first
> appearance, our draft has not received any technical feedback as expected
> (it remained as individual submission and no stream defined).
>
> Thus, the intention of this email is to check with my colleagues whether
> there is any interest from the DTNRG (or its IETF WG counterpart) on new
> routing solutions.
>
> I recall that some emails were exchanged about a generic framework to allow
> better development of new solutions, but that didnt go far as well.
>
> Be it for new routing approaches or for a generic routing framework, we
> would be more than happy to contribute if there is still any interest from
> this RG in such direction.
>
> Best regards,
>
> Researcher at the Association for Research and Development in Cognition and
> People Centric Computing - COPELABS
> Invited Professor at University Lusofona - ULHT/ULP
> External collaborator of the Research Group on Computer Networks and
> Multimedia Communications - GERCOM/UFPA
> LinkedIn profile
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

-- 
Prof. Antonio Carlos de Oliveira Junior, Ph.D. in Computer Science
Universidade Federal de Goiás (UFG/RC)
Instituto de Bio-Tecnologia (Bio-Tec)
Departamento de Ciência da Computação (DCC)
http://antonio.catalao.ufg.br

---

From: "Ciprian Dobre" <[email-masked]>
Date: Wed, 12 Nov 2014 20:04:27 +0200

Dear Antonio,

A possible alternative in this direction, using daily life routines, is SPRINT: http://ieeexplore.ieee.org/xpl/login.jsp?tp=&arnumber=6583442&url=http%3A%2F%2Fieeexplore.ieee.org%2Fxpls%2Fabs_all.jsp%3Farnumber%3D6583442. 

Best regards,
Ciprian

-------------------
Ciprian Dobre, Associate Professor, PhD.
University POLITEHNICA of Bucharest
313, Splaiul Independentei, Office EG403, sector 6, 060042
Bucharest, Romania
Phone: +40.745.174.359, Fax: +40.318.163.028
Web: http://cipsm.hpc.pub.ro
LinkedIn: http://www.linkedin.com/in/cipriandobre

-----Original Message-----
From: dtn-interest [mailto:[email-masked]] On Behalf Of Antonio Carlos de Oliveira Junior
Sent: Wednesday, November 12, 2014 7:13 PM
To: waldir moreira
Cc: [email-masked]
Subject: Re: [dtn-interest] New routing solutions?

Dear Waldir Moreira,

Our group are working on such approaches using dLife protocol as benchmark on ONE simulator. We believe that daily life routines can improve the message dissemination.

All the best.
Antonio

On 12 November 2014 10:16, waldir moreira <[email-masked]> wrote:
> appearance, our draft has not received any technical feedback as 
> expected (it remained as individual submission and no stream defined).
>
> Thus, the intention of this email is to check with my colleagues 
> whether there is any interest from the DTNRG (or its IETF WG 
> counterpart) on new routing solutions.
>
> I recall that some emails were exchanged about a generic framework to 
> allow better development of new solutions, but that didnt go far as well.
>
> Be it for new routing approaches or for a generic routing framework, 
> we would be more than happy to contribute if there is still any 
> interest from this RG in such direction.
>
> Best regards,
>
> Researcher at the Association for Research and Development in 
> Cognition and People Centric Computing - COPELABS Invited Professor at 
> University Lusofona - ULHT/ULP External collaborator of the Research 
> Group on Computer Networks and Multimedia Communications - GERCOM/UFPA 
> LinkedIn profile
>

--
Prof. Antonio Carlos de Oliveira Junior, Ph.D. in Computer Science Universidade Federal de Goiás (UFG/RC) Instituto de Bio-Tecnologia (Bio-Tec) Departamento de Ciência da Computação (DCC) http://antonio.catalao.ufg.br

---

From: waldir moreira <[email-masked]>
Date: Wed, 12 Nov 2014 18:28:14 +0000

Dear Will,
Thanks for the email. 
I agree with you regarding the access to connectivity in urban settings. However, in many situations (and considering I dont want to pay 3G access), I still find myself in "shadowed" areas (tons of closed APs, lots of resourceful peers around that I dont know about their capabilities), and maybe with such solution we could mitigate such situations. 
Still, this situation and the ones you mention are application scenarios, each with their own challenges (privacy, reliability, to name a few) and very good ones.
But the point I raise here is that if it is enough for users to "bring their own or do simple store-carry-and-forward",  does it mean that regarding routing the DTNRG is done with PROPHET?
Cheers,       
Waldir

From: [email-masked]
To: [email-masked]
Subject: Re: [dtn-interest] New routing solutions?
Date: Wed, 12 Nov 2014 14:39:27 +0000

Waldir,

Unfortunately most activity in DTNRG has dried up over the past two years.  I'm sure you noticed.

My understanding is the the IETF DTN Working Group is not sanctioned to work routing at this time.  So, DTNRG is the place for this.

I do like your overall approach.  However, in Urban environments, I am generally not disconnected and can use email or dropbox or a whole lot of other alternatives to communicate.  

On the surface, I think it would be useful for something like what is going on in Syria.  But, when thinking of practical use, I don't think I want anyone knowing who I have come in contact with in such situations. It would put all my contacts in danger.

IMHO, first responders already have solutions for communications.  They either bring their own or do simple store-carry-and-forward via file transfers when the return to home base.

Will

From: waldir moreira <[email-masked]>

Date: Wednesday, November 12, 2014 7:16 AM

To: "[email-masked]" <[email-masked]>

Subject: [dtn-interest] New routing solutions?

Dear colleagues,

Best regards,

Researcher at the Association for Research and Development in Cognition and People Centric Computing - COPELABS
Invited Professor at University Lusofona - ULHT/ULP
External collaborator of the Research Group on Computer Networks and Multimedia Communications - GERCOM/UFPA

LinkedIn profile

---

From: waldir moreira <[email-masked]>
Date: Wed, 12 Nov 2014 18:32:56 +0000

Dear Antonio, Ciprian,
I do believe we could further explorer DTN scenarios as well.
Thanks for sharing, Ciprian.

Waldir 

> From: [email-masked]
> To: [email-masked]; [email-masked]
> CC: [email-masked]
> Subject: RE: [dtn-interest] New routing solutions?
> Date: Wed, 12 Nov 2014 20:04:27 +0200
> 
> Dear Antonio,
>

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 12 Nov 2014 18:56:19 +0000

I don't routing is done with PROPHET.  I believe there is much much work needed for routing and other items.  If the research group is willing to do work, I think this is a worthy item.  It is research and anything learned can be applied here or elsewhere.

I the spirit of "Disconnection Tolerant Networking", I think DTNRG is the place to be.  But, without much participation, you may be better off as an individual submission.

From: waldir moreira <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 12, 2014 1:28 PM
To: William Ivancic <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [dtn-interest] New routing solutions?

Dear Will,

Thanks for the email.

Cheers,

Waldir

________________________________
From: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn-interest] New routing solutions?
Date: Wed, 12 Nov 2014 14:39:27 +0000

Waldir,

Will

From: waldir moreira <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 12, 2014 7:16 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dtn-interest] New routing solutions?

Dear colleagues,

Best regards,

LinkedIn profile<http://www.linkedin.com/in/waldirmoreira>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 12 Nov 2014 20:15:53 +0000

HI, Waldir.  One possibility: we are starting to look at the possibility of basing a generic DTN routing framework on Contact Graph Routing, by extending the CGR notion of a "contact plan" to include not only scheduled contacts but also predicted contacts (that is, enabling association of a probability less than 1.0 with an identified contact).  We think we've got a reasonable concept of how to use somewhat-probable contacts to direct forwarding efficiently in a general way, but that leaves wide open the question of how to populate the contact plan with those somewhat-probable contacts; the problem of inferring such things from social contacts or patterns of movement or whatever remains less-than-comprehensively solved.

Scott
________________________________
From: dtn-interest [[email-masked]] on behalf of waldir moreira [[email-masked]]
Sent: Wednesday, November 12, 2014 4:16 AM
To: [email-masked]
Subject: [dtn-interest] New routing solutions?

Dear colleagues,

Best regards,

---

From: Anders Lindgren <[email-masked]>
Date: Thu, 13 Nov 2014 02:27:37 +0100

Waldir,

As you note, the generic opportunistic routing framework (gorf) draft
hasn't progressed much lately. However, this has unfortunately been
the case for the whole RG for a while (might be partly due to a lot of
people focusing efforts on the startup of the DTNWG, so once that one
is up and running, we might have a better idea of the role and
interest of the RG...).

I am still interested in this, so if there are interest from others in
this, I'd be happy to pick up work on the framework draft again and
try to progress that further.

/Anders

---

From: waldir moreira <[email-masked]>
Date: Thu, 13 Nov 2014 16:36:21 +0000

Thanks for your reply, Scott.
So in other words, you think we should mature more the inference from social-based contacts, as to allow proper application to the CGR contact plan?   

Waldir

From: [email-masked]
To: [email-masked]
Date: Wed, 12 Nov 2014 20:15:53 +0000
Subject: Re: [dtn-interest] New routing solutions?

HI, Waldir.  One possibility: we are starting to look at the possibility of basing a generic DTN routing framework on Contact Graph Routing, by extending the CGR notion of a "contact
 plan" to include not only scheduled contacts but also predicted contacts (that is, enabling association of a probability less than 1.0 with an identified contact).  We think we've got a reasonable concept of how to use somewhat-probable contacts to direct
 forwarding efficiently in a general way, but that leaves wide open the question of how to populate the contact plan with those somewhat-probable contacts; the problem of inferring such things from social contacts or patterns of movement or whatever remains
 less-than-comprehensively solved.

Scott

Dear colleagues,

Best regards,

LinkedIn profile

---

From: waldir moreira <[email-masked]>
Date: Thu, 13 Nov 2014 16:41:46 +0000

Dear Anders,
Thanks for your email.Yes, I noticed the efforts are towards the DTNWG.Still, my concern is whether DTNRG has interest in accepting new routing solutions.I can see that the interest is there, and perhaps we should come up with a plan to follow with the framework.
BR, 

Waldir 

> From: [email-masked]
> Date: Thu, 13 Nov 2014 02:27:37 +0100

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Thu, 13 Nov 2014 16:57:58 +0000

Yes, for the purposes of the development I was talking about it would be great to have a really capable source of somewhat-probable contacts.

Scott
________________________________
From: waldir moreira [[email-masked]]
Sent: Thursday, November 13, 2014 8:35 AM
To: Burleigh, Scott C (312B); [email-masked]
Subject: RE: [dtn-interest] New routing solutions?

Waldir

Scott

Dear colleagues,

Best regards,

_______________________________________________ dtn-interest mailing list [email-masked] https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Nov 2014 17:11:01 +0000

On 13/11/14 16:57, Burleigh, Scott C (312B) wrote:
> Yes, for the purposes of the development I was talking about it would
> be great to have a really capable source of somewhat-probable
> contacts.

We put all the 2010 N4C contacts up on a web server. [1]
Someone (likely Elwyn or me;-) would probably have to help
deciphering formats but there's a bunch of them there and
some pictures [2] to help (and the code to generate all
those from DTN2 logs).

We also have some others but 2010 is probably the most useful
set we have for remote area scenarios.

S.

[1] http://dtn.dsg.cs.tcd.ie/n4c-summer10/
[2] http://down.dsg.cs.tcd.ie/summer10/contacts/pairs/pairs.html

> 
> Scott ________________________________ From: waldir moreira
> [[email-masked]] Sent: Thursday, November 13, 2014 8:35
> AM To: Burleigh, Scott C (312B); [email-masked] Subject: RE:
> [dtn-interest] New routing solutions?
> 
> So in other words, you think we should mature more the inference from
> social-based contacts, as to allow proper application to the CGR
> contact plan?
> 
> Waldir
> 
> 
> ________________________________ From: [email-masked] 
> To: [email-masked] Date: Wed, 12 Nov 2014 20:15:53 +0000 
> HI, Waldir.  One possibility: we are starting to look at the
> possibility of basing a generic DTN routing framework on Contact
> Graph Routing, by extending the CGR notion of a "contact plan" to
> include not only scheduled contacts but also predicted contacts (that
> is, enabling association of a probability less than 1.0 with an
> identified contact).  We think we've got a reasonable concept of how
> to use somewhat-probable contacts to direct forwarding efficiently in
> a general way, but that leaves wide open the question of how to
> populate the contact plan with those somewhat-probable contacts; the
> problem of inferring such things from social contacts or patterns of
> movement or whatever remains less-than-comprehensively solved.
> 
> Scott ________________________________ From: dtn-interest
> [[email-masked]] on behalf of waldir moreira
> [[email-masked]] Sent: Wednesday, November 12, 2014 4:16 AM To:
> [email-masked] Subject: [dtn-interest] New routing solutions?
> 
> Dear colleagues,
> 
> Waldir Aranha Moreira Junior, Ph.D. Researcher at the Association for
> Research and Development in Cognition and People Centric Computing -
> COPELABS Invited Professor at University Lusofona - ULHT/ULP External
> collaborator of the Research Group on Computer Networks and
> Multimedia Communications - GERCOM/UFPA LinkedIn
> profile<http://www.linkedin.com/in/waldirmoreira>
> 
> _______________________________________________ dtn-interest mailing
> list [email-masked]
> _______________________________________________ dtn-interest mailing
> list [email-masked]

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Thu, 13 Nov 2014 18:58:51 +0000

Thanks, Stephen, that will be extremely helpful when we get to the point of having something to test.

The other angle, which I thought Waldir was talking about, is development of software that infers somewhat-probable contacts (from social media interactions, contact history, whatever) on an ongoing basis, that could be integrated with a CGR-based forwarding daemon.  ION provides an open API for inserting contacts into a node's contact plan, so I think this interface can be kept pretty clean.  Notionally, I would be glad to see any number of clever contact inference engines operating concurrently and cooperating in keeping a given node's contact plan as comprehensive and accurate as possible, so that the extended-CGR forwarding based on that probabilistic time-varying topology information can be made as efficient as possible.

Scott
________________________________________
From: Stephen Farrell [[email-masked]]
Sent: Thursday, November 13, 2014 9:11 AM
To: Burleigh, Scott C (312B); [email-masked]
Subject: Re: [dtn-interest] New routing solutions?

S.

---

From: waldir moreira <[email-masked]>
Date: Fri, 14 Nov 2014 12:50:07 +0000

Thats right, Scott.
I think if we worked the generic routing framework as mentioned by Anders, we would certainly have an idea of the existing core routing algorithms that could be added to ION as to allow the feeding of the contact plan. dLife, SPRINT, SCORP, .. do consider the "ongoing basis" as to have a snapshot of the actual moment regarding relevant contact (considering the different levels of social interaction between nodes). This could probably make the collection of contact inference engines to allow the extended-CGR. The outcome would be a 'universal' routing solution that could be employed in sparse and dense DTN scenarios. 

Waldir 

> Date: Thu, 13 Nov 2014 18:58:51 +0000

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Fri, 14 Nov 2014 13:29:55 +0000

Yes, that's just the sort of ecosystem I am hoping for.

Scott
Sent: Friday, November 14, 2014 4:50 AM

Thats right, Scott.

I think if we worked the generic routing framework as mentioned by Anders, we would certainly have an idea of the existing core routing algorithms that could be added to ION as to allow the feeding of the contact plan.
dLife, SPRINT, SCORP, .. do consider the "ongoing basis" as to have a snapshot of the actual moment regarding relevant contact (considering the different levels of social interaction between nodes). This could probably make the collection of contact inference engines to allow the extended-CGR.
The outcome would be a 'universal' routing solution that could be employed in sparse and dense DTN scenarios.

Waldir

---

From: "Birrane, Edward J." <[email-masked]>
Date: Fri, 21 Nov 2014 22:59:26 +0000

Waldir, Scott,

  I have been looking at the idea of contact inference engines for some time and I think there is something usable there. I've proposed some initial inference adapters relating to PROPHET and a generalized routing framework built on a modified contact graph.  I would be happy (and excited) to continue this research with anyone interested and think it could be a valuable undertaking within DTNRG.

-Ed

---
Ed Birrane
Principal Professional Staff, Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

From: dtn-interest [mailto:[email-masked]] On Behalf Of Burleigh, Scott C (312B)
Sent: Friday, November 14, 2014 8:30 AM
To: waldir moreira; [email-masked]
Subject: Re: [dtn-interest] New routing solutions?

Scott
To: [email-masked]<mailto:[email-masked]>

Waldir

> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> To: Burleigh, Scott C (312B); [email-masked]<mailto:[email-masked]>
> > AM To: Burleigh, Scott C (312B); [email-masked]<mailto:[email-masked]> Subject: RE:
> > ________________________________ From: [email-masked]<mailto:[email-masked]>
> > To: [email-masked]<mailto:[email-masked]> Date: Wed, 12 Nov 2014 20:15:53 +0000
> > [email-masked]<mailto:[email-masked]> Subject: [dtn-interest] New routing solutions?
> >
> > Dear colleagues,
> >
> > list [email-masked]<mailto:[email-masked]>
> > list [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Sun, 23 Nov 2014 22:24:31 -0200

Hi there.
It would be good to have a generalized framework, e.g. to evaluate
different routing algorithms.
Besides that, I think it is a nice way to realize how much interest
the DTNRG attracts after the DTNWG start.
Cheers.

Jéferson Campos Nobre
PhD Student
Computer Networks Group -  Institute of Informatics
Federal University of Rio Grande do Sul
http://www.inf.ufrgs.br/~jcnobre

On Fri, Nov 21, 2014 at 8:59 PM, Birrane, Edward J.
<[email-masked]> wrote:
> Waldir, Scott,
>
>
>
>   I have been looking at the idea of contact inference engines for some time
> and I think there is something usable there. I’ve proposed some initial
> inference adapters relating to PROPHET and a generalized routing framework
> built on a modified contact graph.  I would be happy (and excited) to
> continue this research with anyone interested and think it could be a
> valuable undertaking within DTNRG.
>
>
>
> -Ed
>
>
>
> ---
> Ed Birrane
>
> I think if we worked the generic routing framework as mentioned by Anders,
> we would certainly have an idea of the existing core routing algorithms that
> could be added to ION as to allow the feeding of the contact plan.
>
> dLife, SPRINT, SCORP, .. do consider the "ongoing basis" as to have a
> snapshot of the actual moment regarding relevant contact (considering the
> different levels of social interaction between nodes). This could probably
> make the collection of contact inference engines to allow the extended-CGR.
>
>> The other angle, which I thought Waldir was talking about, is development
>> of software that infers somewhat-probable contacts (from social media
>> interactions, contact history, whatever) on an ongoing basis, that could be
>> integrated with a CGR-based forwarding daemon. ION provides an open API for
>> inserting contacts into a node's contact plan, so I think this interface can
>> be kept pretty clean. Notionally, I would be glad to see any number of
>> clever contact inference engines operating concurrently and cooperating in
>> keeping a given node's contact plan as comprehensive and accurate as
>> possible, so that the extended-CGR forwarding based on that probabilistic
>> time-varying topology information can be made as efficient as possible.
>>
>> Scott

---

From: waldir moreira <[email-masked]>
Date: Tue, 25 Nov 2014 10:08:21 +0000

Dear Anders, 
What would be the best approach for continuing with the efforts towards the common framework?I'd be happy to contribute and as I can see there are other colleagues interested in such framework.

Waldir 

> Date: Sun, 23 Nov 2014 22:24:31 -0200
> From: [email-masked]
> To: [email-masked]