Subject: [dtn-interest] How to get wifi signal strength in ad hoc mode

From: Ahmad Zainudin <[email-masked]>
Date: Thu, 1 Oct 2015 20:11:15 +0700

Hai All,

I am trying to modify a flood routing that selects 2 devices (as
intermediate node) to communicate with according to their signal strength.
Can anyone please help me on how i can get the signal strength of currently
connected devices in an ad hoc mode.

Thanks,
Zai

---

From: Hugo Cruz <[email-masked]>
Date: Thu, 1 Oct 2015 17:28:08 +0200

can you give more elements for helping you?
which platforms do you use? chipset and fw;
can you acces to the lower layer information (phy?)

Best regards

On Thu, Oct 1, 2015 at 3:11 PM, Ahmad Zainudin <
[email-masked]> wrote:

> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>
>

---

From: Ahmad Zainudin <[email-masked]>
Date: Fri, 2 Oct 2015 06:05:16 +0700

Thanks Hugo for your response,
I use 5 raspberry pi 2 as dtn node with raspbian operating system and
TL-WN722N TP-LINK usb wireless adapter.

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 2 Oct 2015 11:56:11 +0200

is the kernel of this platform supporting "radio tap" headers?  If yes, 
one can get the power levels by listening to IP packets which are 
preceded by these headers and contain power levels.

Alex

Le 02/10/2015 01:05, Ahmad Zainudin a écrit :
> On Thu, Oct 1, 2015 at 10:28 PM, Hugo Cruz <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     On Thu, Oct 1, 2015 at 3:11 PM, Ahmad Zainudin
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Hai All,
>
>         intermediate node) to communicate with according to their signal
>         strength. Can anyone please help me on how i can get the signal
>         strength of currently connected devices in an ad hoc mode.
>
>         Thanks,
>         Zai
>
>         [email-masked] <mailto:[email-masked]>