Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

From: Nik Ansell <[email-masked]>
Date: Wed, 11 May 2016 08:07:49 +0400

A good way to get in touch with the IBR-DTN guys is to use the mailing list
below.

[email-masked]

The main admin page for the mailing list is here:
https://mail.ibr.cs.tu-bs.de/mailman/listinfo/ibr-dtn

Kind Regards,
Nik

On Tue, May 10, 2016 at 11:00 PM, <[email-masked]> wrote:

> Send dtn-interest mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.irtf.org/mailman/listinfo/dtn-interest
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of dtn-interest digest..."
>
> Today's Topics:
>
>    1. Re: Bad Clock Vs. Clock rating (0) (Joerg Ott)
>
>
> ---------- Forwarded message ----------
> From: Joerg Ott <[email-masked]>
> To: Shyam B <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Date: Tue, 10 May 2016 07:19:16 +0200
> Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)
> I wo¨ld ask the IBR-DTN folks...
>
> On 10.05.16 01:37, Shyam B wrote:
>
>> Hello All,
>>
>> Thanks for the evolving community of DTN. I hope someone can help me
>> with the questions below:
>>
>> How to remove time synchronization between nodes on later versions of
>> IBRDTN:
>> We are using the latest version(s) of IBRDTN on OpenWRT. I read from the
>> change log "Version 1.0.1 (2015-02-24)" that BAD CLOCK has been replaced
>> by something called clock rating (set to 0).
>>
>> 1) I would like to know where and how can I set this clock rating to 0
>> on a node? Is it to be set in the "ibrdtn.conf" file or somewhere else -
>> any specifics will be helpful.
>>
>> 2) I believe this will need to be set "on each node" and the dtnd daemon
>> would read this during its initiation at run-time to bypass any clock
>> synchronization needed to receive bundles/ as well as dtnping, am I right?
>>
>> NOTE: We do not require clock synchronization to keeping our scenarios
>> simple. Just need a way to pass bundles between nodes "under any
>> circumstance".
>>
>> Reference:
>> https://trac.ibr.cs.tu-bs.de/project-cm-2012-ibrdtn/wiki/changelog
>>
>> Thanks for your time. Hope someone can help us soon!
>>
>> --
>> Regards,
>> Shyam, B
>>
>>
>
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>
>

---

From: <[email-masked]>
Date: Mon, 16 May 2016 01:25:07 +0000

Five years ago we pointed out the fundamental problems with the bundle protocol's reliance on clocks and synchronization in our 'A Bundle of Problems' paper.

http://personal.ee.surrey.ac.uk/Personal/L.Wood/dtn/bundle.html

http://dx.doi.org/10.1109/AERO.2009.4839384

People are still trying to use it and work around its clocking? As Australians say: so tragic.
<http://dx.doi.org/10.1109/AERO.2009.4839384>

Lloyd Wood
http://about.me/lloydwood
________________________________
From: dtn-interest <[email-masked]> on behalf of Nik Ansell <[email-masked]>
Sent: Wednesday, 11 May 2016 2:07:49 PM
To: [email-masked]
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

A good way to get in touch with the IBR-DTN guys is to use the mailing list below.

[email-masked]<mailto:[email-masked]>

The main admin page for the mailing list is here: https://mail.ibr.cs.tu-bs.de/mailman/listinfo/ibr-dtn

Kind Regards,
Nik

On Tue, May 10, 2016 at 11:00 PM, <[email-masked]<mailto:[email-masked]>> wrote:
Send dtn-interest mailing list submissions to
        [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.irtf.org/mailman/listinfo/dtn-interest
or, via email, send a message with subject or body 'help' to
        [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
        [email-masked]<mailto:[email-masked]>

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)
I wo?ld ask the IBR-DTN folks...

Reference:

--
Regards,
Shyam, B

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: <[email-masked]>
Date: Tue, 17 May 2016 00:24:14 +0000

I was wrong, and I'd like to take this opportunity to apologise to the list for being wrong and to correct my mistake.

It was SEVEN years ago that we pointed out the fundamental problems with the bundle protocol's reliance on clocks and synchronization in our 'A Bundle of Problems' paper....

Lloyd Wood

________________________________
From: dtn-interest <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Monday, 16 May 2016 11:25 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Lloyd Wood

Kind Regards,
Nik

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Reference:

--
Regards,
Shyam, B

---

From: Kevin Fall <[email-masked]>
Date: Mon, 16 May 2016 21:09:28 -0400

Ah, rehashing old arguments.  A real blast from the past.

The particular paper referenced below indeed points out operational cases
in which the authors had difficulty in establishing synchronized clocks.
While there are cases in which establishing time synch may be challenging,
it isn't really fundamental to the design, and there are a number of other
options people have implemented since then if you are faced with that
problem.  (or, the more realistic/interesting case in which some nodes have
a correct notion of time and others do not).  Of course, not having
synchronized time causes certain features to be difficult or impossible to
implement (e.g., expiring/deleting bundles that have been stored on passive
media lacking actual time stamps).

The reasons for the design decision of using time synchronization was given
in, for example: (
http://web.cs.ucla.edu/classes/cs217/2008DTN_Perspective.pdf), a paper from
2008.

- Kevin

On Mon, May 16, 2016 at 8:24 PM, <[email-masked]> wrote:

> I was wrong, and I'd like to take this opportunity to apologise to the
> list for being wrong and to correct my mistake.
>
>
> It was SEVEN years ago that we pointed out the fundamental problems with
> the bundle protocol's reliance on clocks and synchronization in our 'A
> Bundle of Problems' paper....
>
>
> ------------------------------
> *From:* dtn-interest <[email-masked]> on behalf of
> [email-masked] <[email-masked]>
> *Sent:* Monday, 16 May 2016 11:25 AM
> *To:* [email-masked]; [email-masked]; [email-masked]
>
> *Subject:* Re: [dtn-interest] Bad Clock Vs. Clock rating (0)
>
>
> Five years ago we pointed out the fundamental problems with the bundle
> protocol's reliance on clocks and synchronization in our 'A Bundle of
> Problems' paper.
>
>
> ------------------------------
> *From:* dtn-interest <[email-masked]> on behalf of Nik
> Ansell <[email-masked]>
> *Sent:* Wednesday, 11 May 2016 2:07:49 PM
> *To:* [email-masked]
> *Subject:* Re: [dtn-interest] Bad Clock Vs. Clock rating (0)
>

---

From: <[email-masked]>
Date: Tue, 17 May 2016 01:40:13 +0000

Lloyd, I’m going to attempt to correlate your previous two emails into a single coherent view, albeit with a limited scope. Please let me know if I fail, though I’m sure you will.

RFC5050Bis includes a bundle age block which alleviates the “strict” clocking requirements (30 seconds). From your view, is this insufficient? This block handles the cases mentioned by Kevin where some nodes have accurate clocks (and set the bundle creation timestamp) and some do not (and nullify the creation timestamp but keep a bundle age block).

Thanks,
Jeremy

From: dtn-interest [mailto:[email-masked]] On Behalf Of Kevin Fall
Sent: Dienstag, 17. Mai 2016 03:09
To: [email-masked]
Cc: [email-masked]; [email-masked]; DTN interest
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

The particular paper referenced below indeed points out operational cases in which the authors had difficulty in establishing synchronized clocks.  While there are cases in which establishing time synch may be challenging, it isn't really fundamental to the design, and there are a number of other options people have implemented since then if you are faced with that problem.  (or, the more realistic/interesting case in which some nodes have a correct notion of time and others do not).  Of course, not having synchronized time causes certain features to be difficult or impossible to implement (e.g., expiring/deleting bundles that have been stored on passive media lacking actual time stamps).

The reasons for the design decision of using time synchronization was given in, for example: (http://web.cs.ucla.edu/classes/cs217/2008DTN_Perspective.pdf), a paper from 2008.

- Kevin

On Mon, May 16, 2016 at 8:24 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Lloyd Wood

________________________________
From: dtn-interest <[email-masked]<mailto:[email-masked]>> on behalf of [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, 16 May 2016 11:25 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Lloyd Wood
http://about.me/lloydwood
________________________________
From: dtn-interest <[email-masked]<mailto:[email-masked]>> on behalf of Nik Ansell <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, 11 May 2016 2:07:49 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Kind Regards,
Nik

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Reference:

--
Regards,
Shyam, B

---

From: <[email-masked]>
Date: Tue, 17 May 2016 01:54:54 +0000

"isn't really fundamental to the design" != "makes features impossible to implement"

Lloyd Wood
http://sat-net.com/L.Wood/dtn

________________________________
From: Kevin Fall <[email-masked]>
Sent: Tuesday, 17 May 2016 11:09 AM
To: Wood L Dr (Elec Electronic Eng)
Cc: DTN interest; [email-masked]; [email-masked]
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

- Kevin

Lloyd Wood

Lloyd Wood

Kind Regards,
Nik

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Reference:

--
Regards,
Shyam, B

---

From: <[email-masked]>
Date: Tue, 17 May 2016 01:55:45 +0000

any discussion of RFC5050bis needs to be on the IETF dtn workgroup list.

Lloyd Wood

________________________________
From: [email-masked] <[email-masked]>
Sent: Tuesday, 17 May 2016 11:40 AM
To: [email-masked]; Wood L Dr (Elec Electronic Eng)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [dtn-interest] Bad Clock Vs. Clock rating (0)

Thanks,

Jeremy

- Kevin

Lloyd Wood

Lloyd Wood

Kind Regards,
Nik

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Hello All,

Reference:

--
Regards,
Shyam, B

---

From: "Torgerson, Jordan L (332M)" <[email-masked]>
Date: Tue, 17 May 2016 16:27:30 +0000

http://www.urbandictionary.com/define.php?term=trolling

From: dtn-interest <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 16, 2016 at 6:55 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Lloyd Wood

________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, 17 May 2016 11:40 AM
To: [email-masked]<mailto:[email-masked]>; Wood L Dr (Elec Electronic Eng)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [dtn-interest] Bad Clock Vs. Clock rating (0)

Thanks,

Jeremy

From: dtn-interest [mailto:[email-masked]] On Behalf Of Kevin Fall
Sent: Dienstag, 17. Mai 2016 03:09
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; DTN interest
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

- Kevin

Lloyd Wood

Lloyd Wood

Kind Regards,
Nik

Today's Topics:

---------- Forwarded message ----------
From: Joerg Ott <[email-masked]<mailto:[email-masked]>>
To: Shyam B <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Date: Tue, 10 May 2016 07:19:16 +0200
Subject: Re: [dtn-interest] Bad Clock Vs. Clock rating (0)

Hello All,

Reference:

--
Regards,
Shyam, B