Subject: [dtn-interest] DTN implementation

From: "Coll Perales, Baldomero" <[email-masked]>
Date: Wed, 6 Jul 2016 10:20:51 +0000

Dear colleagues,

I am contacting you to know if you could help me to decide what DTN implementation to use for my purpose. I am creating a multi-hop cellular network which is made of a IEEE 802.11 link between two PCs (source and hybrid) and a cellular link between a PC (hybrid) and the cellular base station. Over this network, I am sending <<any traffic>> from the source node to the server, so data packets travel through the IEEE 802.11 and cellular links. At any time instant I may decide to pause the transmission over the cellular link (not necessarily because the cellular link is not present), and the IEEE 802.11 communication continues. The packets arriving to the hybrid node through the IEEE link will be buffered. After a while (order of ~10s), I decide to resume the transmission over the cellular link. Then the packets that were buffered at the hybrid node are transmitted through the cellular link.

We are using Linux (Ubuntu) as operating system on the PCs.

Please do let me know if you need any further information/clarification.

Thank you in advance for your help!
Best regards,
Baldo

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 6 Jul 2016 12:32:55 +0000

All of the companies that have had contacts with me using some sort of DTN have chosen IBR-DTN – mainly, I think, for ease of use.  For your instance, IBR-DTN should work fine.  I believe it also is IPv6 capable.

Will

From: dtn-interest <[email-masked]<mailto:[email-masked]>> on behalf of "Coll Perales, Baldomero" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 6, 2016 at 6:20 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dtn-interest] DTN implementation

Dearcolleagues,