Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-02.txt

From: [email-masked]
Date: Sun, 21 May 2017 18:52:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking of the IETF.

        Title           : Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
        Authors         : Brian Sipos
                          Michael Demmer
                          Joerg Ott
                          Simon Perreault
	Filename        : draft-ietf-dtn-tcpclv4-02.txt
	Pages           : 36
	Date            : 2017-05-21

Abstract:
   This document describes a revised protocol for the TCP-based
   convergence layer (TCPCL) for Delay-Tolerant Networking (DTN).  The
   protocol revision is based on implementation issues in the original
   TCPCL Version 3 and updates to the Bundle Protocol contents,
   encodings, and convergence layer requirements in Bundle Protocl
   Version 7.  Several new IANA registries are defined for TCPCLv4 which
   define some behaviors inherited from TCPCLv3 but with updated
   encodings and/or semantics.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dtn-tcpclv4-02
https://datatracker.ietf.org/doc/html/draft-ietf-dtn-tcpclv4-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Sipos <[email-masked]>
Date: Mon, 22 May 2017 20:48:36 +0000

All,

<https://www.ietf.org/mailman/listinfo/dtn>
In order to attempt to tie off some open threads from earlier review comments on TCPCLv4, I've made some edits to the draft spec. The most significant changes are also identified in the document itself but they are:

  *   To use separate IANA registries from TCPCLv3 and to change some of the message names to be more internally consistent
  *   Added contact header extension item definition, but do not yet define any item types
  *   To make all fields in the protocol octet-aligned for simplified encoding/decoding
  *   Add several requirements to cover recommended contact parameters and for corner cases (half-closed TCP connections)

I made no change at all to the protocol's use of TLS. The spec mandates its implementation but not its use in any particular TCPCL session.

As always, any further feedback is welcome.