Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-24.txt

From: [email-masked]
Date: Mon, 07 Dec 2020 20:02:35 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking WG of the IETF.

        Title           : Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
        Authors         : Brian Sipos
                          Michael Demmer
                          Joerg Ott
                          Simon Perreault
	Filename        : draft-ietf-dtn-tcpclv4-24.txt
	Pages           : 74
	Date            : 2020-12-07

Abstract:
   This document describes a TCP-based convergence layer (TCPCL) for
   Delay-Tolerant Networking (DTN).  This version of the TCPCL protocol
   resolves implementation issues in the earlier TCPCL Version 3 of
   RFC7242 and updates to the Bundle Protocol (BP) contents, encodings,
   and convergence layer requirements in BP Version 7.  Specifically,
   the TCPCLv4 uses CBOR-encoded BPv7 bundles as its service data unit
   being transported and provides a reliable transport of such bundles.
   This version of TCPCL also includes security and extensibility
   mechanisms.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-24.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-24

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Sipos <[email-masked]>
Date: Tue, 8 Dec 2020 04:39:08 +0000

All,
This latest draft of TCPCLv4 addresses the last sets of IESG comments, specifically it adds an explicit PKIX certificate profile (to combine what were some separate certificate requirements and add new clarifications), simplifies the recommended security policy to focus on Node ID peer authentication (but the other validation methods are still defined), and adds an Extended Key Usage purpose for "bundleSecurity" (which is useful for TCPCL now and for other node/endpoint security in the future).
________________________________
From: dtn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Monday, December 7, 2020 23:02
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-24.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dtn-tcpclv4%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C6b37f2766e29422df68508d89b2e3ddf%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637429970200912159%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=1wfhmSM2QENIyiNl0N8sElZWY5xV8lqTTpkLS9mzIkc%3D&amp;reserved=0

There is also an HTML version available at:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-dtn-tcpclv4-24.html&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C6b37f2766e29422df68508d89b2e3ddf%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637429970200922148%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=NuQwEth6oGQF5j5m5HPJcmgYb78TSGrUdv%2Fl788ieAM%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-dtn-tcpclv4-24&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C6b37f2766e29422df68508d89b2e3ddf%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637429970200922148%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=1%2BHf1Ske9eABfb%2FmtZnkp%2FFJlG51GlhSttSd2%2B0A79A%3D&amp;reserved=0

Internet-Drafts are also available by anonymous FTP at:
https://nam10.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C6b37f2766e29422df68508d89b2e3ddf%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637429970200922148%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=7DI6TpwI6zDFk6ePi2gioNJXue2HKGfre0Agjiz8yNo%3D&amp;reserved=0

_______________________________________________
dtn mailing list
[email-masked]
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdtn&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C6b37f2766e29422df68508d89b2e3ddf%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637429970200922148%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=qITt66r0R8Zyb8AgFjoWF1J35brL4ELoCu%2Fb2tnhH6A%3D&amp;reserved=0