Subject: [Ecrit] I-D Action:draft-ietf-ecrit-phonebcp-16.txt

From: [email-masked]
Date: Mon, 25 Oct 2010 13:30:05 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Emergency Context Resolution with Internet Technologies Working Group of the IETF.

	Title           : Best Current Practice for Communications Services in support of Emergency Calling
	Author(s)       : B. Rosen, J. Polk
	Filename        : draft-ietf-ecrit-phonebcp-16.txt
	Pages           : 24
	Date            : 2010-10-25

The IETF and other standards organization have efforts targeted at
standardizing various aspects of placing emergency calls on IP
networks.  This memo describes best current practice on how devices,
networks and services should use such standards to make emergency
calls.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ecrit-phonebcp-16.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 26 Oct 2010 09:34:27 +0200

Just checked the diffs.

In SP-18 it now says:
"SP-18 If a proxy is attempting to insert location but the UA conveyed
   a location to it, the proxy MUST use the UA's location for routing in
   the initial INVITE and MUST convey that location towards the PSAP."
The wording "for routing in the initial INVITE" do now seem to make sense. 
Should it say "...the proxy MUST use the UA's location in the initial INVITE for routing..."

In 9.3 item 4 it now says:
"In the absence of another spec(T), such proxies should  
           pass the header unmodified if and only if the connection between  
           the proxy and the PSAP is, as far as the proxy can determine,  
           protected by TLS with mutual authentication using keys reliably  
           known by the parties, encrypted with no less strength than AES  
           and the local regulations governing the PSAP do not otherwise  
           specify."
This is a long sentence - it seems understandable apart from the last part:
"and the local regulations governing the PSAP do not otherwise  
           specify"
I am not sure what this is trying to say. One possible interpretation is that the sentence is trying to say:
"In the absence of another spec(T) and except where regulations governing the PSAP specify otherwise, such proxies should ...."

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 25 October 2010 21:30
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action:draft-ietf-ecrit-phonebcp-16.txt 
> 
> This draft is a work item of the Emergency Context Resolution 
> with Internet Technologies Working Group of the IETF.
> 
> 
> 	Title           : Best Current Practice for 
> Communications Services in support of Emergency Calling