Subject: [Emu] draft-ietf-emu-eap-tls13-11: Conformance with the TLS 13 Spec

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 21 Oct 2020 09:16:00 +0000

Hi all,

Section 2.1.6 says:

"
   An EAP-TLS peer and server SHOULD support the use of
   HelloRetryRequest message.
"

My understanding of the TLS 1.3 specification is that the HelloRetryRequest is not an optional-to-implement message but it is only optional to use.

Is there a reason to deviate from the TLS 1.3 specification? Is there any reason to talk about the HRR message? The purpose of the message is given in the TLS 1.3 spec and whether you use it or not is up to the deployment.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mohit Sethi M <[email-masked]>
Date: Sat, 31 Oct 2020 17:04:24 +0000

Hi Hannes,

Jim Schaad had asked for this: https://mailarchive.ietf.org/arch/msg/emu/XpRkNN-mh5BuiTD1O8iEfz9sM4M/

It is still optional to use. The figure only shows what the exchange would look like if a HRR was sent by the server.

--Mohit

On 10/21/20 12:16 PM, Hannes Tschofenig wrote:
Hi all,

Section 2.1.6 says:

"

Ciao
Hannes

_______________________________________________
Emu mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/emu