Subject: [Gen-art] Gen-ART Telechat review for draft-cardenas-dff-014

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 13 May 2013 12:16:12 +0000

Hi,

As stated in the review made on a previous version of the document, from my point of view this document is ready. All my questions and concerns were answered with the exception of issue #6 mentioned below. It would be nice to have this issue answered as well, however this is a clarification non-blocking issue. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Romascanu, Dan (Dan)
> Sent: Wednesday, March 27, 2013 4:52 PM
> To: Ulrich Herberg; [email-masked]
> Cc: [email-masked]; Alvaro Cardenas; [email-masked]; Ralph
> Droms (rdroms); [email-masked]; Ted Lemon
> Subject: Re: [Gen-art] Gen-ART review for draft-cardenas-dff-09
> 
> Hi Ulrich,
> 
> I apologize for the late response but travel and holidays intervened.
> 
> The updated version answers all my concerns, and thank you for
> addressing these and for the improved specification.
> 
> I have only one clarification question to ask, related to your answers:
> 
> > >6. In section 9.2 - what happened if when adding a new Processed
> > >Tuple based on a new incoming packet the routing discovers that the
> > >P_seq_number is already in used for another entry in the list. This
> > >can happen, as the sequence numbers are unique per routers, and
> > >current packets may originate from different routers? Is this not a
> problem?
> > Why?
> >
> > That would not be a problem as for each packet, existing tuples are
> > searched using *both*
> > +  P_orig_address = the Originator Address of the current Packet,
> >           AND;
> >        +  P_seq_number = the sequence number of the current Packet.
> >
> >
> > So a tuple with same P_seq_number but different P_orig_address would
> > not be returned
> 
> Is the algorithm clarified some place in the specification, and I could
> not find it? If such explanation existed it would have answered my
> concern from start, maybe I missed it. If this is not clearly stated,
> maybe adding such an explanation would be useful.
> 
> Thanks and Regards,
> 
> Dan
> 
> 
> 
> > -----Original Message-----
> > From: Ulrich Herberg [mailto:[email-masked]]
> > Sent: Monday, March 11, 2013 7:29 PM
> > To: Romascanu, Dan (Dan); [email-masked]
> > Cc: Ralph Droms (rdroms); [email-masked];
> > [email-masked]; [email-masked]; Alvaro Cardenas; Ted
> > Lemon
> > Subject: Re: Gen-ART review for draft-cardenas-dff-09
> >
> > Dan,
> >
> > thank you very much for your review. I tried to address your comments,
> > and have submitted a new revision just now:
> > http://tools.ietf.org/html/draft-cardenas-dff-10
> > See below:
> >
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 13 May 2013 10:08:19 -0700

Dan,

I apologize for the oversight of this issue #6. We had already agreed with
Ted to make the sentence clearer by replacing it with the below text. I
just forgot to actually update the draft ;-)
Ted will advise me if this can be done in an RFC editor note or a new
revision:

from:
>If no Processed Tuple (henceforth denoted the "current tuple")
>       exists in the Processed Set, *with*:
>       +  P_orig_address = the Originator Address of the current Packet;
>(*line-break*)
>          AND;

to:
>If no Processed Tuple (henceforth denoted the "current tuple")
>       exists in the Processed Set, *where both of the following
>conditions are true*:
>       +  P_orig_address = the Originator Address of the current Packet;
>(*line-break*)
>          AND;

Best regards
Ulrich

On 5/13/13 5:16 AM, "Romascanu, Dan (Dan)" <[email-masked]> wrote:

>
>Hi,
>
>As stated in the review made on a previous version of the document, from
>my point of view this document is ready. All my questions and concerns
>were answered with the exception of issue #6 mentioned below. It would be
>nice to have this issue answered as well, however this is a clarification
>non-blocking issue.
>
>Thanks and Regards,
>
>Dan
>
>
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 13 May 2013 18:06:38 +0000

> Ted will advise me if this can be done in an RFC editor note or a new

Editor's note is fine.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 20 May 2013 15:30:35 +0000

This is great. Thanks for addressing (also) this issue. 

Regards,

Dan

> From: Ted Lemon [mailto:[email-masked]]
> Sent: Monday, May 13, 2013 9:07 PM
> To: Ulrich Herberg
> Cc: Romascanu, Dan (Dan); [email-masked]; [email-masked];
> Alvaro Cardenas; [email-masked]; Ralph Droms (rdroms); smartnetpro-
> [email-masked]
> Subject: Re: Gen-ART Telechat review for draft-cardenas-dff-014
>