Subject: [Gen-art] Late comment on draft-ietf-bfd-seamless-ip-04

From: Elwyn Davies <[email-masked]>
Date: Wed, 4 May 2016 09:43:59 +0100

Hi.

While reviewing draft-ietf-l2tpext-sbfd-discriminator-05 for gen-art, I 
came across a
  'common mode' issue with multiple discriminators that lead me to check 
the various other seamless BFD drafts.

In the process I noticed the last paragraph in Section 5.1.1 of 
draft-ietf-bfd-seamless-ip-04 contained the following text:
>     This also requires S-BFD control packets not be dropped by the
>     responder node due to TTL expiry.  Thus implementations on the
>     responder MUST allow received S-BFD control packets taking TTL expiry
>     exception path to reach corresponding reflector BFD session.
This struck me as out of line with (AFAICS) every existing IP 
implementation. TTL expiry checking is typically deep in the stack and 
making an exception for this one case is (IMO) likely to be problematic. 
It may even be a security issue. Have I misunderstood what is going on here?

Regards,
Elwyn

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 4 May 2016 18:45:53 +0000

Hi, Elwyn,

Thanks for the re-review of a different document :-) All comments welcome and help, thanks.

> On May 4, 2016, at 4:43 AM, Elwyn Davies <[email-masked]> wrote:
> 
> Hi.
> 
> While reviewing draft-ietf-l2tpext-sbfd-discriminator-05 for gen-art, I came across a
> 'common mode' issue with multiple discriminators that lead me to check the various other seamless BFD drafts.
> 
> In the process I noticed the last paragraph in Section 5.1.1 of draft-ietf-bfd-seamless-ip-04 contained the following text:
> This struck me as out of line with (AFAICS) every existing IP implementation. TTL expiry checking is typically deep in the stack and making an exception for this one case is (IMO) likely to be problematic. It may even be a security issue. Have I misunderstood what is going on here?
> 

See first para of https://tools.ietf.org/html/rfc4379#section-4.4 <https://tools.ietf.org/html/rfc4379#section-4.4>, as one example, of this OAM practice.

Thanks,

— Carlos.