Subject: Fwd: Georpiv and actively lying

From: "James M. Polk" <[email-masked]>
Date: Thu, 18 Sep 2003 10:50:19 -0500

Forgive (simple) - I didn't include simple in my original response to 
Jonathan's email.

Forgive (geopriv) - for sending a redundant message

just trying to get everyone in sync

>Date: Wed, 17 Sep 2003 17:29:25 -0500
>From: "James M. Polk" <[email-masked]>
>Subject: Georpiv and actively lying
>X-Sender: jmpolk@localhost
>To: Jonathan Rosenberg <[email-masked]>
>Cc: Henning Schulzrinne <[email-masked]>,
>         Tschofenig Hannes <[email-masked]>,
>         John Morris <[email-masked]>, [email-masked],
>         [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Version 4.3.2
>List-Owner: <mailto:[email-masked]>
>List-Subscribe:
>  <mailto:[email-masked]?subject=subscribe%20ietf-geopriv>
>List-Unsubscribe:
>  <mailto:[email-masked]?subject=unsubscribe%20ietf-geopriv>
>List-Id: <[email-masked]>
>Spam-test: False ; -1.5 / 4.5
>
>comments below
>
>** I've added the Geopriv list to this discussion because this thread has 
>whittled down to the one issue (lying) and it hasn't been commented on yet 
>there, and if a previous WG agreement is being called into question (which 
>is OK) - more people should see this discussion
>
>At 05:48 PM 9/17/2003 -0400, Jonathan Rosenberg wrote:
>
>
>>James M. Polk wrote:
>>
>>>At 04:02 AM 9/17/2003 -0400, Jonathan Rosenberg wrote:
>>>
>>>>Henning,
>>>>
>>>>Also, how does this handle lying? I raised this question on the list as 
>>>>well.
>>>
>>>We had this discussion over two meetings last year and the consensus was 
>>>that in Geopriv, we shouldn't explicitly allow lying (as in, defining 
>>>how to do it - yet knowing we can't prevent it). That was resolved in 
>>>the POV that one can always give "less precise" location information 
>>>(replying that I'm in North America (only) when I know I'm at 123 Main 
>>>St., Dallas, TX, USA).
>>>This is where permissions can be mapped to a template or table that 
>>>equates to the level of resolution of the target's location a particular 
>>>requester can learn.
>>
>>That works for geoloc, and can be mapped nicely into the model Henning is 
>>proposing. "resolution" can be considered an integer, such that the 
>>maximum resolution is the value that is communicated.
>>
>>It doesnt work for presence, and it won't work for geoloc later on when 
>>you do decide to lie. It seems lying is really crucial there too. THe 
>>classic "mistress" problem applies here - if your wife only sees "I'm in 
>>North America" as opposed to "I'm at the office in Parsippany, NJ", the 
>>mere fact that the information has been made less precise conveys that 
>>there is a problem. You need to be able to say "I'm in Parsippany" when 
>>you are really in Las Vegas.
>
>Why should we design for permissible lying in an IETF effort?
>
>If your server or service is configured to give out misinformation, that's 
>one thing - but to build it into the protocol as a requirement lacks 
>technical justification at this point. A compliant protocol implementation 
>shouldn't be required to be able to lie just to be compliant. A protocol 
>that chooses not to be compliant can always misbehave.
>
>
>>As such, I am somewhat surprised this was dismissed.
>
>One argument for this dismissal was that if this were built into Geopriv, 
>the IETF would be actively, explicitly endorsing (through functionality of 
>the base protocol) the ability to lie.
>
>Doesn't seem like something to be proud of, when all is said and done
>
>>I understand its hard, but it seems crucial, no?
>
>There just hasn't been a good technical reason for allowing this into the 
>protocol as a requirement of compliance yet. What I believe you are 
>pointing to is a (debatable) societal reason for this
>
>
>>-Jonathan R.
>>--
>>Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
>>Chief Technology Officer                    Parsippany, NJ 07054-2711
>>dynamicsoft
>>[email-masked]                     FAX:   (973) 952-5050
>>http://www.jdrosen.net                      PHONE: (973) 952-5000
>>http://www.dynamicsoft.com
>
>
>cheers,
>James
>
>                                *******************
>                 Truth is not to be argued... it is to be presented
>

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 18 Sep 2003 10:50:19 -0500

cheers,
James

                                *******************

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv