Subject: RE: [Geopriv] A description of the relationship of permissions and rules.

From: [email-masked]
Date: Wed, 17 Sep 2003 10:06:32 -0400

Hi Jonathan,

>> 
>> The good news is that if we believe in the soundness of the 
>fundamental 
>> model,
>> we can publish documents describing the statements for retention, 
>> distribution,
>> granularity, and naming of URIs without having completed the 
>work on the 
>> rules,
>> as we will be sure that the presence of the un-dereferenced 
>URI will not 
>> constitute
>> a privacy violation.
>
>I encountered one big snag in this model which I havent quite worked 
>out. THe snag is what we are calling "transformational permissions". 
>These are cases where I want to say "if my activity is 'busy', change 
>it to 'idle'". Simply put - lying. I believe that lying will play a 
>far more important role than omission of information, both in presence 
>and geolocation. I don't know if this was discussed at the 
>interim or not.
>
>Lying doesnt really fit into the model. Its not a permission in that 
>it doesnt grant access to a piece of information fundamentally in the 
>data. Rather, it asks for a change in that data. I could think of no 
>other solution than to include explicitly defined ordering values that 
>tell the server how to compose the information.

Wouldn't "transformational permissions" be also useful for cases in which I want to 
grant permission to, let's say, geoloc location but with less granularity for the particular watcher, 
i.e., even though the location information exists with 95% confidence, I would like to "blur" it before
providing to the particular watcher, e.g., provide it with 70% confidence only? This is probably the 
case of "lying" for non-discrete presence items!? 

But this would make the authorization description quite complex since explicit ordering wouldn't do, right? 
Hence, it might be useful to describe the scope of such "transformational permissions" with respect to 
supported transformations.

Dirk

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: [email-masked]
Date: Thu, 18 Sep 2003 10:15:50 +0300

Hi All,

One comment inline.

 > -----Original Message-----
 > From: ext Jonathan Rosenberg [mailto:[email-masked]]
 > Sent: 17 September, 2003 10:36
 > To: [email-masked]
 > Cc: [email-masked]; Simple WG
 > Subject: [Simple] Re: [Geopriv] A description of the relationship of
 > permissions and rules.
[snip]
 > > The good news is that if we believe in the soundness of 
 > the fundamental 
 > > model,
 > > granularity, and naming of URIs without having completed 
 > the work on the 
 > > rules,
 > > as we will be sure that the presence of the 
 > un-dereferenced URI will not 
 > > constitute
 > > a privacy violation.
 > 

I think one way to make 'lying' part of the model is to explicitly include this false information in the data. 

For presence, this would mean publishing two pieces of information - the true information as well as the false. Granted that this would not be efficient in terms of the amount of publication traffic it would generate, I think it would reduce the 'lying' into a set of ordinary permissions instead of the transformational permissions.

Cheers,
Aki

 > 
 > -Jonathan R.
 > 
 > 
 > -- 
 > Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
 > Chief Technology Officer                    Parsippany, NJ 07054-2711
 > dynamicsoft
 > [email-masked]                     FAX:   (973) 952-5050
 > http://www.jdrosen.net                      PHONE: (973) 952-5000
 > http://www.dynamicsoft.com
 > 
 > 
 > Simple mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/simple
 >