Subject: [hrpc] Draft association : Extended litterature review

From: Stéphane Couture <[email-masked]>
Date: Mon, 22 Jun 2020 23:04:06 -0400

Dear all,

I'd like to finally send you - in odt format, not on github (sorry for
this) - the work I did in expanding the literature review on draft
association. Thank you  Mallory for a the few working sessions we had in
the last weeks on this, and to Melinda Shore for converting the document in
Word and all other who discussed with me before (Niels and Avri, notably)

At this point, I'd like to pass the responsibility of the draft to someone
else as I have difficulties bringing this draft to another step, both
because of lack of time and lack of vision on how to proceed from there
while keeping the "spirit" of the initial draft.

In this document, I am only sending you the first part of the draft
(literature review), which is the part I worked. My approach was to start
with what exists in the literature review, and then raise questions that
are relevant to IETF and protocol development more broadly. The section on
"Cases and examples" is not included in this document, as I did not work on
it, and still don't know what to do with it. In particular, I feel it is
not aligned with the questions raised by the literature.

One important thing in this document is that we tried (again) to change the
central question. It is now : "*What are the considerations of the right to
freedom of assembly and association for protocol development?*", which
seems more aligned to the research group title. The original question was
"How does the architecture of the internet enable and/or inhibit the right
to freedom of assembly and association?". I think these two questions
do not orient us exactly to the same analysis, something that I feel might
be important to note.

And here are other questions I felt were raised from the literature review.
Maybe just raising the questions could be a good contribution in itself...

1. As a general matter, what are the features of protocols that enable
freedom of association and assembly? Can protocols facilitate agency of
membership in associations, assemblies and interactions? Where in the stack
do we care for FAA?

2. Does protocol development sufficiently consider the enabling of freedom
of association without discrimination as to race, colour, national, ethnic
origin?

3.  Does protocol development sufficiently consider usable and accessible
formats and technologies appropriate for persons with different kinds of
disabilities?

4.  Is it possible to distinguish “peaceful” and “non-peaceful” association
from the perspective of protocol development? If yes, can and should
protocols be designed to limit “non-peaceful” association?

5. In particular, should protocols be designed to enable legitimate
limitations on association in the interests of “national security or public
safety, public order, the protection of public health or morals or the
protection of the rights and freedoms of others”, as stated in the ICCPR
article 21?

6. Can a protocol be designed to legitimately exclude someone from an
association?

7. In general, what kind of human rights impact assessments should be made
to incorporate the rights to freedom of peaceful assembly and of
association when developing protocols, as recommended by SpecialRapporteur
on the rights to freedom of peaceful assembly and of association.

I hope this would be helpful,

Best,

Stéphane

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 23 Jun 2020 22:55:33 +0000

Thank you for this, Stéphane... the list of questions from the literature review are fascinating (so is the literature review!).
________________________________
From: hrpc <[email-masked]> on behalf of Stéphane Couture <[email-masked]>
Sent: Monday, June 22, 2020 23:04
To: Hrpc <[email-masked]>
Subject: [hrpc] Draft association : Extended litterature review

Dear all,

I'd like to finally send you - in odt format, not on github (sorry for this) - the work I did in expanding the literature review on draft association. Thank you  Mallory for a the few working sessions we had in the last weeks on this, and to Melinda Shore for converting the document in Word and all other who discussed with me before (Niels and Avri, notably)

At this point, I'd like to pass the responsibility of the draft to someone else as I have difficulties bringing this draft to another step, both because of lack of time and lack of vision on how to proceed from there while keeping the "spirit" of the initial draft.

In this document, I am only sending you the first part of the draft (literature review), which is the part I worked. My approach was to start with what exists in the literature review, and then raise questions that are relevant to IETF and protocol development more broadly. The section on "Cases and examples" is not included in this document, as I did not work on it, and still don't know what to do with it. In particular, I feel it is not aligned with the questions raised by the literature.

One important thing in this document is that we tried (again) to change the central question. It is now : "What are the considerations of the right to freedom of assembly and association for protocol development?", which seems more aligned to the research group title. The original question was "How does the architecture of the internet enable and/or inhibit the right to freedom of assembly and association?". I think these two questions do not orient us exactly to the same analysis, something that I feel might be important to note.

And here are other questions I felt were raised from the literature review. Maybe just raising the questions could be a good contribution in itself...

1. As a general matter, what are the features of protocols that enable freedom of association and assembly? Can protocols facilitate agency of membership in associations, assemblies and interactions? Where in the stack do we care for FAA?

2. Does protocol development sufficiently consider the enabling of freedom of association without discrimination as to race, colour, national, ethnic origin?

3.  Does protocol development sufficiently consider usable and accessible formats and technologies appropriate for persons with different kinds of disabilities?

4.  Is it possible to distinguish “peaceful” and “non-peaceful” association from the perspective of protocol development? If yes, can and should protocols be designed to limit “non-peaceful” association?

5. In particular, should protocols be designed to enable legitimate limitations on association in the interests of “national security or public safety, public order, the protection of public health or morals or the protection of the rights and freedoms of others”, as stated in the ICCPR article 21?

6. Can a protocol be designed to legitimately exclude someone from an association?

7. In general, what kind of human rights impact assessments should be made to incorporate the rights to freedom of peaceful assembly and of association when developing protocols, as recommended by SpecialRapporteur on the rights to freedom of peaceful assembly and of association.

Best,

Stéphane

---

From: Mallory Knodel <[email-masked]>
Date: Wed, 24 Jun 2020 10:01:18 -0400

I find them fascinating, too.

Co-chair hat: I wonder if we can agree that the way forward with this 
draft is to try to answer those questions in the form of specific case 
studies. This means that we will likely use some of the case studies 
that are already there, but not all, and there would be quite a bit of 
writing to do.

The second part of agreeing on a way forward is recognising Stéphane's 
heroic work on this and thinking about replacing his capacity as well as 
adding research and writing capacity back onto the "team" with this new 
direction.

Joe, are you still able to work on this as an editor?

Anyone able to step in to help me write?

-Mallory

On 6/23/20 6:55 PM, Joseph Lorenzo Hall wrote:
> Thank you for this, Stéphane... the list of questions from the 
> literature review are fascinating (so is the literature review!).
> ------------------------------------------------------------------------
> *From:* hrpc <[email-masked]> on behalf of Stéphane Couture 
> <[email-masked]>
> *Sent:* Monday, June 22, 2020 23:04
> *To:* Hrpc <[email-masked]>
> *Subject:* [hrpc] Draft association : Extended litterature review
> Dear all,
>
> association. Thank you  Mallory for a the few working sessions we had 
> in the last weeks on this, and to Melinda Shore for converting the 
> document in Word and all other who discussed with me before (Niels and 
> Avri, notably)
>
> At this point, I'd like to pass the responsibility of the draft to 
> someone else as I have difficulties bringing this draft to another 
> step, both because of lack of time and lack of vision on how to 
> proceed from there while keeping the "spirit" of the initial draft.
>
> (literature review), which is the part I worked. My approach was to 
> start with what exists in the literature review, and then raise 
> questions that are relevant to IETF and protocol development more 
> broadly. The section on "Cases and examples" is not included in this 
> document, as I did not work on it, and still don't know what to do 
> with it. In particular, I feel it is not aligned with the questions 
> raised by the literature.
>
> One important thing in this document is that we tried (again) to 
> change the central question. It is now : "*What are the considerations 
> of the right to freedom of assembly and association for protocol 
> development?*", which seems more aligned to the research group title. 
> The original question was "How does the architecture of the internet 
> enable and/or inhibit the right to freedom of assembly and 
> association?". I think these two questions do not orient us exactly to 
> the same analysis, something that I feel might be important to note.
>
> And here are other questions I felt were raised from the literature 
> review. Maybe just raising the questions could be a good contribution 
> in itself...
>
> freedom of association and assembly? Can protocols facilitate agency 
> of membership in associations, assemblies and interactions? Where in 
> the stack do we care for FAA?
>
> 2. Does protocol development sufficiently consider the enabling of 
> freedom of association without discrimination as to race, colour, 
> national, ethnic origin?
>
> 3.  Does protocol development sufficiently consider usable and 
> accessible formats and technologies appropriate for persons with 
> different kinds of disabilities?
>
> 4.  Is it possible to distinguish “peaceful” and “non-peaceful” 
> association from the perspective of protocol development? If yes, can 
> and should protocols be designed to limit “non-peaceful” association?
>
> limitations on association in the interests of “national security or 
> public safety, public order, the protection of public health or morals 
> or the protection of the rights and freedoms of others”, as stated in 
> the ICCPR article 21?
>
> 7. In general, what kind of human rights impact assessments should be 
> made to incorporate the rights to freedom of peaceful assembly and of 
> association when developing protocols, as recommended 
> by SpecialRapporteur on the rights to freedom of peaceful assembly and 
> of association.
>
> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc

-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 24 Jun 2020 14:38:20 +0000

Alas, I am a spectator at this point... apologies. Need to focus on the PEARG censorship draft for the near future. I do like the suggestion of the rest of the document flowing from those questions!
________________________________
From: Mallory Knodel <[email-masked]>
Sent: Wednesday, June 24, 2020 10:01
To: Joseph Lorenzo Hall <[email-masked]>; Stéphane Couture <[email-masked]>; Hrpc <[email-masked]>
Subject: Re: [hrpc] Draft association : Extended litterature review

Co-chair hat: I wonder if we can agree that the way forward with this draft is to try to answer those questions in the form of specific case studies. This means that we will likely use some of the case studies that are already there, but not all, and there would be quite a bit of writing to do.

The second part of agreeing on a way forward is recognising Stéphane's heroic work on this and thinking about replacing his capacity as well as adding research and writing capacity back onto the "team" with this new direction.

-Mallory

On 6/23/20 6:55 PM, Joseph Lorenzo Hall wrote:
Thank you for this, Stéphane... the list of questions from the literature review are fascinating (so is the literature review!).
________________________________
From: hrpc <[email-masked]><mailto:[email-masked]> on behalf of Stéphane Couture <[email-masked]><mailto:[email-masked]>
Sent: Monday, June 22, 2020 23:04
To: Hrpc <[email-masked]><mailto:[email-masked]>
Subject: [hrpc] Draft association : Extended litterature review

Dear all,

Best,

Stéphane

_______________________________________________
hrpc mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/hrpc

---

From: Eliot Lear <[email-masked]>
Date: Wed, 24 Jun 2020 16:38:26 +0200

That’s a nice piece of work, Stéphane.  Your questions are good ones.

A caution: as we discussed before, there are other rights involved, and the intersection of those rights also has to be considered by protocol developers.

Eliot

> On 24 Jun 2020, at 16:01, Mallory Knodel <[email-masked]> wrote:
> 
>> From: hrpc <[email-masked]> <mailto:[email-masked]> on behalf of Stéphane Couture <[email-masked]> <mailto:[email-masked]>
>> To: Hrpc <[email-masked]> <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/hrpc <https://www.irtf.org/mailman/listinfo/hrpc>
> -- 
> Mallory Knodel
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/hrpc <https://www.irtf.org/mailman/listinfo/hrpc>

---

From: Mallory Knodel <[email-masked]>
Date: Wed, 24 Jun 2020 10:39:23 -0400

That's totally fair, Joe. Thanks for your support of a way forward!

-Mallory

On 6/24/20 10:38 AM, Joseph Lorenzo Hall wrote:
> Alas, I am a spectator at this point... apologies. Need to focus on 
> the PEARG censorship draft for the near future. I do like the 
> suggestion of the rest of the document flowing from those questions!
> *From:* Mallory Knodel <[email-masked]>
> *Sent:* Wednesday, June 24, 2020 10:01
> *To:* Joseph Lorenzo Hall <[email-masked]>; Stéphane Couture 
> <[email-masked]>; Hrpc <[email-masked]>
> *Subject:* Re: [hrpc] Draft association : Extended litterature review
>
> heroic work on this and thinking about replacing his capacity as well 
> as adding research and writing capacity back onto the "team" with this 
> new direction.
>
>
>> *From:* hrpc <[email-masked]> <mailto:[email-masked]> 
>> on behalf of Stéphane Couture <[email-masked]> 
>> <mailto:[email-masked]>
>> *To:* Hrpc <[email-masked]> <mailto:[email-masked]>
>> I'd like to finally send you - in odt format, not on github (sorry 
>> for this) - the work I did in expanding the literature review on 
>> draft association. Thank you  Mallory for a the few working sessions 
>> we had in the last weeks on this, and to Melinda Shore for converting 
>> the document in Word and all other who discussed with me before 
>> (Niels and Avri, notably)
>>
>> change the central question. It is now : "*What are the 
>> considerations of the right to freedom of assembly and association 
>> for protocol development?*", which seems more aligned to the research 
>> group title. The original question was "How does the architecture of 
>> the internet enable and/or inhibit the right to freedom of assembly 
>> and association?". I think these two questions do not orient us 
>> exactly to the same analysis, something that I feel might be 
>> important to note.
>>
>> 1. As a general matter, what are the features of protocols that 
>> enable freedom of association and assembly? Can protocols facilitate 
>> agency of membership in associations, assemblies and interactions? 
>> Where in the stack do we care for FAA?
>>
>> public safety, public order, the protection of public health or 
>> morals or the protection of the rights and freedoms of others”, as 
>> stated in the ICCPR article 21?
>>
>> by SpecialRapporteur on the rights to freedom of peaceful assembly 
>> and of association.
>>

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 29 Jun 2020 21:09:12 +0200

Thanks a lot for this work Stephane,

I have taken the liberty to put your contribution in I-D format for easier reading and discussion in the WG. I have replaced the introduction and the methods of the last version (-04) with your text for -05:

https://datatracker.ietf.org/doc/html/draft-irtf-hrpc-association-05

I still have to do many of the references, but will try to do that later this week. 

Best,

Niels

On 6/23/20 5:04 AM, Stéphane Couture wrote:
> One important thing in this document is that we tried (again) to change the central question. It is now : "*What are the considerations of the right to freedom of assembly and association for protocol development?*", which seems more aligned to the research group title. The original question was "How does the architecture of the internet enable and/or inhibit the right to freedom of assembly and association?". I think these two questions do not orient us exactly to the same analysis, something that I feel might be important to note.
> 

-- 
Niels ten Oever
Researcher and PhD Candidate - DATACTIVE Research Group - University of Amsterdam
Postdoctoral Scholar (abd) - Communications Department - Texas A&M University
Research Fellow - Centre for Internet and Human Rights - European University Viadrina
Associated Scholar - Centro de Tecnologia e Sociedade - Fundação Getúlio Vargas

W: https://nielstenoever.net
E: [email-masked]
T: @nielstenoever
P/S/WA: +31629051853
PGP: 2458 0B70 5C4A FD8A 9488 643A 0ED8 3F3A 468A C8B3