Subject: [Http-well-known] Revising the Well-Known URI registration policy (tldr; new draft, new list)

From: Mark Nottingham <[email-masked]>
Date: Mon, 7 May 2018 22:16:29 +1000

Hi everyone,

At the DISPATCH session in London, it became clear that the consensus recorded in RFC5785 about the scope of use for Well-Known URIs didn't match that in the room; while the intended uses in 2010 were focused on site-specific policy and metadata, the mechanism has become attractive for other uses as well.

So, in consultation with Alexey, I reached out to the W3C Technical Architecture Group to see if they had any concerns about opening upon Well-known URI registrations to use cases beyond what's countenanced by RFC5785, since the TAG was originally consulted when we established the registry:
  https://github.com/w3ctag/design-reviews/issues/237

The answer seems to be that they're not too concerned about architectural issues here. That being the case, I think it's reasonable to revise 5785 to allow broader use, and would like to confirm that direction with the broader community.

I've started to reflect that in a revision of my draft:
  https://mnot.github.io/I-D/rfc5785bis/

Diff from previous:
  https://tools.ietf.org/rfcdiff?url2=draft-nottingham-rfc5785bis-05.txt#diff0001

Alexey has created a mailing list to discuss the future of Well-Known URIs here:
  https://www.ietf.org/mailman/listinfo/http-well-known

If you have suggestions or feedback on this draft, concerns about this change, or other input, please head on over there to discuss.

Cheers,

P.S. Note that Reply-To is set to that list.

--
Mark Nottingham   https://www.mnot.net/

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 14 May 2018 07:12:20 -0600

Thank you for making progress on this draft. 

One question I had related to the text that says 

“Registrations MUST reference a freely available, stable specification.”

In other documents, people have argued for that but that means that 3GPP (and others) would not be able to use the mechanism which seems bad. 

In the name of broad use and getting done, I would prefer to just use "Specification Required" from RFC 5226. 

But if we don’t do that, we better specify what we mean by “free” in this context.

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 May 2018 14:31:16 +0100

Hi Cullen,

On Mon, May 14, 2018, at 2:12 PM, Cullen Jennings wrote:
> In other documents, people have argued for that but that means that 3GPP 
> (and others) would not be able to use the mechanism which seems bad. 

This is a good point. In general Desinated Experts need to be able to get access to specifications for free, but this is not the same as making them freely available.

> But if we don’t do that, we better specify what we mean by “free” in 

Best Regards,
Alexey

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 22 May 2018 10:20:58 +1000

> On 14 May 2018, at 11:12 pm, Cullen Jennings <[email-masked]> wrote:
> 
> 

8126 :)

> But if we don’t do that, we better specify what we mean by “free” in this context. 

The intent is to lower this barrier, not raise it. 3GPP would certainly qualify. 

Personally, I think a spec on a site run by any organisation -- open source project, company, foundation, etc. -- would be fine too.

I'm a bit less comfortable with using a personal site -- but of course we can always update the registration, and there are things like archive.org.

I also think that this includes WHATWG specs, despite their "living standard " policy.

Re-reading 8126, yes I think Specification Required would suffice.

Cheers,