Subject: [Http-well-known] Provisional and permanent entries

From: Mark Nottingham <[email-masked]>
Date: Thu, 6 Sep 2018 09:38:08 +1000

After the earlier discussion with Martin, and some off-list discussion, I've tentatively added a "status" field to the registry. Text currently is:

Status:
: One of "permanent" or "provisional". See guidance below.

[...]

Standards-defined values have a status of "permanent". Other values can also be registered as permanent, if the Experts find that they are in use, in consultation with the community. Other values should be registered as "provisional".

Provisional entries can be removed from the Experts if -- in consultation with the community -- find that they are not in use. The Experts can change a provisional entry's status to permanent at any time.

[...]

Upon publication, IANA should:

* Update the status of all existing registrations to "permanent".

Are people comfortable with this?

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 6 Sep 2018 14:48:42 +0900

Hello Mark,

> Provisional entries can be removed from the Experts if -- in consultation with the community -- find that they are not in use. The Experts can change a provisional entry's status to permanent at an…

Just some editorial fixes:

"Provisional entries can be removed from the Experts if"
-> "Provisional entries can be removed by the Experts if"

"-- in consultation with the community -- find that they are not in use."
-> "-- in consultation with the community -- the Experts find that they 
are not in use."

Regards,   Martin.

> Are people comfortable with this?

Except for the details, no problem at all.

Regards,   Martin.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 6 Sep 2018 16:16:25 +1000

Fixed in source, thanks!

> On 6 Sep 2018, at 3:48 pm, Martin J. Dürst <[email-masked]> wrote:
> 
> Hello Mark,
> 
> -> "-- in consultation with the community -- the Experts find that they are not in use."
> 
> Regards,   Martin.
> 
>> [...]
> _______________________________________________
> Http-well-known mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-well-known