Subject: [hybi] Errors in HTTP proxy examples in Web Socket protocol, 3.1 step 3

From: Jeff Walden <[email-masked]>
Date: Fri, 29 May 2009 19:18:23 -0700

The examples don't (explicitly) include the (required) port number in the authority part of the Request-Line.  Also, they're missing HTTP/1.1's (required) Host header.  They instead should be:

   CONNECT example.com:80 HTTP/1.1
   Host: example.com

and

   CONNECT example.com:80 HTTP/1.1
   Host: example.com
   Proxy-authorization: Basic ZWRuYW1vZGU6bm9jYXBlcyE=

Jeff

---

From: Ian Hickson <[email-masked]>
Date: Sat, 30 May 2009 02:33:08 +0000 (UTC)

On Fri, 29 May 2009, Jeff Walden wrote:
>
> The examples don't (explicitly) include the (required) port number in 
> the authority part of the Request-Line.  Also, they're missing 
> HTTP/1.1's (required) Host header.  They instead should be:
> 

Fixed, thanks.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'