Subject: [idn] UCS/UTF-8 is needed for interoperability

From: Dan Oscarsson <[email-masked]>
Date: Tue, 26 Mar 2002 08:47:37 +0100

There have been much talk about UTF-8 as the solution with mind
set on the client.

But the most important thing is that if we are going to make
it easy to interoperate between systems we must agree on the
format of data in the protocols.
Today it is a mess filled with lots of formats. Just look at
e-mail and MIME - just the code needed to decode or encode
a e-mail header is big and complex. That is why it is so difficult
to make programs use e-mail. Think how easy it would have been
if all header lines had used UTF-8!

We need ONE format for character data. UCS encoded as UTF-8 normalised
form C
is the best choice.

Locally in a system you will still use a local character set.
But think how easy the code will be:
- One library to handle the conversion between UCS and local charcter
set
  that can be used by all programs.
- Much simplified parsing, no embedded character set switches.

   Dan

---

From: "Soobok Lee" <[email-masked]>
Date: Tue, 26 Mar 2002 21:03:42 +0900

----- Original Message ----- 
From: "Dan Oscarsson" <[email-masked]>
> We need ONE format for character data. 

I agree. Legacy coded identifiers cannot ensure stable IDN operations.

>UCS encoded as UTF-8 normalised
> form C is the best choice.

I take very conservative position from this point.

NFC is not mature. I have long lists of NFC corrections to be made.
only new normalization can solve it. "new bag for new wine".
If we think UTF8 solutions as long terms solutions, there is no 
reason why we stick with old NFC.

Moreover, we should sync IDN standardization with additions of all *MODERN* scripts 
which should also be debugged and stabilized.   after that, we could freeze the 
unicode version for IDN.

This may be bad news for some commercial driving forces of IDN, because that
means the lucrative IDN (+solutions) market is still far from them.

> - One library to handle the conversion between UCS and local charcter

The conversion to utf8 should be made on direct user inputs and should also
give immediate/interactive responses regarding to any unsuccessful conversions if any.
That is crucial for identifier security and stability.

The DNS is the most crucial kernel component of the INTERNET *OPERATING SYSTEM*. That is why
most paranoid and conservative criticisms of IDN efforts are always justified and welcomed. :-)

Soobok Lee

---

From: Dave Crocker <[email-masked]>
Date: Tue, 26 Mar 2002 06:48:53 -0800

>We need ONE format for character data. UCS encoded as UTF-8 normalised

Since these sorts of discussions are outside the scope of this working 
group, they should move to a different discussion venue and so they can 
focus on formulating a working group with an appropriate charter.

d/

----------
Dave Crocker <mailto:[email-masked]>
TribalWise, Inc. <http://www.tribalwise.com>
tel +1.408.246.8253; fax +1.408.850.1850

---

From: "David Leung \(Neteka Inc.\)" <[email-masked]>
Date: Tue, 26 Mar 2002 11:36:04 -0500

> if all header lines had used UTF-8!

I agree with that. We can use EDNS or something similar to denote that it is
UTF8 : )

> - Much simplified parsing, no embedded character set switches.

Or we can even have ACE in zone file and the DNS generate the UTF8 in
memory...

David Leung
Chief Technology Officer
Neteka Inc.
T: (416) 971-4302
http://w!.neteka.com