Subject: Working Group last call

From: Susan Hares <[email-masked]>
Date: Mon, 26 Aug 2002 14:12:28 -0400

We are starting a working group last call on the
FSM words for the draft-18.  These were sent out by Bill Fenner
in July at the IETF.  I have received comments on the
state machine draft, but I have not received any comments on these words.

Please send any comments on the attached words to the IDR
mail group.  I will send the words in the next message as well.

Please send any comments on the state machine document:

http://www.ietf.org/internet-drafts/draft-hares-bgp-statemt-01.txt

to me.  I have distributed to some individuals a -02 version.
I will be sending to the Internet draft -03 to the IETF secretary for
posting.  Could anyone who has specific text changes send it by
Tuesday evening?  I'll be sending in the draft to the IETF secretary
on Wed am.

We will be focusing on discussing the FSM words for the next 2 weeks.

Sue

---

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 26 Aug 2002 15:22:54 -0400

Sue:
  While your draft is in "work in progress" state, would it be possible
for you to include the "current version key changes section" that you made.
That way we know if our issues are getting addressed.  

Regards,
Ben

> -----Original Message-----
> From: Susan Hares [mailto:[email-masked]]
> Sent: Monday, August 26, 2002 2:12 PM
> To: yakov Rekhter
> Cc: [email-masked]
> Subject: Working Group last call
> 
> 
> 
>

---

From: Susan Hares <[email-masked]>
Date: Wed, 28 Aug 2002 12:50:44 -0400

Ben:

1st - be glad to do the work in progress document.
2nd - could you send me any specific changes to the document today.

Sue

---

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 28 Aug 2002 15:14:34 -0400

Sue:

  I don't have version 2 or 3 of your draft, so I can't comment. Only thing
that
stands out in version 1 is, Actions that could/should Restart the Hold Timer
should not be limited to just KeepAlive and Update messages but any session
non-destructive BGP message (e.g Capability, Inform, etc.). I thought we had
a round on this on the list and I am not sure what the decision was?

IMHO, if a router restarts its Hold Timer upon reception of any session
non-destructive message, it can still communicate correctly with an old
router that
does not support this capability. It just means that a KeepAlive or Update
are
not the only messages preventing the session from expiring. The new router
could still send keepAlive in the absence of any Update message. So the
previous
issue on the list over this for phasing has no merits.

Ben

> Sent: Wednesday, August 28, 2002 12:51 PM
> To: Abarbanel, Benjamin
> Cc: 'Susan Hares'; yakov Rekhter; [email-masked]
> Subject: RE: Working Group last call
> 
> 
> Ben:
>

---

From: "Natale, Jonathan" <[email-masked]>
Date: Wed, 28 Aug 2002 17:28:52 -0400

I agree, it seems to have no merit.  Maybe I missed it?

-----Original Message-----
From: Abarbanel, Benjamin [mailto:[email-masked]] 
Sent: Wednesday, August 28, 2002 3:15 PM
To: 'Susan Hares'; Abarbanel, Benjamin
Cc: yakov Rekhter; [email-masked]
Subject: RE: Working Group last call

Sue:

Ben