Subject: Planned BGP Graceful Restart

From: "Stephen Waters" <[email-masked]>
Date: Fri, 2 Aug 2002 15:16:37 +0100

Hi,

When a manager wishes to force a planned bounce with BGP graceful-restart to glue the bits back together, it seems there is scope (not covered in the draft as far as I can see) to send a message to the peer to say that you are going down.  

This message would be a cue to the helper peer to start the previously exchanged Restart Time timer.

As things stand, it may be a long time (e.g. three minutes) before the helper peer spots that a peer has gone - at which point the restart timer is started. And then, possibly another three minutes later, spot that they have really gone.

In the spec, if a NOTIFICATION is received from a peer, normal session termination is followed, i.e. no graceful restart function is used. 

Perhaps this could be amended to include support for a new notification cause of 'Graceful Restart', which allow the helper to run graceful restart procedures instead?

Thanks, Steve.

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 2 Aug 2002 12:35:32 -0400

If I recall the answer from the last time this was asked:
(and please wrap your lines! :-)

On Fri, Aug 02, 2002 at 03:16:37PM +0100, Stephen Waters wrote:
> When a manager wishes to force a planned bounce with BGP
> graceful-restart to glue the bits back together, it seems there is
> scope (not covered in the draft as far as I can see) to send a
> message to the peer to say that you are going down.

Said message is called a TCP RST or TCP FIN. :-)

-- 
Jeff Haas 
NextHop Technologies