Subject: BGP draft-19 - FSM input needed from developers

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Jan 2003 13:54:16 -0500

The following state machine issues were queried to the list between 12/2 - 12/20 

The following issues need input from developers:

	13.2, 13.4, 13.6 

========================================================

	13.2 -  Connect state, Event 14th

	      Event 14: 
		receipt of a valid TCP connection with an invalid or unconfigured peer

	      Should the peer:
		1) Treat it as a valid response, and enters the active state
		   to watch for a another TCP connection with a valid peer.

		2) treat it as an invalid response, reject the connection and see if a valid
		   configured one comes iwthin the connect timer's window.

	         Without further input, I will select option 2. 
	
	13.4 TCP connection events in state machine

		Do the implementors require Events 13 - 17 in the State machine?

		Event 13 - TCP connection valid indication
		Event 14 - TCP connection invalid indication
		Event 15 - TCP connection request acknowedged
		Event 16 - TCP connection confirmed
		Event 17 - TCP connection fails 

		Choice 1:  Events 13 - 17 are mandatory
		Choice 2:  Event 13 and Event 14 be optional, and Events 15 - 17 be mandator.

		If no one objects, we will use Choice 2.

	13.6   FSM Missing Next States

		In the Open Confirm state, a valid Open message [Event 22] is received.  
		The BGP Peer connection is check to ee if there is a collision per 
		section 6.8.  If this connection is to be dropped due to the call collision,
		the local system will drop the call by:

			- sending a NOTIFICATION with a CEASE,
			- resets the Connect timer (to zero),
			- releases all BGP resources 
				(this includes stopping the Open Delay Timer and reseting it to zero),
			- increments the ConnectRetryCnt by 1 (connect retry count), and
			- optionally performs a BGP peer oscilation damping processing, and
			- enters the Idle State.

		Implementors need to verify if this text and the text for Event 22 allows all implementors
		to perform the necessary Call Collision actions.

		If no objects, we will use this text.

Thank you for your help.

Sue Hares

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 20 Jan 2003 15:09:53 -0500

In message <[email-masked]
> The following issues need input from developers:

All fine except there is no "call collision".  Perhaps you mean
"connection collision".  There seem to be 4 instances of "call
collision" that should be replaced with "connection collision" in the
draft.

Curtis