Subject: BGP Base Draft - Issue List v2.1 (Draft-19)

From: [email-masked]
Date: Mon, 20 Jan 2003 17:01:14 -0800

Attaches is version 2.1 of the issues list.  Since our last iteration,
we have updated 13 issues, and reached consensus on 4.  We're close
on 3 more (13.2, 13.4 and 13.6).  We have 22 issue remaining to clear
up.

Andrew

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 28 Jan 2003 17:28:48 -0500

> ----------------------------------------------------------------------------
> 45) Event 17 in the Connect state
> ----------------------------------------------------------------------------
> Tom then proposed this text:
> 
>        If the TCP connection fails[Event 17] and the Open Delay
>        timer is running, the local system:
>            - restarts the connect retry timer,
>            - clears the Open Delay timer
>            - continues to listen for a connection that may be
>               initiated by the remote BGP peer, and
>            - changes its state to Active.
> 
>         If the TCP connection fails [Event17] and the Open Delay
>         timer is not running, the local system:
>              - drops the TCP connection,
>              - releases all BGP resources,

There are no resources to release while in the connect state.
(Unless we're using this as shorthand for something else - I forget.)

>              - sets ConnectRetryCnt (the connect retry count) to zero

I'm forgetting if this action is consistant with everything else.
I don't have a current copy of the FSM and I don't trust -18 to be
current enough. :-)

This said, why do we go to zero?  I could see not incrementing it
and letting the normal decay process deal with it.  The same would
apply for the above.

>              - resets the connect retry timer (sets to zero), and
>              - goes to Idle state.

Sounds otherwise good.

-- 
Jeff Haas 
NextHop Technologies