Subject: Re: issues 12 - consensus & two changes - 2nd message

From: "Tom Petch" <[email-masked]>
Date: Thu, 30 Jan 2003 21:12:13 -0000

Sue

Change 2, stop Open Delay timer in Connect state events 9 and 17,
fine; that is what I understand to be the real issue 12.

Change 1, event 19 in Active state, is IMHO issues 47 and 52.  This is
tangled because the initial paragraphs of Issue 12 in the issue list
are nothing to to with stopping Open Delay timer and everything to to
with sending a Keepalive message before entering Open Confirm state
from Active or Connect state on event 19; which I raised and see as
issue 52.  Issue 47 was Siva's issue 28 and relates to a different
action for Active state event 19.

I agree with change 1 in that it adds in the sending of Keepalive
which I believe essential; I think Siva needs to respond concerning
issue 47.  (nb the stop Open Delay action is duplicated)  I wonder if
we should use a different character for the bullet points under the if
and else clauses to make it clear where they end ie
- if the hold timer ....
+ do this
+ and this
  else if ...
+ do the other
+ and this

But I still have an issue for Connect state event 19 where I believe,
as for Active state event 19, we should send a Keepalive and start the
Keepalive timer.  I will pursue this as part of issue 52 if that suits
you.  I think the text will be the same as whatever we agree for
Active state event 19.

Tom Petch
[email-masked]

-----Original Message-----
From: Susan Hares <[email-masked]>
To: Tom Petch <[email-masked]>; [email-masked]
<[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: 30 January 2003 10:39
Subject: issues 12 - consensus & two changes - 2nd message

Tom and idr:

I believe issues 12 is in consensus. Please
ack the new text below.

Sue
==================
Change 1:  new text

Active state - event 19

    If an Open is received with the Open Delay timer is
    running [Event 19], the local system
        - clears the connect retry timer (cleared to zero),
        - stops and clears the Open Delay timer
        - completes the BGP initialization,
        - stops and clears the Open Delay timer
        - sends an OPEN message,
- send a Keepalive message,
- if the hold timer value is non-zero,
- starts the keepalive timer to initial value,
- resets the hold timer to the negotiated value,
  else if the hold timer is zero
- resets the keepalive timer (set to zero),
- resets the hold timer to zero.

        - changes its state to OpenConfirm.

    If the value of the autonomous system field is the same as the
local
    Autonomous System number, set the connection status to an internal
    connection; otherwise it is "external".

Change 2 -
Connect state
event 17 (currently defined as going to Active)
event 9 (stays in Connect state)

new Text:

     In response to the connect retry timer expires event [Event
     9], the local system:
        - drops the TCP connection,
        - restarts the connect retry timer,
- stops the Open Delay timer and resets the timer to zero,
        - initiates a TCP connection to the other BGP peer,
        - continues to listen for a connection that may be
          initiated by the remote BGP peer, and
        - stays in Connect state.

     If the TCP connection fails [Event17], the local system:
         - restarts the connect retry timer,
- stops the Open Delay timer and resets value to zero,
         - continues to listen for a connection that may be
           initiated by the remote BGP peer, and
         - changes its state to Active.

Sue Hares

---

From: [email-masked]
Date: Thu, 30 Jan 2003 13:43:56 -0800

Ok, does anyone object, if we move Issue 12 to consensus, with the text
that Sue spelled out in Change 2, as its resolution?  I'll then move
the Keepalive discussion, and the text in Change 1 to issue 52.

Andrew

On Thu, Jan 30, 2003 at 09:12:13PM -0000, Tom Petch wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Reply-To: "Tom Petch" <[email-masked]>
> From: "Tom Petch" <[email-masked]>
> To: "Susan Hares" <[email-masked]>, <[email-masked]>
> Cc: <[email-masked]>
> Subject: Re: issues 12 -  consensus & two changes - 2nd message
> Date: Thu, 30 Jan 2003 21:12:13 -0000
> X-Priority: 3
> X-MSMail-Priority: Normal
> X-Mailer: Microsoft Outlook Express 4.72.2106.4
> X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
> Precedence: bulk
> X-Spam-Status: No, hits=0.7 required=5.0
> 	tests=AWL,SPAM_PHRASE_00_01,USER_AGENT_OE
> 	version=2.43
> X-OriginalArrivalTime: 30 Jan 2003 21:14:54.0402 (UTC) FILETIME=[A25D7220:01C2C8A4]
> 
> Sue
>