Subject: BGP-draft-19: Issue 52 - Event 18 in OpenSent State (Keepalive timer set)

From: "Susan Hares" <[email-masked]>
Date: Tue, 21 Jan 2003 10:46:26 -0500

Jeff and Siva:

  I need to hear from additional implementers
on the following.  Would you both check your
implementations? 

Sue Hares

-------------	

Issue 52 - 
	status: non-consensus 

		<----	Open [Open sent state]
	open ---->  
			[Event 18 in Open Sent 
		<----- Keepalive 

	Event 18:
		- clears BGP delay timer
		- resets BGP connect timer
		- sends Keepalive message
		- if negotiated hold timer is zero,
			o reset keepalive timer,
			o reset hold timer.

		- if negotiated hold timer is non-zero
			o set keepalive timer,
			o set hold timer to negotiated value. 

	Here the question is, do you want to send a 2nd
	keepalive if the keepalive timer expires in 
	Open Confirm.  

     The current draft allows this until the hold timer 
     expires.   The sequence would be:

     The current draft allows this until the hold timer 
     expires.   The sequence would be:

			<---- open [open sent]
		open -->  [event 18]

			<-----keepalive

				[keepalive timeout [Event 11]
			<---- Keepalive

				[Keepalive time out [Event 11]
			<--- Keepalive

				[hold time-out, Event 10]
			<---Notification
			    drop TCP connection
			 
Please confirm that you want to remove these subsequent keepalives in
Open Confirm.

Sue

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 21 Jan 2003 21:28:28 -0500

In message <[email-masked]
> on the following.  Would you both check your

Yawn...		[not what you wanted to hear?]

Make it optional.  Timing out in open or open-sent has never been much
of an issue, so whether one or three keepalive get sent shouldn't be a
hot topic.

Curtis