Subject: Re: [Idr] RFC 4360 clarification (BGP Extended Communities Attribute)

From: "Pradosh Mohapatra (pmohapat)" <[email-masked]>
Date: Mon, 3 Aug 2009 13:52:34 -0700

Hi Bruno,

| We have a clarification question regarding RFC 4360. Section "6.
| Operations" states that "If a route has a non-transitivity extended
| community, then before advertising the route across the Autonomous
| System boundary the community SHOULD be removed from the route."
| 
| Is it compliant with the specification to:
| -a- set / add, on the outbound policy of an eBGP session, a non
| transitive extended community?
| -b- expect that the eBGP peer will not remove it to enforce the
| non-transitivity?
| 
| It seems to us that this is compliant:
| -a- seems to be inlined with the operation of well know communities
| defined in RFC 1997 where the advertisement restrictions applies when
| BGP receive a route with this community, not when it advertise it.
| -b- RFC 4360 does not ask the eBGP to enforce the non-transitivity
(and
| besides, non-transivity is a SHOULD, not a MUST)
| 
| - Could you please correct or confirm this?
| - If your BGP implementation removes a non-transitive community
| received
| over an eBGP session, could you please tell us? (either privately or
on
| the mailing list).

The implementations I know of will strip out the non-transitive extcomms
even if they get attached through the outbound policy before advertising
them to EBGP peers. And yes, it would also remove all non-transitive
extcomms received over an EBGP session.

- Pradosh

---

From: "Dhananjaya Rao (dhrao)" <[email-masked]>
Date: Mon, 3 Aug 2009 14:01:57 -0700

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Pradosh Mohapatra (pmohapat)
>Sent: Monday, August 03, 2009 1:53 PM
>To: [email-masked]; [email-masked]
>Subject: Re: [Idr] RFC 4360 clarification (BGP Extended 
>CommunitiesAttribute)
>
>Hi Bruno,
>
>

Although this does seem to be different from the behavior for other
non-transitive attributes, for example MED. Any good reason for it to
be different ? Seems like this behavior would in fact prevent a
non-transitive extended community from being used between 2 ASes.

Thanks,
-Dhananjaya

>- Pradosh
>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/idr
>