Subject: Re: [Idr] draft-uttaro-idr-add-paths-guidelines-02

From: Pierre Francois <[email-masked]>
Date: Sun, 01 Aug 2010 21:33:14 +0200

Uli, Martin,

Thanks for your input.

What do you mean by "generally improve consistency" ? I'm not sure about which 
consistency we're talking about.

Regarding the new proposed mode, we'll provide its analysis under the terms of 
the draft, to the ML, and based on feedback consider it for inclusion in the draft.

Regards,

Pierre.

Uli Bornhauser wrote:
> Hi Pierre, all,
> 
> as we discussed yesterday, my thoughts and remarks with respect to the draft version:
> 
> In section 4.2, the authors mention that receiving multiple paths improves convergence (cf. MED/IGP oscillation section) and Expressiveness (cf. Path optimality section). At this point, you could also mention that path diversity generally improves the consistency. As far as I see, this pro-argument is not covered by the remarks.
> 
> With respect to the Path Selection Modes, cf. section 4.3.1: After reading the draft, it seems reasonable to say that the mode described in section 4.3.1.5,
> 
> "Advertising Neighbor-AS Group Best Path", is a natural generalization of the common best path advertisement to all neighbor-AS groups.
> 
> From my point of view, exchanging best external paths between domains as described in [1] is also a very interesting concept. As this document is a work group draft, I assume that I am not the only one who things so. Similar to the scheme described in section 4.3.1.5., from my point of view, it seems reasonable to generalize the concept of advertising best external paths to all neighbor-AS groups. I.e., I think an interesting path selection mode could be 
> 
> "Advertising Neighbor-AS Group Best External Path". Analogously to 4.3.1.5, this could be understood as a generalization of the best external path advertisement scheme [1] to all neighbor-AS groups. According to the draft, the basic idea is simple. Using this scheme, "a speaker"
> 
> - advertises its best domain external path for each neighbor-AS group into the own domain, and
> - advertises its best domain internal path for each neighbor-AS group to the external domains.
> 
> As thoroughly described in [1], a domain can be a Route Reflection cluster (in this case "the speaker" is a RR) or the AS (in that case "the speaker" is an ASBR). This concept would combine the advantages of advertising best external paths and the availability of group best paths. Comments to this idea are of course welcome. I something did not become clear, feel free to ask.
> 
> All in all, I think that besides the one scheme I mentioned, the draft covers all important and interesting modes that can be to applied upon add-path. So far, a very good and substantial work.
> 
> Best Regards
> 
> Uli
> 
> [1] http://tools.ietf.org/id/draft-ietf-idr-best-external-01.txt
> 
> Am 26.07.2010 um 10:43 schrieb Pierre Francois:
> 
>>
>> Hi,
>>
>> For those who are impatient to read the latest version of the add-paths-guidelines draft, and couldn't find it :
>>
>> http://inl.info.ucl.ac.be/system/files/draft-uttaro-idr-add-paths-guidelines-02.txt
>>
>> Regards,
>>
>> Pierre.
>>
>> _______________________________________________
>> Idr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/idr
>

---

From: Uli Bornhauser <[email-masked]>
Date: Wed, 4 Aug 2010 17:45:25 +0200

Hi Pierre, 

sorry for the delay.

Am 01.08.2010 um 21:33 schrieb Pierre Francois:

> What do you mean by "generally improve consistency" ? I'm not sure about which consistency we're talking about.

I am thinking of consistency in the sense of avoiding deflection and loops (which result from inconsistent local views). By realizing path diversity, it becomes more likely that routers are aware of the same (important) routing information, resulting in an increased probability for consistent routing decisions.

A very simple example may be found in [1], page 11, figure 14.

Regards

Uli

[1]
Timothy Griffin and Gordon T. Wilfong.
On the Correctness of IBGP Configuration.
SIGCOMM Comput. Commun. Rev., 32(4):17–29, August 2002.

-- 
_______________________________________________________
ULI BORNHAUSER
University of Bonn - Institute of Computer Science IV
c/o Bonn-Aachen International Center for Information Technology B-IT 
Dahlmannstr. 2 - D-53113 Bonn - Germany

Web: www.cs.bonn.edu/IV/ub
Email: [email-masked]			
Phone: +49 (228) 2699-154
Fax: +49 (228) 73 - 4571

---

From: Pierre Francois <[email-masked]>
Date: Wed, 04 Aug 2010 18:02:50 +0200

Uli,

> sorry for the delay.

No problem.

If it's about avoiding deflection and loops, wouldn't you be pro
"AS Wide best + next best" in guidelines-02, or the variant described below ?

I'm failing to see what other gain you would get from advertising the additional 
paths as in [1] that you wouldn't find with one of these 2 modes.

Advertise Double AS Wide Best Paths

This variant of "Advertise AS Wide Best Paths" trades-off the number
of paths being propagated within the iBGP system for post-convergence
alternate paths availability and routing stability. A BGP speaker
running this mode will select for advertisement its AS Wide Best
paths, plus all the AS Wide Best paths obtained when removing the
first ones from consideration.

Under this mode, a BGP speaker knows multiple AS-Wide best paths or
the AS-Wide best path and all the second AS-Wide best paths, so
that routing optimality and backup path availability are ensured. Note that the
post-convergence paths will be known by each BGP node in an AS
supporting this mode.

The computation complexity of this mode is relatively low as it
requires to run the usual BGP Decision Process up to and including the
MED rule. The set of paths remaining after that step form the first set of 
AS-Wide best paths.  Next, a best path selection algorithm is run up to and
including the MED rule, based on the paths that are not in the first set of
AS-Wide best paths.

The number of paths for a prefix p, known by a given router of the AS,
is the number of AS-Wide best and second AS-Wide best paths found at
the Borders of the AS.

MED Oscillations are avoided by this mode, both for the primary and
alternate paths being picked.

Comments are welcome !

Pierre.

---

From: Uli Bornhauser <[email-masked]>
Date: Thu, 5 Aug 2010 15:54:14 +0200

Hi Pierre,

Am 04.08.2010 um 18:02 schrieb Pierre Francois:

> 
> Uli,
> 
> Uli Bornhauser wrote:
>> Hi Pierre, sorry for the delay.
> 
> No problem.
> 
> I'm failing to see what other gain you would get from advertising the additional paths as in [1] that you wouldn't find with one of these 2 modes.

This seems to be a misunderstanding.
I only wanted to suggest to add the statement that path diversity helps to improve consistency within an AS in section 3, Add-Paths Applications; it helps to avoid loops and deflection. This is an add-path application the drafts does not mention so far.
"Advertise All AS-Wide Best Paths Plus Next-Best" is fine to reach this. With the reference to [1], I did not want to suggest a(n) new/other mode. I only what to give you an example where "Advertise All AS-Wide Best Paths Plus Next-Best" (and a lot of other modes the drafts proposed) helps to get consistent views.
So, no new mode, only another add-path application for the described modes.

Independently, I think that "Advertising Neighbor-AS Group Best External Path" as described in my email of 2010-07-29 could be another mentionable concept.

Sorry for the confusion and best regards

Uli

> MED rule. The set of paths remaining after that step form the first set of AS-Wide best paths.  Next, a best path selection algorithm is run up to and

---

From: Pierre Francois <[email-masked]>
Date: Mon, 09 Aug 2010 13:56:12 +0200

Uli,

Got it.

We will modify the draft accordingly, thanks for your input.

Pierre.