Subject: [Idr] FW: New Version Notification for draft-qin-idr-sr-policy-ifit-03.txt

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 2 Sep 2020 08:00:44 +0000

Dear All,
We have just uploaded a new version of draft-qin-idr-sr-policy-ifit. 
This revision addresses the comments received during the IDR session at IETF 108 from Ketan and Joel.
In particular we tried to clarify the term IFIT and we also included a new Motivation Section.

Feedbacks and suggestions are always welcome.

Best Regards,

Giuseppe

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, September 2, 2020 9:47 AM
To: Giuseppe Fioccola <[email-masked]>; Fengwei Qin <[email-masked]>; wangyali <[email-masked]>; Hang Yuan <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-qin-idr-sr-policy-ifit-03.txt

A new version of I-D, draft-qin-idr-sr-policy-ifit-03.txt
has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.

Name:		draft-qin-idr-sr-policy-ifit
Revision:	03
Title:		BGP SR Policy Extensions to Enable IFIT
Document date:	2020-09-02
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-qin-idr-sr-policy-ifit-03.txt
Status:         https://datatracker.ietf.org/doc/draft-qin-idr-sr-policy-ifit/
Htmlized:       https://tools.ietf.org/html/draft-qin-idr-sr-policy-ifit-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-qin-idr-sr-policy-ifit
Diff:           https://www.ietf.org/rfcdiff?url2=draft-qin-idr-sr-policy-ifit-03

Abstract:
   Segment Routing (SR) policy is a set of candidate SR paths consisting
   of one or more segment lists and necessary path attributes.  It
   enables instantiation of an ordered list of segments with a specific
   intent for traffic steering.  In-situ Flow Information Telemetry
   (IFIT) refers to network OAM data plane on-path telemetry techniques,
   in particular the most popular are In-situ OAM (IOAM) and Alternate
   Marking.  This document defines extensions to BGP to distribute SR
   policies carrying IFIT information.  So that IFIT methods can be
   enabled automatically when the SR policy is applied.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sun, 27 Sep 2020 10:53:13 +0000

Hi Giuseppe, 

Thanks for this update, here are some review comments from my side:

1. This document defines several sub-TLVs under BGP Tunnel Encapsulation Attribute for different IFIT related functions. Perhaps it would be better to define just one sub-TLV for IFIT, then define the different IFIT functions with sub-sub-TLVs?

2. In addition to describing the encoding of the sub-TLVs, it may be helpful to also describe the operation of node when receiving an SR policy with these IFIT sub-TLVs.

Best regards,
Jie

> From: Idr [mailto:[email-masked]] On Behalf Of Giuseppe Fioccola
> Sent: Wednesday, September 2, 2020 4:01 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Idr] FW: New Version Notification for draft-qin-idr-sr-policy-ifit-03.txt
> 
> Dear All,
> To: Giuseppe Fioccola <[email-masked]>; Fengwei Qin
> <[email-masked]>; wangyali <[email-masked]>; Hang
> Yuan <[email-masked]>; Tianran Zhou <[email-masked]>
> URL:
> https://www.ietf.org/internet-drafts/draft-qin-idr-sr-policy-ifit-03.txt
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-qin-idr-sr-policy-ifit
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 28 Sep 2020 10:37:45 +0000

Hi Jie,
Thanks a lot for your review.
Please find my answers inline tagged as [GF].

Regards,

Giuseppe

-----Original Message-----
From: Dongjie (Jimmy) 
Sent: Sunday, September 27, 2020 12:53 PM
To: Giuseppe Fioccola <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: New Version Notification for draft-qin-idr-sr-policy-ifit-03.txt

Hi Giuseppe, 

1. This document defines several sub-TLVs under BGP Tunnel Encapsulation Attribute for different IFIT related functions. Perhaps it would be better to define just one sub-TLV for IFIT, then define the different IFIT functions with sub-sub-TLVs?
[GF]: Yes, I agree. We can clarify that the 5 sub-TLVs (IOAM and AltMark) are carried in the IFIT sub-TLV. The new general IFIT attributes sub-TLV will be introduced in the next revision.

2. In addition to describing the encoding of the sub-TLVs, it may be helpful to also describe the operation of node when receiving an SR policy with these IFIT sub-TLVs.
[GF]: Good suggestion, we can also add a new section about the operations with IFIT similarly to the section on SR Policy Operations of draft-ietf-idr-segment-routing-te-policy. We will describe how the addition of IFITAttributes Sub-TLVs is handled for the SR Policy NLRI.

Best regards,
Jie

> This revision addresses the comments received during the IDR session 
> at IETF
> 108 from Ketan and Joel.
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 30 Sep 2020 08:07:21 +0000

Hi Giuseppe,

Thanks for your reply. 

The changes in plan looks good to me. Look forward to a updated version.

Best regards,
Jie

> From: Giuseppe Fioccola
> Sent: Monday, September 28, 2020 6:38 PM
> To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
> 1. This document defines several sub-TLVs under BGP Tunnel Encapsulation
> Attribute for different IFIT related functions. Perhaps it would be better to
> define just one sub-TLV for IFIT, then define the different IFIT functions with
> sub-sub-TLVs?
> [GF]: Yes, I agree. We can clarify that the 5 sub-TLVs (IOAM and AltMark) are
> carried in the IFIT sub-TLV. The new general IFIT attributes sub-TLV will be
> introduced in the next revision.
> 
> 2. In addition to describing the encoding of the sub-TLVs, it may be helpful to
> also describe the operation of node when receiving an SR policy with these IFIT
> sub-TLVs.
> [GF]: Good suggestion, we can also add a new section about the operations
> with IFIT similarly to the section on SR Policy Operations of
> draft-ietf-idr-segment-routing-te-policy. We will describe how the addition of
> IFITAttributes Sub-TLVs is handled for the SR Policy NLRI.
> 
> Best regards,
> Jie
> 
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-qin-idr-sr-policy-ifit-03
> >
> > Abstract: