Subject: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

From: <[email-masked]>
Date: Mon, 7 Sep 2020 11:12:55 +0800 (CST)

Hi Ketan,

I have a question for section 7.3.  SRv6 SID Structure TLV, and hope to get your answer.

It described:

SRv6 SID Structure TLV is used to advertise the length of each
 individual part of the SRv6 SID as defined in
 [I-D.ietf-spring-srv6-network-programming]. It is an optional TLV
 for use in the BGP-LS Attribute for an SRv6 SID NLRI and as an
 optional sub-TLV of the SRv6 End, IS-IS SRv6 LAN End.X and OSPFv3
 SRv6 LAN End.X TLVs. The TLV has the following format:

My question is:

1) Becasue section 7 mentions that "This section specifies the new TLVs to be carried in the BGP Link State Attribute associated with the BGP-LS SRv6 SID NLRI.",

    so, can "structure TLV" be also associated with BGP-LS Link NLRI ?

2) As the description, does it mean that an SRv6 SID NLRI can contain SRv6 SID Information TLV for END SID or LAN End.X SID, then "structure TLV" is also associated with BGP-LS Link NLRI ?

3) Why the description skip End.X SID ?

Regards,

PSF

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 7 Sep 2020 04:19:17 +0000

Hi PSF and Ketan,

IMHO, the SRv6 SID Structure TLV can be included in the sub-TLV field of SRv6 END.X TLV, SRv6 LAN END.X TLV (for adj SIDs) and SRv6 SID NLRI(for node SIDs). So I guess it may be a typo, the SRv6 End should be SRv6 End.X.  We can double check the IANA section.

But from the text in Section 7, SRv6 SID attributes,

   This section specifies the new TLVs to be carried in the BGP Link
   State Attribute associated with the BGP-LS SRv6 SID NLRI.

The sub-TLVs defined in this section are associated with the SRv6 SID NLRI, so these sub-TLVs are associated with node SIDs. Regarding Adj SIDs, the information is included in the Link NLRI. If so, do we need to make a new upper level for SRv6 SID Structure sub-TLV? Because it is not only apply for node SIDs but also link/adj SIDs.

Regarding the second question.  I think,

·         an Adj-SID is included in the Link NLRI, with an optional SID Structure TLV as a sub-TLV. SRv6 SID NLRI and attributes are not needed to be included.

·         a Node SID is included in the SRv6 SID NLRI, with TLVs like SRv6 Endpoint Behavior TLV, SRv6 BGP Peer Node SID TLV, SRv6 SID Structure TLV in the SRv6 SID attributes to describe the information of the node SID.

Respect,
Cheng

From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, September 7, 2020 11:13 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan,

It described:

My question is:

Regards,

PSF

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 9 Sep 2020 07:07:04 +0000

Hi PSF and Cheng,

Please check inline below.

From: Chengli (Cheng Li) <[email-masked]>
Sent: 07 September 2020 09:49
To: [email-masked]; Ketan Talaulikar (ketant) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi PSF and Ketan,

IMHO, the SRv6 SID Structure TLV can be included in the sub-TLV field of SRv6 END.X TLV, SRv6 LAN END.X TLV (for adj SIDs) and SRv6 SID NLRI(for node SIDs). So I guess it may be a typo, the SRv6 End should be SRv6 End.X.
[KT] You are correct. It should be End.X and not End. Will fix this typo in the next update.

 We can double check the IANA section.

The sub-TLVs defined in this section are associated with the SRv6 SID NLRI, so these sub-TLVs are associated with node SIDs.
[KT] This is correct – they are SIDs associated with the node.

Regarding Adj SIDs, the information is included in the Link NLRI. If so, do we need to make a new upper level for SRv6 SID Structure sub-TLV? Because it is not only apply for node SIDs but also link/adj SIDs.
[KT] I do not understand what you mean by “new upper level for SRv6 SID Structure sub-TLV”? Sec 7.3 clearly says how it can be encoded

   It is an optional TLV
   for use in the BGP-LS Attribute for an SRv6 SID NLRI and as an
   optional sub-TLV of the SRv6 End.X, IS-IS SRv6 LAN End.X and OSPFv3
   SRv6 LAN End.X TLVs.
Regarding the second question.  I think,

  *   an Adj-SID is included in the Link NLRI, with an optional SID Structure TLV as a sub-TLV. SRv6 SID NLRI and attributes are not needed to be included.
[KT] Correct – we are talking about End.X and LAN End.X here.

  *   a Node SID is included in the SRv6 SID NLRI, with TLVs like SRv6 Endpoint Behavior TLV, SRv6 BGP Peer Node SID TLV, SRv6 SID Structure TLV in the SRv6 SID attributes to describe the information of the node SID.
[KT] Correct.

[KT] I did not understand the third question from PSF

Thanks,
Ketan

Respect,
Cheng

From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, September 7, 2020 11:13 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan,

It described:

My question is:

Regards,

PSF

---

From: <[email-masked]>
Date: Wed, 9 Sep 2020 15:27:33 +0800 (CST)

Hi Ketan, Cheng,

Thanks for your reply.

I have get clear answer to my questions.

The third question is meaningless once the typo is corrected.

I also suggest that "structure TLV" can not be palced under section 7, as Cheng suggested.

Regards,

PSF

原始邮件

发件人：KetanTalaulikar(ketant) <ketant=[email-masked]>
收件人：Chengli (Cheng Li) <[email-masked]>;彭少富10053815;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年09月09日 15:07
主 题 ：Re: [spring] [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

Hi PSF and Cheng,

 

 

Hi PSF and Ketan,

IMHO, the SRv6 SID Structure TLV can be included in the sub-TLV field of SRv6 END.X TLV, SRv6 LAN END.X TLV (for adj SIDs) and SRv6 SID NLRI(for
 node SIDs). So I guess it may be a typo, the SRv6 End should be SRv6 End.X. 

 

 

 

 

 

Regarding Adj SIDs, the information is included in the Link NLRI. If so, do we need to make a new upper level for SRv6 SID Structure sub-TLV? Because
 it is not only apply for node SIDs but also link/adj SIDs.

 

   It is an optional TLV

   SRv6 LAN End.X TLVs.

an Adj-SID is included in the Link NLRI, with an optional SID Structure TLV as a sub-TLV. SRv6 SID NLRI and attributes are not needed to be included.  

 

a Node SID is included in the SRv6 SID NLRI, with TLVs like SRv6 Endpoint Behavior TLV, SRv6 BGP Peer Node SID TLV, SRv6 SID Structure TLV in the SRv6 SID attributes to describe the
 information of the node SID.

[KT] Correct.

 

 

Thanks,

Ketan

Respect,

Cheng

 

 

From: Idr [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: Monday, September 7, 2020 11:13 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan,

It described:

SRv6 SID Structure TLV is used to advertise the length of each   individual part of the SRv6 SID as defined in   [I-D.ietf-spring-srv6-network-programming].  It is an optional TLV   for use in the BGP-LS Attribute for an SRv6 SID NLRI and as an   optional sub-TLV of the SRv6 End, IS-IS SRv6 LAN End.X and OSPFv3   SRv6 LAN End.X TLVs.  The TLV has the following format:

My question is:

2) As the description, does it mean that an SRv6 SID NLRI can contain SRv6 SID Information TLV for END SID or LAN End.X SID, then "structure TLV" is also associated with BGP-LS Link
 NLRI ?

Regards,

PSF

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 9 Sep 2020 07:30:33 +0000

Hi Ketan and PSF,

Yes, I mean it may be better to add a new section to describe the SRv6 SID structure TLV, like section 8, instead of 7.3.

Thanks,
Cheng

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, September 9, 2020 3:28 PM
To: ketant=[email-masked]
Cc: Chengli (Cheng Li) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re:[spring] [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan, Cheng,

Thanks for your reply.

Regards,

PSF

原始邮件
发件人：KetanTalaulikar(ketant) <ketant=[email-masked]<mailto:ketant=[email-masked]>>
收件人：Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>;彭少富10053815;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;[email-masked] <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年09月09日 15:07
主 题 ：Re: [spring] [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring
Hi PSF and Cheng,

From: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: 07 September 2020 09:49
To: [email-masked]<mailto:[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi PSF and Ketan,

   It is an optional TLV

Thanks,
Ketan

Respect,
Cheng

From: Idr [mailto:[email-masked]]On Behalf Of [email-masked]<mailto:[email-masked]>

Hi Ketan,

It described:

My question is:

Regards,

PSF

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 9 Sep 2020 09:05:13 +0000

Sure. We can make this editorial change on the next update.

Thanks,
Ketan

From: Chengli (Cheng Li) <[email-masked]>
Sent: 09 September 2020 13:01
To: [email-masked]; Ketan Talaulikar (ketant) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: Re:[spring] [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan and PSF,

Thanks,
Cheng

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, September 9, 2020 3:28 PM
To: ketant=[email-masked]<mailto:ketant=[email-masked]>
Cc: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re:[spring] [Idr] questions about draft-ietf-idr-bgpls-srv6-ext-03

Hi Ketan, Cheng,

Thanks for your reply.

Regards,

PSF

原始邮件

Hi PSF and Ketan,

   It is an optional TLV

Thanks,
Ketan

Respect,
Cheng

Hi Ketan,

It described:

My question is:

Regards,

PSF