Subject: Re: [Idr] [IANA #1183451] Protocol Action: 'Dissemination of Flow Specification Rules for IPv6' to Proposed Standard (draft-ietf-idr-flow-spec-v6-21.txt)

From: Christoph Loibl <[email-masked]>
Date: Mon, 14 Dec 2020 10:57:47 +0100

Hi Amanda,

CC also to IDR for reference.

Sorry for the delayed answers to your questions. During the review of the changes I noticed that the Action 2 requested a new codepoint from the Generic Extended Community registry but the document is clearly referencing a IPv6-Specific-Extended Community in sections 6., 6.1 (the IANA section 8.2 was not aligned with the text above). 

I updated and uploaded  a version -22 of the document to correct that defect. Alvaro reviewed the changes. I will also notify RFC-Editors about the changed document.

To answer your questions:

ACTION 1:

>> QUESTION: All words in the registry other than "flags" and "length"
>> (at values 9 and 10) were capitalized by this document. We have no
>> opinion, but should those words have been capitalized as well?

Please capitalize those as well. The -22 document also addresses this nit.

ACTION 2:

Please revert the -21 changes and see the new -22 Section 8.2 for the correct registry that needs to be updated.

Sorry for that.

Cheers Christoph

-- 
Christoph Loibl
[email-masked] | CL8-RIPE | PGP-Key-ID: 0x4B2C0055 | http://www.nextlayer.at

> On 10.12.2020, at 20:41, Amanda Baber via RT <[email-masked]> wrote:
> 
> Dear Authors,
> 
> This is a reminder that we need a reply to the message below.
> 
> Best regards,
> 
> Amanda Baber
> Lead IANA Services Specialist
> 
> On Thu Dec 03 01:19:39 2020, amanda.baber wrote:
>> Dear Authors:
>> 
>> ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED
>> 
>> We've completed the registry actions for the following RFC-to-be:
>> 
>> draft-ietf-idr-flow-spec-v6-21
>> 
>> ACTION 1:
>> 
>> An "IPv6 Name" column, references to this document, and a new
>> registration at value 13 have been added to the Flow Spec Component
>> Types registry, which now reads as follows:
>> 
>> Flow Spec Component Types
>> Expert(s): Susan Hares, Robert Raszuk
>> Reference: [RFC-ietf-idr-rfc5575bis-26][RFC-ietf-idr-flow-spec-v6-21]
>> 
>> Range   Registration Procedures
>> 0       Reserved
>> 1-127   Specification Required
>> 128-254 Expert Review
>> 255     Reserved
>> 
>> Type Value      IPv4 Name       IPv6 Name       Reference
>> 0       Reserved        Reserved        [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 1       Destination Prefix      Destination IPv6 Prefix [RFC-ietf-idr-
>> rfc5575bis-26][RFC-ietf-idr-flow-spec-v6-21]
>> 2       Source Prefix   Source IPv6 Prefix      [RFC-ietf-idr-
>> rfc5575bis-26][RFC-ietf-idr-flow-spec-v6-21]
>> 3       IP Protocol     Upper-Layer Protocol    [RFC-ietf-idr-
>> rfc5575bis-26][RFC-ietf-idr-flow-spec-v6-21]
>> 4       Port    Port    [RFC-ietf-idr-rfc5575bis-26][RFC-ietf-idr-
>> flow-spec-v6-21]
>> 5       Destination Port        Destination Port        [RFC-ietf-idr-
>> rfc5575bis-26][RFC-ietf-idr-flow-spec-v6-21]
>> 6       Source Port     Source Port     [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 7       ICMP Type       ICMPv6 Type     [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 8       ICMP Code       ICMPv6 Code     [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 9       TCP flags       TCP flags       [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 10      Packet length   Packet length   [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 11      DSCP    DSCP    [RFC-ietf-idr-rfc5575bis-26][RFC-ietf-idr-
>> flow-spec-v6-21]
>> 12      Fragment        Fragment        [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 13      Unassigned      Flow Label      [RFC-ietf-idr-flow-spec-v6-21]
>>     14-254  Unassigned      Unassigned
>> 255     Reserved        Reserved        [RFC-ietf-idr-rfc5575bis-
>> 26][RFC-ietf-idr-flow-spec-v6-21]
>> 
>> QUESTION: All words in the registry other than "flags" and "length"
>> (at values 9 and 10) were capitalized by this document. We have no
>> opinion, but should those words have been capitalized as well?
>> 
>> Please see
>> https://www.iana.org/assignments/flow-spec
>> 
>> ACTION 2:
>> 
>> We've added the following entry to the Generic Transitive Experimental
>> Use Extended Community Sub-Types registry:
>> 
>> Sub-Type Value: 0x0e
>> Name: Flow spec rt-redirect-ipv6 format
>> Reference: [RFC-ietf-idr-flow-spec-v6-21]
>> Date: 2020-12-02
>> 
>> Please see
>> https://www.iana.org/assignments/bgp-extended-communities
>> 
>> Please let us know whether this document's registry actions have been
>> completed correctly. Once we receive your confirmation, we'll notify
>> the RFC Editor that the actions are complete. If a team of authors is
>> responsible for the document, and the actions have been performed
>> correctly, please send a single confirmation message.
>> 
>> We'll update any references to this document in the registries when
>> the RFC Editor notifies us that they've assigned an RFC number.
>> 
>> Best regards,
>> 
>> Amanda Baber
>> Lead IANA Services Specialist
>

---

From: "Michelle Cotton via RT" <[email-masked]>
Date: Mon, 14 Dec 2020 18:45:00 +0000

Hello,

The changes as requested in version 22 of the document have been completed.

We have capitalized "Flags" and "Length" for values 9 and 10 in the following registry:  https://www.iana.org/assignments/flow-spec

We removed the registration (0x0e) in the Generic Transitive Experimental Use Extended Community Sub-Types registry.

We have registered the following:

Transitive IPv6-Address-Specific Extended Community Types

0x000d	Flow spec rt-redirect-ipv6 format

See: https://www.iana.org/assignments/bgp-extended-communities

Please let us know if this document's revised actions have been completed correctly.

Thank you,

Michelle Cotton
Protocol Parameters Engagement Sr. Manager
IANA Services

On Mon Dec 14 09:58:27 2020, [email-masked] wrote:
> Sorry for the delayed answers to your questions. During the review of
> the changes I noticed that the Action 2 requested a new codepoint from
> the Generic Extended Community registry but the document is clearly
> referencing a IPv6-Specific-Extended Community in sections 6., 6.1
> (the IANA section 8.2 was not aligned with the text above).
> 
> I updated and uploaded  a version -22 of the document to correct that
> defect. Alvaro reviewed the changes. I will also notify RFC-Editors
> about the changed document.
> 
> Please revert the -21 changes and see the new -22 Section 8.2 for the
> correct registry that needs to be updated.
> 
> Sorry for that.
> 
> Cheers Christoph