Subject: [Idr] I-D Action: draft-ietf-idr-bgp-ls-segment-routing-ext-17.txt

From: [email-masked]
Date: Sun, 21 Mar 2021 23:39:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : BGP Link-State extensions for Segment Routing
        Authors         : Stefano Previdi
                          Ketan Talaulikar
                          Clarence Filsfils
                          Hannes Gredler
                          Mach(Guoyi) Chen
	Filename        : draft-ietf-idr-bgp-ls-segment-routing-ext-17.txt
	Pages           : 31
	Date            : 2021-03-21

Abstract:
   Segment Routing (SR) allows for a flexible definition of end-to-end
   paths by encoding paths as sequences of topological sub-paths, called
   "segments".  These segments are advertised by routing protocols e.g.
   by the link state routing protocols (IS-IS, OSPFv2 and OSPFv3) within
   IGP topologies.

   This document defines extensions to the BGP Link-state address-family
   in order to carry segment routing information via BGP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing-ext/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-17
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-segment-routing-ext-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-ls-segment-routing-ext-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 22 Mar 2021 06:45:58 +0000

Hi All,

This update to the BGP-LS SR draft (that was sitting in the RFC-editor Q due to misref) was required to the recent changes in the https://datatracker.ietf.org/doc/html/draft-ietf-lsr-ospf-prefix-originator-09 that was the missing reference as part of the AD review.

It updates the references to the Source Router Identifier TLV for OSPF and introduces a new TLV for the Source OSPF Router-ID TLV to cover the new TLV introduced by draft-ietf-lsr-ospf-prefix-originator.

Thanks,
Ketan (on behalf of co-authors)

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of [email-masked]
Sent: 22 March 2021 12:10
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-bgp-ls-segment-routing-ext-17.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr