Subject: [Idr] Adoption Call on DT document (draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

From: "Susan Hares" <[email-masked]>
Date: Wed, 10 Mar 2021 13:03:32 -0500

Greetings: 

This is an adoption/feedback call for the DT team document:

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-autoconf-considerations/

This call for comments will run for 3 weeks. 

In your feedback please let us know: 

1) do you think this represents a good set of requirements for bgp autoconf
protocol in the data center? 

2) Do you think the document should remove any requirements or add an
requirements?  

3) Do you think the review of the protocols should be moved to another
document? 

4) Should a IDR DT create the requirements for non-Data Center deployments
prior to starting work on a BGP auto-configuration protocol? If so, should a
DT start these requirements in parallel? 

Cheers, Sue Hares

---

From: Randy Bush <[email-masked]>
Date: Wed, 10 Mar 2021 10:10:43 -0800

sue,

i repeat in case ...

the document should be, as originally, a survey of the different
alternative architectural alternatives at different layers.

the recently added feature laundry list should be a separate document.

randy

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 11 Mar 2021 00:20:43 +0100

I must say I fully agree with Randy here.

I do not really understand the derailment ....  nor I think it was the
original point of DT to perform layout of the single rails
the autodiscovery proposals MUST be bounded to or adhere to.  Or maybe it
was and some just did not get it :)

Cheers,
R.

On Wed, Mar 10, 2021 at 7:10 PM Randy Bush <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 16 Mar 2021 11:30:56 +0000

As a contributor, I support WG adoption.

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Wednesday, March 10, 2021 at 1:04 PM
To: IDR List <[email-masked]>
Subject: [Idr] Adoption Call on DT document (draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

Greetings:

  1.  do you think this represents a good set of requirements for bgp autoconf protocol in the data center?
Yes

  1.  Do you think the document should remove any requirements or add an requirements?

Not at this time.

  1.  Do you think the review of the protocols should be moved to another document?

I don’t think it is necessary but wouldn’t be strongly opposed.

  1.  Should a IDR DT create the requirements for non-Data Center deployments prior to starting work on a BGP auto-configuration protocol? If so, should a DT start these requirements in parallel?

I believe it makes sense to use the same DT.

Thanks,
Acee

Cheers, Sue Hares

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 16 Mar 2021 13:20:33 +0100

Hi Sue,

Ad 1-3)

As a contributor I do not support progressing the document in the
current form.

In my opinion set of requirements is too broad to what is required to
provide a simple discovery of BGP peer candidate. IMO single bit in LLDP
message or as proposed either BGP OPEN to link multicast or sort message to
link multicast should suffice.

Number of requirements already duplicate what is exchanged between peers in
BGP OPEN.

Is a BGP speaker capable of autodiscovery supposed now to filter peers with
the same BGP_ID ?

Why are we stating something against RFC5082 which says:

   "If, however, dynamic negotiation of GTSM support
   is necessary, protocol messages used for such negotiation
*MUST be   authenticated* using other security mechanisms to prevent DoS
attacks.

Why do we need to send a device role and what RFC defines the device role ?
You can't put requirements in place something which is today
nowhere deployed.

Support AFI/SAFI is already covered by BGP Capability negotiation. Do we
need to repeat those procedures here ?

Requirements list IPSec as one of transport security options .. and now
what if peer exchange such requirement ? Is this optional for a candidate
peer or mandatory ? What if list of transport security requirements is
exchanged ? Is there no requirement for preference order ?

Ad 4)

We have been working in IDR for many years on
https://tools.ietf.org/html/draft-raszuk-idr-bgp-auto-discovery-06

So now perhaps more valuable would be to review this work instead of
creating a requirements document ?

Many thx,
Robert

On Wed, Mar 10, 2021 at 7:03 PM Susan Hares <[email-masked]> wrote:

> 1) do you think this represents a good set of requirements for bgp
> autoconf protocol in the data center?
>
>
>
> prior to starting work on a BGP auto-configuration protocol? If so, should
> a DT start these requirements in parallel?
>
>
>
> Cheers, Sue Hares
>
>

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 16 Mar 2021 15:59:56 -0400

Robert,

I will be covering the state requirements for autoconfiguration in a
separate thread.  However, I do wish to note:

On Tue, Mar 16, 2021 at 01:20:33PM +0100, Robert Raszuk wrote:
[...]
> Is a BGP speaker capable of autodiscovery supposed now to filter peers with
[...]
> need to repeat those procedures here ?
[...]

> https://tools.ietf.org/html/draft-raszuk-idr-bgp-auto-discovery-06

This draft includes the elements above you're complaining about.

> creating a requirements document ?

Appendix A of the autoconf considerations draft contains comparisons and
critique on the various proposals sent to date.

-- Jeff

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 16 Mar 2021 21:12:23 +0100

Jeff,

And that is one of the other points I forgot to mention.

The agreed scope of the work was about automation of BGP
session establishment procedure in DC/MSDC env.

Throwing in (even into appendix) the reference to WAN/IXP BGP discovery
seems not to be even within the agreed scope.

Many thx,
R.

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 16 Mar 2021 17:05:15 -0400

> seems not to be even within the agreed scope.

: 2.  Design Team Determinations
: 
: 2.1.  Problem Scope
: 
:    The current target environment is BGP as used for the underlay
:    routing protocol in data center networks.  Other scenarios may be
:    considered as part of the analysis for this work, but work on those
:    environments will be deferred to other efforts.

-- Jeff

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 17 Mar 2021 16:44:26 +0800

Hi, Susan:

Supports it adoption.

My considerations for your questions are the followings:

Best Regards

Aijun Wang

China Telecom

From: [email-masked] <[email-masked]> On Behalf Of Susan Hares
Sent: Thursday, March 11, 2021 2:04 AM
To: [email-masked]
Subject: [Idr] Adoption Call on DT document
(draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

Greetings: 

[WAJ] Yes, I think it analyses clearly the process and necessary stages of
bgp autoconf.

[WAJ] The consideration for device role should be removed. The reasons are
the followings:

1） There is no standard definition of the device role.

2） BGP works in peer to peer model. 

3） BGP within the datacenter is mainly used for the underlay network
connection. If there is no IGP, every device within the DC should be
connected via BGP.

[WAJ] Should consider adding the “Passive Interface” concept on the
devices, to filter the sending of BGP autoconf packet to the customer facing
interfaces.

[WAJ] Should consider the definition of IP address space and AS number
space, from which each device can get its own assignment automatically
without conflict. 

[WAJ] Leave them in the current Appendix part can help the user to have a
quick review of the current approaches in different layers.

[WAJ] It seems the necessary for the non-Data center deployment is not
emergent. 

Cheers, Sue Hares

---

From: "Majumdar, Kausik" <[email-masked]>
Date: Wed, 17 Mar 2021 18:09:57 +0000

As a contributor, I also support the WG adoption.

My comments to the below questions along the line with Acce.

Yes

I don’t see that we need to remove any requirements at this time what we have reviewed and captured. But definitely, we can review one more based on the input from others.

              To me, it is easier to have it in the same document, but if others prefer to move in another document I am fine.

              I think we should.  Yes, DT should start on these requirements.

Regards,
Kausik

From: Idr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Tuesday, March 16, 2021 4:31 AM
To: Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] Adoption Call on DT document (draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

As a contributor, I support WG adoption. 
External (acee=[email-masked]<mailto:acee=[email-masked]>)
  Report This Email<https://shared.outlook.inky.com/report?id=Y29tbXNjb3BlL2thdXNpay5tYWp1bWRhckBjb21tc2NvcGUuY29tL2E3YTA2NjJjMTY4NGU3MDU0YTAxYWQxNjc5Y2I0NmJmLzE2MTU4OTQyNzguNzc=#key=e9a0acc9b2cf7a49b85c827b1c721118>  FAQ<https://www.inky.com/banner-faq/>  Protection by INKY<https://www.inky.com>

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 10, 2021 at 1:04 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Adoption Call on DT document (draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

Greetings:

This is an adoption/feedback call for the DT team document:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-autoconf-considerations/<https://secure-web.cisco.com/1A0kHOz5A99Y7Y3RA3G77hJqKB9MBYdy14di4w9NnTD1Ojy-jew28bad9PgDoVnFYvQkbsJsmb3gx39vdoHc1dRWP5ewAe0wnOUDG1f1r_wTyXTrE22oiTF88O5z_W72fzrGUCb0KlR34qHzO_IVJR8eDc9QvIitnTIh7LB4RT4brJ_oZXOtCX6bxmvNCETc_hdPFXtgajNG7A3TtjRsUp1NRsqVsaL7idWeTo18nRIY5M4k7CDCzCPbgxvipvKTL55u8gTAwDPgbY_27UdhG6GuAOASHK0hiNxCXvVXg7iWbU2-Fes4VvoSz3s49my3H/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-bgp-autoconf-considerations%2F>

Not at this time.

Thanks,
Acee

Cheers, Sue Hares

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 17 Mar 2021 19:27:30 -0400

I support WG Adoption.

Few comments.

The BGP Autoconf draft for Data Centers is primarily  geared for BGP only
Data Center fabric per RFC 79

As the draft reference L3 discovery solutions from LSVR, can the scope also
apply to DC with IGP underlay or is this strictly for BGP underlay like
LSVR.  I see it’s out of scope but wanted to see if possible to make in
scope.

Yes

 No

 No

 I think both DC and Non DC can be done in parallel.

Kind Regards

Gyan

On Wed, Mar 17, 2021 at 2:10 PM Majumdar, Kausik <
[email-masked]> wrote:

> I don’t see that we need to remove any requirements at this time what we
> have reviewed and captured. But definitely, we can review one more based on
> the input from others.
>
>
>
>               To me, it is easier to have it in the same document, but if
> others prefer to move in another document I am fine.
>
>
>
>    1. Should a IDR DT create the requirements for non-Data Center
>    deployments prior to starting work on a BGP auto-configuration protocol? If
>    so, should a DT start these requirements in parallel?
>
>
>
> *From:* Idr <[email-masked]> *On Behalf Of * Acee Lindem (acee)
> *Sent:* Tuesday, March 16, 2021 4:31 AM
> *To:* Susan Hares <[email-masked]>; [email-masked]
> *Subject:* Re: [Idr] Adoption Call on DT document
> *From: *Idr <[email-masked]> on behalf of Susan Hares <
> [email-masked]>
> *Date: *Wednesday, March 10, 2021 at 1:04 PM
> *To: *IDR List <[email-masked]>
> *Subject: *[Idr] Adoption Call on DT document
> <https://secure-web.cisco.com/1A0kHOz5A99Y7Y3RA3G77hJqKB9MBYdy14di4w9NnTD1Ojy-jew28bad9PgDoVnFYvQkbsJsmb3gx39vdoHc1dRWP5ewAe0wnOUDG1f1r_wTyXTrE22oiTF88O5z_W72fzrGUCb0KlR34qHzO_IVJR8eDc9QvIitnTIh7LB4RT4brJ_oZXOtCX6bxmvNCETc_hdPFXtgajNG7A3TtjRsUp1NRsqVsaL7idWeTo18nRIY5M4k7CDCzCPbgxvipvKTL55u8gTAwDPgbY_27UdhG6GuAOASHK0hiNxCXvVXg7iWbU2-Fes4VvoSz3s49my3H/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-idr-bgp-autoconf-considerations%2F>
>
>
>
>    1. Should a IDR DT create the requirements for non-Data Center
>    deployments prior to starting work on a BGP auto-configuration protocol? If
>    so, should a DT start these requirements in parallel?
>
>
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 18 Mar 2021 01:46:43 +0000

Hi Sue,

As a design team member I support the adoption of this document.

Please see my replies to the questions inline:

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, March 11, 2021 2:04 AM
To: [email-masked]
Subject: [Idr] Adoption Call on DT document (draft-ietf-idr-bgp-autoconf-considerations-00.txt) [3/10/2021 to 3/31/2021]

Greetings:

1)      do you think this represents a good set of requirements for bgp autoconf protocol in the data center?

Yes.

2)      Do you think the document should remove any requirements or add an requirements?

None at current stage, while further discussion about which set of requirements are MUST and which set are optional may be helpful.

3)      Do you think the review of the protocols should be moved to another document?

The review of the existing proposals is another targeted output of the design team, at current stage it is convenient to have them in the same document for people to review. It may be split out as a separate document later based on WG consensus.

4)      Should a IDR DT create the requirements for non-Data Center deployments prior to starting work on a BGP auto-configuration protocol? If so, should a DT start these requirements in parallel?

This may depend on the requirement from the operators. Some discussion about non-DC scenarios already happened in the autoconf DT, thus if needed the discussion about non-DC case could continue there.

Best regards,
Jie

Cheers, Sue Hares