Subject: [Idr] [Editorial Errata Reported] RFC4271 (6498)

From: RFC Errata System <[email-masked]>
Date: Sat, 27 Mar 2021 13:16:17 -0700 (PDT)

The following errata report has been submitted for RFC4271,
"A Border Gateway Protocol 4 (BGP-4)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6498

--------------------------------------
Type: Editorial
Reported by: Graham Paasch <[email-masked]>

Section: 5.1.5

Original Text
-------------
LOCAL_PREF is a well-known attribute that SHALL be included in all UPDATE messages that a given BGP speaker sends to other internal peers. 

Corrected Text
--------------
LOCAL_PREF is a well-known discretionary attribute that SHALL be included in all UPDATE messages that a given BGP speaker sends to other internal peers. 

Notes
-----
It is unclear from the text to which of the four path attribute categories LOCAL_PREF belongs. There was even submitted an errata to create a fifth category for this attribute, but it is clear from the definition of the categories, that this attribute is well known discretionary. All routers must be capable of sending or receiving the LOCAL_PREF attribute, however it is up to a routers discretion whether to include that attribute in an UPDATE message.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4271 (draft-ietf-idr-bgp4-26)
--------------------------------------
Title               : A Border Gateway Protocol 4 (BGP-4)
Publication Date    : January 2006
Author(s)           : Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed.
Category            : DRAFT STANDARD
Source              : Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 27 Mar 2021 18:58:43 -0400

"SHALL" is the same as "MUST" or "REQUIRED" [RFC2119]. So if it MUST
be included, how can inclusion be discretionary?

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Sat, Mar 27, 2021 at 6:39 PM RFC Errata System
<[email-masked]> wrote:
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Alvaro Retana <[email-masked]>
Date: Sat, 27 Mar 2021 18:16:53 -0500

Hi!

rfc4271 defines “discretionary” as simply the fact that the attribute may
or may not be included in all UPDATE messages.  From that point of view,
the type is well-known discretionary.

However, using “discretionary” with a required action can also cause
confusion.

I think the report is valid — but I also don’t think it should be marked as
Verified.  Instead, it should be marked as “Hold for Document Update”.
Does anyone object to this classification?

Thanks!

Alvaro.

From: Donald Eastlake <[email-masked]> <[email-masked]>
Date: March 27, 2021 at 6:58:43 PM
To: RFC Errata System <[email-masked]>
<[email-masked]>
CC: Yakov Rekhter <[email-masked]> <[email-masked]>, Tony Li
<[email-masked]> <[email-masked]>, [email-masked] <[email-masked]>
<[email-masked]>, Alvaro Retana <[email-masked]>
<[email-masked]>, John G. Scudder <[email-masked]>
<[email-masked]>, Martin Vigoureux <[email-masked]>
<[email-masked]>, Jeffrey Haas <[email-masked]> <[email-masked]>,
Keyur Patel <[email-masked]> <[email-masked]>, Susan Hares
<[email-masked]> <[email-masked]>, idr@ietf. org <[email-masked]> <[email-masked]>,
[email-masked] <[email-masked]> <[email-masked]>
Subject:  Re: [Idr] [Editorial Errata Reported] RFC4271 (6498)

> LOCAL_PREF is a well-known attribute that SHALL be included in all UPDATE
> messages that a given BGP speaker sends to other internal peers.
>
> Corrected Text
> --------------
> LOCAL_PREF is a well-known discretionary attribute that SHALL be included
> in all UPDATE messages that a given BGP speaker sends to other internal
> peers.
>
> Notes
> -----
> It is unclear from the text to which of the four path attribute categories
> LOCAL_PREF belongs. There was even submitted an errata to create a fifth
> category for this attribute, but it is clear from the definition of the
> categories, that this attribute is well known discretionary. All routers
> must be capable of sending or receiving the LOCAL_PREF attribute, however
> it is up to a routers discretion whether to include that attribute in an
> UPDATE message.
>
> Instructions:
> -------------

---

From: John Scudder <[email-masked]>
Date: Sun, 28 Mar 2021 17:05:37 +0000

(Trimmed incredibly long cc list)

On Mar 27, 2021, at 7:16 PM, Alvaro Retana <[email-masked]<mailto:[email-masked]>> wrote:

I think the report is valid — but I also don’t think it should be marked as Verified.  Instead, it should be marked as “Hold for Document Update”.  Does anyone object to this classification?

That seems like the least problematic way to deal with it. What this really points to is something we’ve known a long time, though — the terminology 4271 chose doesn’t properly capture the way these attributes are defined and used. So, document update indeed: whenever 4271 is revised, the well-known/discretionary mess (and so on) needs to be cleaned up.

—John