Subject: [Idr] On the Calculation of Entropy Labels

From: <[email-masked]>
Date: Mon, 15 Mar 2021 19:08:21 +0800 (CST)

Hi Robin,

Thanks for your comments on draft-zhou-idr-bgp-srmpls-elp at the IDR meeting last week.

You mentioned that there's a work about calculating both the vlaue and the position of the entropy labels using the controller.

(Sorry I haven't find the draft, I would appreciate it if you could offer the name of the draft.)

Since the entropy label value for each flow may be different, the control needs to calculate the value and the position of ELs per flow, and needs to maintain the state of the label stack per flow.

The solution introduced in draft-zhou-idr-bgp-srmpls-elp is that the controller calculates the position of the ELs for each path. The method for calculating the EL value is unchanged, the ingress router computes a hash based on several fields from a given packet. 

The calculation and state in the controller is per path. This method is applicable to a network with many flows and ingress nodes.

Regards,

Yao

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 15 Mar 2021 15:36:29 -0700

Yao,

Position of entropy label in SR stack is discussed in RFC8662

Cheers,
Jeff
On Mar 15, 2021, 4:09 AM -0700, [email-masked], wrote:
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Lizhenbin <[email-masked]>
Date: Mon, 22 Mar 2021 03:30:02 +0000

Hi Yao,
Sorry for the late reply. The following information is for your reference:
1. The draft is as follows. In the presentation, we proposed the example to calculate the entropy label for the specific prefix and download the entropy label and the VPN label together for better load sharing in the network.
https://tools.ietf.org/html/draft-li-idr-mpls-path-programming-04

2. After the IDR session om which you did the presentation, I thought there is the difference between the idea in the draft and the draft in your draft. The draft is calculate the entropy label for the PREFIX and the idea is to calculate the entropy label position for the SR path.

3. I am a little doubtful about the benefit of calculating the position only. I am not sure about how will the position is calculated. If the fixed position is calculated for the SR path, but the traffic flows with different destination address will be carried by the SR path and the entropy labels is randomly calculated, can the load sharing be improved?

Best Regards,
Robin

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, March 15, 2021 7:08 PM
To: [email-masked]; Lizhenbin <[email-masked]>
Subject: [Idr] On the Calculation of Entropy Labels

Hi Robin,

Regards,

Yao