Subject: [ietf-dkim] San Francisco

From: "J.D. Falk" <[email-masked]>
Date: Fri, 30 Jan 2009 09:28:05 -0700

Will this WG be meeting in SF?  I'd assumed not, but with all this 
discussion recently, it could be very useful....

-- 
J.D. Falk
Return Path Inc
http://www.returnpath.net/
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Suresh Ramasubramanian <[email-masked]>
Date: Fri, 30 Jan 2009 22:07:49 +0530

> discussion recently, it could be very useful....

If there's no space on the agenda we could figure out a working lunch
of some sort?
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "MH Michael Hammer (5304)" <[email-masked]>
Date: Fri, 30 Jan 2009 11:45:49 -0500

> -----Original Message-----
> From: [email-masked] [mailto:ietf-dkim-
> [email-masked]] On Behalf Of Suresh Ramasubramanian
> Sent: Friday, January 30, 2009 11:38 AM
> To: J.D. Falk
> Cc: DKIM IETF WG
> Subject: Re: [ietf-dkim] San Francisco
> 

+1

I know not everyone will be in SF but a face-to-face even if it's a
partial group might be useful.

---

From: Al Iverson <[email-masked]>
Date: Fri, 30 Jan 2009 10:47:31 -0600

> If there's no space on the agenda we could figure out a working lunch

I'm interested. Also, I wish somebody smarter than me would take a
shot at a PPT for dummies like me, showing a few examples of how a
receiver would like to use DKIM.

Al

-- 
Al Iverson on Spam and Deliverability, see http://www.spamresource.com
News, stats, info, and commentary on blacklists: http://www.dnsbl.com
My personal website: http://www.aliverson.com   --   Chicago, IL, USA
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 30 Jan 2009 10:52:19 -0600

> discussion recently, it could be very useful....

Unfortunately:

    January 19, 2009 Monday (Extended to January 21, 2009) - Cutoff date for 
requests to schedule Working Group meetings

We missed the dealine by almost 2 weeks.  We might ask for an exception, I 
suppose.  I have no idea whether they are ever granted.

But one way or the other, yes, it does look like we should find a way to meet.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 30 Jan 2009 10:55:58 -0600

Al Iverson wrote:
>      Also, I wish somebody smarter than me would take a

Can you describe particular usage examples you would like to see explained?

I'm not asking you to give the details, but rather describe what the details 
should explain.

d/
-- 

   Dave Crocker

---

From: Al Iverson <[email-masked]>
Date: Fri, 30 Jan 2009 11:11:31 -0600

> I'm not asking you to give the details, but rather describe what the details

Off the top of my head...
.
Use cases for i= and d=, and what an ISP would care to do with that
data, if they could do anything they wanted to.

What the restrictions are on i= and d= (and other fields/configuration
options I might not be thinking of). What has to match the PRA, if
anything, what can contain a sub-level identifier, etc.

Best,
Al

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 30 Jan 2009 11:26:45 -0600

Perhaps it can help to turn this around, and make the technical details be 
derivative of functional need.

That is:  What kinds of questions and answers would signer and assessor like to 
share, which DKIM could help with?  What kinds of roles and analyses would be 
good to facilitate?

d/

-- 

   Dave Crocker

---

From: Al Iverson <[email-masked]>
Date: Fri, 30 Jan 2009 11:32:29 -0600

Not bad questions, but ones that I don't really have answers for. I
could tell you what I *want* out of authentication, but that leads us
to things like *cough* disposition instructions for bad mail and
things like ADSP. Instead of going there, I'd like to learn more about
how what is more or less nearing consensus, and how it is actually
desired to be used by ISPs.

Al

On Fri, Jan 30, 2009 at 11:26 AM, Dave CROCKER <[email-masked]> wrote:
> That is:  What kinds of questions and answers would signer and assessor like
> to share, which DKIM could help with?  What kinds of roles and analyses
> would be good to facilitate?
>
> d/
>
> Al Iverson wrote:
>>

---

From: "J.D. Falk" <[email-masked]>
Date: Fri, 30 Jan 2009 11:26:27 -0700

> desired to be used by ISPs.

The consensus amongst ISPs is to wait and see what the mail coming in looks 
like, and then develop reputation algorithms based on that.

Way too much of the email industry has been waiting for years for someone 
else to tell them what to do.  We need more real-world experimentation.

---

From: "J.D. Falk" <[email-masked]>
Date: Fri, 30 Jan 2009 11:29:14 -0700

Dave CROCKER wrote:

> We missed the dealine by almost 2 weeks.  We might ask for an exception, 
> I suppose.  I have no idea whether they are ever granted.

Yeah, I thought that might be the case.

> But one way or the other, yes, it does look like we should find a way to 

I was thinking I wouldn't attend this meeting, but if there's a DKIM WG 
discussion (even a semi-informal one) then I can justify the expense.

---

From: Suresh Ramasubramanian <[email-masked]>
Date: Sat, 31 Jan 2009 00:17:32 +0530

>> things like ADSP. Instead of going there, I'd like to learn more about

Well .. my daughter wants to bring every mutt she sees on the streets
home. My wife has something different to say.

Rather similar situation here, I guess?  :)

> like, and then develop reputation algorithms based on that.

The rough consensus seems to be to look at d= and let the sender
figure out what they want to do with the i= they publish

--srs

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 30 Jan 2009 13:15:41 -0600

Barry has put a request into the ietf scheduling tool, asking for an official 
meeting slot.  Even with that, we might want to plan, now, for a lunch get-together.

d/

d/

-- 

   Dave Crocker

---

From: Ellen Siegel <[email-masked]>
Date: Fri, 30 Jan 2009 16:16:53 -0500

I know we may not have much control over what we get out of the tool, but at
least for the lunch I'd vote for something in the earlier half of the week
if at all possible (I have a conflict on Thursday/Friday).

Ellen

---

From: <[email-masked]>
Date: Fri, 30 Jan 2009 14:39:22 -0500

I would (using the singular I) ignore any i/d comparisons or usage as a valid signature represents a
dkim=passed
part of any rules engine. This may be coupled with a subset of adsp requests to drop non signed or malformed signatures. Otherwise its just one cog in a rule based asav system.
thanks,

Bill Oxley
Messaging Engineer
Cox Communications, Inc
404-847-6397

-----Original Message-----
From: [email-masked] on behalf of Al Iverson
Sent: Fri 1/30/2009 12:32 PM
To: [email-masked]
Cc: DKIM IETF WG
Subject: Re: [ietf-dkim] dkim usage examples

Al

---

From: DKIM Chair <[email-masked]>
Date: Fri, 30 Jan 2009 13:49:14 -0500

> I suppose.  I have no idea whether they are ever granted.

I asked Marcia nicely, and after the flames subsided[1], she said OK, submit the 
request and she'd see what she could do.

So I put in a request for a two-hour slot.  You'll know more, when I know more.

Barry

--
Barry Leiba, DKIM working group chair  ([email-masked])

[1] No, no, not really.  Marcia was, as always, very calm and pleasant.