Subject: Re: [Ietf-languages] Forms for July 2017 changes to ISO 15924

From: Michael Everson <[email-masked]>
Date: Tue, 1 Aug 2017 12:25:00 +0100

On 31 Jul 2017, at 18:16, Peter Constable <[email-masked]> wrote:
> 
> I was not asking "what are they doing here". My only concern is that, if we are providing a phonetic transcription of a language name, that it should be the autoglossonym as pronounced by a native speaker.

ISO 15924 specifies codes for the representation of the names of scripts. 

Michael Everson

---

From: Michael Everson <[email-masked]>
Date: Tue, 1 Aug 2017 13:38:00 +0100

On 31 Jul 2017, at 17:53, Mark Davis ☕️ <[email-masked]> wrote:
> 
> Adding a name in a core language to help distinguish an entry from others is good.
> 
> But is "na²¹ɕi³³ to³³ba²¹" really the way the script is really is spelled in a native language using that script?

No; they write https://en.wikipedia.org/wiki/Dongba_symbols#/media/File:Naxi-dongba.png

The autonyms for the script itself are (in Rock’s transcription, which is a bit difficult to match up to more modern transcriptions) ²ss ³dgyu ‘wood record’ and ²lv ³dgyu ‘stone record’, but the “name” of the scripts as they are known generally are Naxi Geba and Naxi Dongba. But those are Pinyin romanizations, based on Han phonology, so the Naxi romanizations were given. 

> On 31 Jul 2017, at 19:15, Mark Davis ☕️ <[email-masked]> wrote:
> 
> The purpose in the registry of a name for ascript is to enable people to distinguish it from other scripts. So the question is whether any significant community would be unable to distinguish Naxi Geba from other scripts, but would be able if "na²¹ɕi³³ to³³ba²¹" were another description.

The registry specifies standard codes for the representation of the names of scripts. Sometimes scripts have more than one name, or there is more than one way of writing the name. Often scripts are not widely known, so it is handy tobe able to say that "yes, this name is represented by that code element”.

> On 1 Aug 2017, at 08:59, Hugh Paterson <[email-masked]> wrote:
> 
> My impression of Naxi, having only met one linguist researcher who has worked in those communites, is that the communities use a logographic script, but couldn't that be determined for sure by consulting the ISO script to see what is the code range of unicode characters are refernced in the script?

Neither Naxi Dongba nor Naxi Geba is yet encoded. Andrew West and I are working with Chinese colleagues to get somewhere with that. It isn’t easy. 

Michael Everson

---

From: Peter Constable <[email-masked]>
Date: Tue, 1 Aug 2017 16:41:46 +0000

Duh! In this case, the script is associated with a particular language. So, script name as pronounced by the primary community.

Peter

-----Original Message-----
From: Ietf-languages [mailto:[email-masked]] On Behalf Of Michael Everson
Sent: Tuesday, August 1, 2017 4:25 AM
To: ietflang IETF Languages Discussion <[email-masked]>
Subject: Re: [Ietf-languages] Forms for July 2017 changes to ISO 15924

Michael Everson
_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7Cpetercon%40microsoft.com%7C75ca3ac7c9014286ed0e08d4d8d0e634%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636371839110710744%7CUnknown%7CVW5rbm93bnx7IlYiOiIwLjAuMDAwMCIsIlAiOiJXaW4zMiIsIkFOIjoiT3RoZXIifQ%3D%3D%7C-1&sdata=m72ul9kwq24e6fo8%2BReBW7ruB9OvqdzQ8VtzTSrD2b0%3D&reserved=0

---

From: Mark Davis ☕️ <[email-masked]>
Date: Fri, 4 Aug 2017 09:20:02 -0700

Formally, yes.

In reality, clearly has *never* been the case. ISO will not encode two
different codes for the names "Arabische Schrift" and "Arab Script".

In some sense I don't care. But in another sense, encoding names that do
not help the users of the registry distinguish between scripts just looks
like showing off.

Mark

(https://twitter.com/mark_e_davis)

On Tue, Aug 1, 2017 at 4:25 AM, Michael Everson <[email-masked]>
wrote:

> > I was not asking "what are they doing here". My only concern is that, if
> we are providing a phonetic transcription of a language name, that it
> should be the autoglossonym as pronounced by a native speaker.
>
> https://www.ietf.org/mailman/listinfo/ietf-languages
>